aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-05 14:55:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-05 14:55:37 +0000
commit40ba6356cccfc94f8fe24e66ab79393169e9df04 (patch)
tree7b9debc1a8b9e64f4c8dc9ba6b11895fdf60ab34 /shells
parent8f0c5e9c316745c109b29494174e08f4087e00f4 (diff)
downloadports-40ba6356cccfc94f8fe24e66ab79393169e9df04.tar.gz
ports-40ba6356cccfc94f8fe24e66ab79393169e9df04.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/bash-completion-classic/Makefile1
-rw-r--r--shells/bash-completion-classic/files/patch-aa22
-rw-r--r--shells/bash-completion/Makefile1
-rw-r--r--shells/bash-completion/files/patch-aa22
4 files changed, 42 insertions, 4 deletions
diff --git a/shells/bash-completion-classic/Makefile b/shells/bash-completion-classic/Makefile
index 8eb721594e3c..1efb5a006ba5 100644
--- a/shells/bash-completion-classic/Makefile
+++ b/shells/bash-completion-classic/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bash-completion
PORTVERSION= 20040331
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://www.caliban.org/files/bash/
diff --git a/shells/bash-completion-classic/files/patch-aa b/shells/bash-completion-classic/files/patch-aa
index 5eace9dd220f..001c5448b350 100644
--- a/shells/bash-completion-classic/files/patch-aa
+++ b/shells/bash-completion-classic/files/patch-aa
@@ -1,5 +1,5 @@
---- bash_completion.orig Wed Feb 18 09:10:18 2004
-+++ bash_completion Wed Feb 18 09:11:01 2004
+--- bash_completion.orig Wed Mar 31 19:45:32 2004
++++ bash_completion Sat Jun 5 16:53:42 2004
@@ -31,14 +31,14 @@
if [ -n "${FUNCNAME:-}" ]; then
# we're being sourced from within a function, so we can't use
@@ -19,3 +19,21 @@
2>/dev/null
fi
+@@ -1056,7 +1056,7 @@
+ else
+ len=${#cur}
+ idx=0
+- for pval in $( /usr/sbin/postconf -m ); do
++ for pval in $( postconf -m ); do
+ if [[ "$cur" == "${pval:0:$len}" ]]; then
+ COMPREPLY[$idx]="$pval:"
+ idx=$(($idx+1))
+@@ -1132,7 +1132,7 @@
+ fi
+ len=${#cur}
+ idx=0
+- for pval in $( /usr/sbin/postconf | cut -d ' ' -f 1 ); do
++ for pval in $( postconf | cut -d ' ' -f 1 ); do
+ if [[ "$cur" == "${pval:0:$len}" ]]; then
+ COMPREPLY[$idx]="$pval$eqext"
+ idx=$(($idx+1))
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 8eb721594e3c..1efb5a006ba5 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bash-completion
PORTVERSION= 20040331
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://www.caliban.org/files/bash/
diff --git a/shells/bash-completion/files/patch-aa b/shells/bash-completion/files/patch-aa
index 5eace9dd220f..001c5448b350 100644
--- a/shells/bash-completion/files/patch-aa
+++ b/shells/bash-completion/files/patch-aa
@@ -1,5 +1,5 @@
---- bash_completion.orig Wed Feb 18 09:10:18 2004
-+++ bash_completion Wed Feb 18 09:11:01 2004
+--- bash_completion.orig Wed Mar 31 19:45:32 2004
++++ bash_completion Sat Jun 5 16:53:42 2004
@@ -31,14 +31,14 @@
if [ -n "${FUNCNAME:-}" ]; then
# we're being sourced from within a function, so we can't use
@@ -19,3 +19,21 @@
2>/dev/null
fi
+@@ -1056,7 +1056,7 @@
+ else
+ len=${#cur}
+ idx=0
+- for pval in $( /usr/sbin/postconf -m ); do
++ for pval in $( postconf -m ); do
+ if [[ "$cur" == "${pval:0:$len}" ]]; then
+ COMPREPLY[$idx]="$pval:"
+ idx=$(($idx+1))
+@@ -1132,7 +1132,7 @@
+ fi
+ len=${#cur}
+ idx=0
+- for pval in $( /usr/sbin/postconf | cut -d ' ' -f 1 ); do
++ for pval in $( postconf | cut -d ' ' -f 1 ); do
+ if [[ "$cur" == "${pval:0:$len}" ]]; then
+ COMPREPLY[$idx]="$pval$eqext"
+ idx=$(($idx+1))