aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2010-09-20 23:09:06 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2010-09-20 23:09:06 +0000
commit0cf84630c9836a9ee9d3110927c998931d4c3a6d (patch)
treecfae1592623ad1440818670cf25fde5d38db5277 /shells
parent1512448ae3e703d35a640951f4c3513cb708dd1d (diff)
downloadports-0cf84630c9836a9ee9d3110927c998931d4c3a6d.tar.gz
ports-0cf84630c9836a9ee9d3110927c998931d4c3a6d.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/bash-completion/Makefile9
-rw-r--r--shells/bash-completion/pkg-plist2
2 files changed, 4 insertions, 7 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index ad0cec8ca4d6..80521ad6dfb4 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -19,16 +19,14 @@ USE_BZIP2= yes
SUB_FILES= pkg-message
RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
+CONFLICTS+= bash-completion-classic-[0-9]*
GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-AMD64_REMOVE_RSYNC= /contrib\/rsync/d
-PLIST_SUB+= NOAMD64="@comment "
-.else
-PLIST_SUB+= NOAMD64=""
+BROKEN= Hostname completion on amd64 causes bash to freeze. Use shells/bash-completion-classic instead
.endif
post-patch:
@@ -41,8 +39,7 @@ post-patch:
s|/usr/lib\(/aspell\)|${PREFIX}/share\1|g; \
s|/usr/share/info|&:${PREFIX}/info|g; \
s|\$$(sysconfdir)/profile.d|${PREFIX}/bin|g; \
- s|\(FLAC\)|\1\|flv\|FLV|; \
- ${AMD64_REMOVE_RSYNC}' \
+ s|\(FLAC\)|\1\|flv\|FLV|' \
${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in ${WRKSRC}/contrib/*
post-install:
diff --git a/shells/bash-completion/pkg-plist b/shells/bash-completion/pkg-plist
index da9385be9452..5fc2329a0750 100644
--- a/shells/bash-completion/pkg-plist
+++ b/shells/bash-completion/pkg-plist
@@ -124,7 +124,7 @@ etc/bash_completion.d/rpcdebug
etc/bash_completion.d/rpm
etc/bash_completion.d/rpmcheck
etc/bash_completion.d/rrdtool
-%%NOAMD64%%etc/bash_completion.d/rsync
+etc/bash_completion.d/rsync
etc/bash_completion.d/rtcwake
etc/bash_completion.d/samba
etc/bash_completion.d/sbcl