aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-12-04 23:56:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-12-04 23:56:24 +0000
commita0e5f7ed9245406aeda61d7d87338e19428ff217 (patch)
tree0e911a4303ce73b925e9cde86b3b8391302e2acd /shells
parentbc58fccd2991990f0eddc46ea0ef8adb2a1c150e (diff)
downloadports-a0e5f7ed9245406aeda61d7d87338e19428ff217.tar.gz
ports-a0e5f7ed9245406aeda61d7d87338e19428ff217.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/scponly/Makefile25
-rw-r--r--shells/scponly/distinfo4
-rw-r--r--shells/scponly/files/patch-aa14
3 files changed, 24 insertions, 19 deletions
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
index 577735723bb2..05010ad73d7f 100644
--- a/shells/scponly/Makefile
+++ b/shells/scponly/Makefile
@@ -15,6 +15,11 @@
#
# Core funcionality:
#
+# SCPONLY_DEFAULT_CHDIR=DIR
+# default: undefined
+# example: public_html
+# define if you want to make users `cd' to this directory after authentication
+#
# WITHOUT_SCPONLY_WILDCARDS
# default: undefined
# define if you want to disable wildcard processing.
@@ -39,6 +44,10 @@
# default: undefined
# define if you want to enable rsync compatibility.
#
+# WITH_SCPONLY_SVN
+# default: undefined
+# define if you want to enable subversion compatibility.
+#
# WITH_SCPONLY_UNISON
# default: undefined
# define if you want to enable unison compatibility.
@@ -53,7 +62,7 @@
# to be installed.
PORTNAME= scponly
-PORTVERSION= 3.11
+PORTVERSION= 4.0
PORTREVISION= 0
CATEGORIES= shells
MASTER_SITES= http://www.sublimation.org/scponly/
@@ -69,6 +78,10 @@ PLIST_SUB+= SCPONLY_CHROOT="@comment "
.include <bsd.port.pre.mk>
+.if defined(SCPONLY_DEFAULT_CHDIR) && !empty(SCPONLY_DEFAULT_CHDIR)
+CONFIGURE_ARGS+=--with-default-chdir=${SCPONLY_DEFAULT_CHDIR}
+.endif
+
.if defined(WITHOUT_SCPONLY_WILDCARDS)
CONFIGURE_ARGS+=--disable-wildcards
.endif
@@ -91,11 +104,17 @@ CONFIGURE_ARGS+=--enable-chrooted-binary
.endif
.if defined(WITH_SCPONLY_RSYNC)
-BUILD_DEPENDS= rsync:${PORTSDIR}/net/rsync
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS+= rsync:${PORTSDIR}/net/rsync
+RUN_DEPENDS+= ${BUILD_DEPENDS}
CONFIGURE_ARGS+=--enable-rsync-compat
.endif
+.if defined(WITH_SCPONLY_SVN)
+BUILD_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+CONFIGURE_ARGS+=--enable-svn-compat
+.endif
+
.if defined(WITH_SCPONLY_UNISON)
BUILD_DEPENDS+= unison:${PORTSDIR}/net/unison
RUN_DEPENDS+= ${BUILD_DEPENDS}
diff --git a/shells/scponly/distinfo b/shells/scponly/distinfo
index 97dcc117c9f2..e345c5a271b0 100644
--- a/shells/scponly/distinfo
+++ b/shells/scponly/distinfo
@@ -1,2 +1,2 @@
-MD5 (scponly-3.11.tgz) = cdbbc570c2bf3cad33ecf66d0af41372
-SIZE (scponly-3.11.tgz) = 83767
+MD5 (scponly-4.0.tgz) = 1706732945996865ed0cccd440b64fc1
+SIZE (scponly-4.0.tgz) = 85053
diff --git a/shells/scponly/files/patch-aa b/shells/scponly/files/patch-aa
deleted file mode 100644
index 82fbc17fc470..000000000000
--- a/shells/scponly/files/patch-aa
+++ /dev/null
@@ -1,14 +0,0 @@
---- scponly.c.orig Mon Mar 22 14:30:38 2004
-+++ scponly.c Sat Jul 17 19:43:04 2004
-@@ -442,9 +442,9 @@
- (-1 == asprintf( &env[0], "HOME=%s", homedir)))
- {
- syslog(LOG_ERR, "could not set HOME environment variable(%s))", logstamp());
-- exit(EXIT_FAIL);
-+ exit(EXIT_FAILURE);
- }
-- if (debug)
-+ if (debuglevel)
- syslog(LOG_DEBUG, "set HOME environment variable to %s (%s))", env[0], logstamp());
- #endif
-