aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2011-04-06 17:47:52 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2011-04-06 17:47:52 +0000
commitbf7ad139d5ae39e53ab4ea23c315852a0bec44e6 (patch)
tree00462ea7c6588bde232f27878e9f4b4ba7f0c509 /shells
parent42d651738471ea348da32977191945d7c1bf8032 (diff)
downloadports-bf7ad139d5ae39e53ab4ea23c315852a0bec44e6.tar.gz
ports-bf7ad139d5ae39e53ab4ea23c315852a0bec44e6.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile5
-rw-r--r--shells/bash/options3
2 files changed, 7 insertions, 1 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 40505bdd7926..6a8fd5348672 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -104,6 +104,11 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/doc/bash.1
+.if defined(WITH_SYSLOG)
+ @${REINPLACE_CMD} \
+ -e "s|/\*.*#define SYSLOG_HISTORY .*\*/|#define SYSLOG_HISTORY|g" \
+ ${WRKSRC}/config-top.h
+.endif
.if defined(WITHOUT_NLS)
@${REINPLACE_CMD} -e "s|@LIBICONV@||g" ${WRKSRC}/Makefile.in
.endif
diff --git a/shells/bash/options b/shells/bash/options
index 5fb109a83dd5..e470ed66b4cd 100644
--- a/shells/bash/options
+++ b/shells/bash/options
@@ -3,4 +3,5 @@ OPTIONS= IMPLICITCD "Use directory name alone to cd into it" on \
HELP "Install the help files" on \
INST_READL "Use readline from base, otherwise bash's" on \
NLS "National Language Support" on \
- STATIC_BASH "Compile without shared libs" off
+ STATIC_BASH "Compile without shared libs" off \
+ SYSLOG "Compile with syslog support" off