aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-02-13 09:46:26 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-02-13 09:46:26 +0000
commit5294c83b62283d0478d586de99eaf59f3a81edb8 (patch)
tree6c6754b3d0c2acab5a8b9e657d4f684d89d668ce /shells
parent31467bc5f2d36d12d768b94a9b7b2b37f271178e (diff)
downloadports-5294c83b62283d0478d586de99eaf59f3a81edb8.tar.gz
ports-5294c83b62283d0478d586de99eaf59f3a81edb8.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/ksh93/Makefile15
-rw-r--r--shells/ksh93/pkg-plist8
2 files changed, 14 insertions, 9 deletions
diff --git a/shells/ksh93/Makefile b/shells/ksh93/Makefile
index 0c9d38d60436..d1686725e228 100644
--- a/shells/ksh93/Makefile
+++ b/shells/ksh93/Makefile
@@ -7,7 +7,6 @@
PORTNAME= ksh93
PORTVERSION= ${VERSION:S/-//g}
CATEGORIES= shells
-FETCH_ENV= HTTP_AUTH='basic:*:I accept www.opensource.org/licenses/cpl:.'
MASTER_SITES= http://www.research.att.com/~gsf/download/tgz/
DISTNAME= ${PORTNAME}-${VERSION}
DISTFILES= INIT.${VERSION}.tgz ast-ksh.${VERSION}.tgz
@@ -17,8 +16,9 @@ MAINTAINER= joe@zircon.seattle.wa.us
COMMENT= Official AT&T release of KornShell 93
VERSION= 2006-01-24
-RESTRICTED= "Source recipient must acknowledge license"
+RESTRICTED= Source recipient must acknowledge license
+FETCH_ENV= HTTP_AUTH='basic:*:I accept www.opensource.org/licenses/cpl:.'
FETCH_CMD= /usr/bin/fetch -Rr # see bin/76134
NO_WRKSUBDIR= yes
MAKE_ENV= CCFLAGS="${CFLAGS}" SHELL="${SH}"
@@ -27,16 +27,21 @@ MAKE_ENV+= LDFLAGS=-static
.endif
MAN1= ksh93.1
-INSTALLROOT= ${WRKSRC}/arch/freebsd.${ARCH}
.include <bsd.port.pre.mk>
+.if (${OSVERSION} >= 600000)
+INSTALLROOT= ${WRKSRC}/arch/freebsd${OSREL:R}.${ARCH}
+.else
+INSTALLROOT= ${WRKSRC}/arch/freebsd.${ARCH}
+.endif
+
.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
+BROKEN= Does not compile on sparc64
.endif
do-build:
- @cd ${WRKSRC} && env -i ${MAKE_ENV} ${SH} bin/package make
+ @cd ${WRKSRC} && ${SETENV} -i ${MAKE_ENV} ${SH} bin/package make
do-install:
${INSTALL_PROGRAM} ${INSTALLROOT}/bin/ksh ${PREFIX}/bin/ksh93
diff --git a/shells/ksh93/pkg-plist b/shells/ksh93/pkg-plist
index 6c29fc976008..fa4cb8a5e905 100644
--- a/shells/ksh93/pkg-plist
+++ b/shells/ksh93/pkg-plist
@@ -2,7 +2,7 @@
bin/ksh93
@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells; rm -f /etc/shells.bak
@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells; rm -f /etc/shells.bak
-share/examples/ksh93/dirs
-share/examples/ksh93/popd
-share/examples/ksh93/pushd
-@dirrm share/examples/ksh93
+%%EXAMPLESDIR%%/dirs
+%%EXAMPLESDIR%%/popd
+%%EXAMPLESDIR%%/pushd
+@dirrm %%EXAMPLESDIR%%