aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-21 11:35:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-21 11:35:38 +0000
commit279a1d6cef350fa63c1f2591fd35eaed308cc289 (patch)
tree99df93fe2c6cb138e8bf38b448c1f7ba6dde7343 /shells
parent43166060310d849ddcd279d3347dea95638ff39a (diff)
downloadports-279a1d6cef350fa63c1f2591fd35eaed308cc289.tar.gz
ports-279a1d6cef350fa63c1f2591fd35eaed308cc289.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/fish/Makefile37
-rw-r--r--shells/fish/distinfo6
-rw-r--r--shells/fish/files/patch-configure.ac117
-rw-r--r--shells/fish/pkg-plist106
4 files changed, 211 insertions, 55 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index 5cb52b08a20c..327c3db1e8c2 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -6,14 +6,11 @@
#
PORTNAME= fish
-PORTVERSION= 1.22.3
-PORTREVISION= 4
+PORTVERSION= 1.23.1
CATEGORIES= shells
-MASTER_SITES= http://www.fishshell.org/files/1.22.3/ \
- http://roo.no-ip.org/fish/files/1.22.3/ \
- http://web.student.chalmers.se/~kaiw/FreeBSD/disfiles/
+MASTER_SITES= SF
-MAINTAINER= kaiw27@gmail.com
+MAINTAINER= rfarmer@predatorlabs.net
COMMENT= A user friendly command line shell
USE_AUTOTOOLS= autoconf:262
@@ -30,18 +27,18 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LIBS="${LDFLAGS}" \
OPTIONS= NLS "Native language support" on \
XSEL "Build with xsel" on
-MAN1= count.1 fish.1 fish_pager.1 fishd.1 \
- mimedb.1 set_color.1 alias.1 and.1 begin.1 \
- bg.1 bind.1 block.1 break.1 builtin.1 \
- case.1 cd.1 command.1 commandline.1 complete.1 \
- contains.1 continue.1 dirh.1 dirs.1 else.1 \
- end.1 eval.1 exec.1 exit.1 fg.1 for.1 \
- function.1 functions.1 help.1 if.1 isatty.1 \
- jobs.1 math.1 nextd.1 not.1 open.1 or.1 \
- popd.1 prevd.1 psub.1 pushd.1 random.1 \
- read.1 return.1 save_function.1 set.1 \
- source.1 status.1 switch.1 trap.1 type.1 \
- ulimit.1 umask.1 vared.1 while.1
+MAN1= alias.1 and.1 begin.1 bg.1 bind.1 block.1 \
+ break.1 breakpoint.1 builtin.1 case.1 cd.1 \
+ command.1 commandline.1 complete.1 contains.1 \
+ continue.1 count.1 dirh.1 dirs.1 else.1 \
+ emit.1 end.1 eval.1 exec.1 exit.1 fg.1 fish.1 \
+ fish_indent.1 fish_pager.1 fish_prompt.1 \
+ fishd.1 for.1 funced.1 funcsave.1 function.1 \
+ functions.1 help.1 if.1 isatty.1 jobs.1 math.1 \
+ mimedb.1 nextd.1 not.1 open.1 or.1 popd.1 \
+ prevd.1 psub.1 pushd.1 random.1 read.1 return.1 \
+ set.1 set_color.1 source.1 status.1 switch.1 \
+ trap.1 type.1 ulimit.1 umask.1 vared.1 while.1
.include <bsd.port.pre.mk>
@@ -66,10 +63,6 @@ post-install:
.if !defined(WITHOUT_XSEL)
${MV} ${PREFIX}/man/man1/xsel.1x ${PREFIX}/man/man1/xsel.1
.endif
-# remove duplicate manpages
-.for i in count.1 fish.1 fish_pager.1 fishd.1 mimedb.1 set_color.1
- cd ${DATADIR}/man && ${RM} -f ${i}
-.endfor
${CP} ${DATADIR}/man/*.1 ${PREFIX}/man/man1/
${RM} -rf ${DATADIR}/man
if ${GREP} -q '${PREFIX}/bin/${PORTNAME}' /etc/shells; then \
diff --git a/shells/fish/distinfo b/shells/fish/distinfo
index d19275fe4e78..bfe81444de1d 100644
--- a/shells/fish/distinfo
+++ b/shells/fish/distinfo
@@ -1,3 +1,3 @@
-MD5 (fish-1.22.3.tar.gz) = 088a977e08c5026bbad300e56dcb6ac3
-SHA256 (fish-1.22.3.tar.gz) = 5d55d90fed997762cb42ac002eedbd5b156af21f4b0c93a579415ff62fb60769
-SIZE (fish-1.22.3.tar.gz) = 1045212
+MD5 (fish-1.23.1.tar.gz) = 4b2436843e63bebba467cc4add11428a
+SHA256 (fish-1.23.1.tar.gz) = a7f2890b0112d57b4760975f3d8f8c7e0cd240edcb2b3a87b5d66744a8deaf64
+SIZE (fish-1.23.1.tar.gz) = 1152997
diff --git a/shells/fish/files/patch-configure.ac b/shells/fish/files/patch-configure.ac
index e9d3338d8812..e7441feaccb5 100644
--- a/shells/fish/files/patch-configure.ac
+++ b/shells/fish/files/patch-configure.ac
@@ -1,13 +1,118 @@
---- configure.ac.orig 2007-02-08 09:38:58.000000000 -0800
-+++ configure.ac 2007-09-22 18:29:24.000000000 -0700
-@@ -412,9 +412,3 @@
+--- configure.ac.orig 2009-03-08 07:46:47.000000000 -0700
++++ configure.ac 2009-09-18 21:28:07.000000000 -0700
+@@ -451,20 +451,6 @@
+
+ #
+-# Set up the directory where the documentation files should be
+-# installed
+-#
+-
-AC_ARG_VAR( [docdir], [Documentation direcotry] )
-
-if test -z $docdir; then
-- AC_SUBST(docdir, [$datadir/doc/fish] )
+- docdir=$datadir/doc/fish
-else
-- AC_SUBST(docdir, [$docdir])
+- docdir=$docdir
+-fi
+-
+-
+-#
+ # Set up locale directory. This is where the .po files will be
+ # installed.
+ #
+@@ -500,94 +486,19 @@
+ #
+
+ # Check for os dependant libraries for all binaries.
+-LIBS_COMMON=$LIBS
+-LIBS=""
+ AC_SEARCH_LIBS( connect, socket, , [AC_MSG_ERROR([Cannot find the socket library, needed to build this package.] )] )
+ AC_SEARCH_LIBS( nanosleep, rt, , [AC_MSG_ERROR([Cannot find the rt library, needed to build this package.] )] )
+ AC_SEARCH_LIBS( setupterm, [ncurses curses], , [AC_MSG_ERROR([Could not find a curses implementation, needed to build fish])] )
+ AC_SEARCH_LIBS( [nan], [m], [AC_DEFINE( [HAVE_NAN], [1], [Define to 1 if you have the nan function])] )
+-LIBS_SHARED=$LIBS
+-LIBS=$LIBS_COMMON
+
+ #
+ # Check for libraries needed by fish.
+ #
+
+-LIBS_COMMON=$LIBS
+-LIBS="$LIBS_SHARED"
+ if test x$local_gettext != xno; then
+ AC_SEARCH_LIBS( gettext, intl,,)
+ fi
+
+-# Check for libiconv_open if we can't find iconv_open. Silly OS X does
+-# weird macro magic for the sole purpose of amusing me.
+-AC_SEARCH_LIBS( iconv_open, iconv, , [AC_SEARCH_LIBS( libiconv_open, iconv, , [AC_MSG_ERROR([Could not find an iconv implementation, needed to build fish])] )] )
+-
+-LIBS_FISH=$LIBS
+-LIBS=$LIBS_COMMON
+-
+-#
+-# Check for libraries needed by fish_indent.
+-#
+-
+-LIBS_COMMON=$LIBS
+-LIBS="$LIBS_SHARED"
+-if test x$local_gettext != xno; then
+- AC_SEARCH_LIBS( gettext, intl,,)
+-fi
+-LIBS_FISH_INDENT=$LIBS
+-LIBS=$LIBS_COMMON
+-
+-#
+-# Check for libraries needed by fish_pager.
+-#
+-
+-LIBS_COMMON=$LIBS
+-LIBS="$LIBS_SHARED"
+-if test x$local_gettext != xno; then
+- AC_SEARCH_LIBS( gettext, intl,,)
+-fi
+-AC_SEARCH_LIBS( iconv_open, iconv, , [AC_MSG_ERROR([Could not find an iconv implementation, needed to build fish])] )
+-LIBS_FISH_PAGER=$LIBS
+-LIBS=$LIBS_COMMON
+-
+-#
+-# Check for libraries needed by fishd.
+-#
+-
+-LIBS_COMMON=$LIBS
+-LIBS="$LIBS_SHARED"
+-if test x$local_gettext != xno; then
+- AC_SEARCH_LIBS( gettext, intl,,)
+-fi
+-AC_SEARCH_LIBS( iconv_open, iconv, , [AC_MSG_ERROR([Could not find an iconv implementation, needed to build fish])] )
+-LIBS_FISHD=$LIBS
+-LIBS=$LIBS_COMMON
+-
+-#
+-# Check for libraries needed by mimedb.
+-#
+-
+-LIBS_COMMON=$LIBS
+-LIBS="$LIBS_SHARED"
+-if test x$local_gettext != xno; then
+- AC_SEARCH_LIBS( gettext, intl,,)
+-fi
+-LIBS_MIMEDB=$LIBS
+-LIBS=$LIBS_COMMON
+-
+-
+-#
+-# Check for libraries needed by set_color
+-#
+-
+-LIBS_COMMON=$LIBS
+-LIBS="$LIBS_SHARED"
+-if test x$local_gettext != xno; then
+- AC_SEARCH_LIBS( gettext, intl,,)
-fi
-+AC_SUBST(docdir, [$datadir/doc/fish] )
+-LIBS_SET_COLOR=$LIBS
+-LIBS=$LIBS_COMMON
+ #
+ # Check presense of various header files
diff --git a/shells/fish/pkg-plist b/shells/fish/pkg-plist
index 1101d7783340..938052de33e5 100644
--- a/shells/fish/pkg-plist
+++ b/shells/fish/pkg-plist
@@ -1,29 +1,29 @@
-bin/count
bin/fish
+bin/fish_indent
bin/fish_pager
bin/fishd
bin/mimedb
bin/seq
bin/set_color
%%XSEL%%bin/xsel
-etc/fish/config.fish
-etc/fish/fish_inputrc
-%%DOCSDIR%%/ChangeLog
-%%DOCSDIR%%/commands.html
-%%DOCSDIR%%/design.html
-%%DOCSDIR%%/doc_8h-source.html
-%%DOCSDIR%%/doc_8h_source.html
-%%DOCSDIR%%/doxygen.css
-%%DOCSDIR%%/doxygen.png
-%%DOCSDIR%%/faq.html
-%%DOCSDIR%%/files.html
-%%DOCSDIR%%/index.html
-%%DOCSDIR%%/license.html
-%%DOCSDIR%%/pages.html
-%%DOCSDIR%%/tab_b.gif
-%%DOCSDIR%%/tab_l.gif
-%%DOCSDIR%%/tab_r.gif
-%%DOCSDIR%%/tabs.css
+%%ETCDIR%%/config.fish
+share/doc/ChangeLog
+share/doc/commands.html
+share/doc/design.html
+share/doc/doc_8h-source.html
+share/doc/doxygen.css
+share/doc/doxygen.png
+share/doc/faq.html
+share/doc/files.html
+share/doc/index.html
+share/doc/license.html
+share/doc/pages.html
+share/doc/tab_b.gif
+share/doc/tab_l.gif
+share/doc/tab_r.gif
+share/doc/tabs.css
+%%DATADIR%%/completions/acpi.fish
+%%DATADIR%%/completions/adduser.fish
%%DATADIR%%/completions/and.fish
%%DATADIR%%/completions/ant.fish
%%DATADIR%%/completions/apm.fish
@@ -56,9 +56,12 @@ etc/fish/fish_inputrc
%%DATADIR%%/completions/atd.fish
%%DATADIR%%/completions/atq.fish
%%DATADIR%%/completions/atrm.fish
+%%DATADIR%%/completions/awk.fish
+%%DATADIR%%/completions/badblocks.fish
%%DATADIR%%/completions/bc.fish
%%DATADIR%%/completions/bg.fish
%%DATADIR%%/completions/bind.fish
+%%DATADIR%%/completions/bison.fish
%%DATADIR%%/completions/block.fish
%%DATADIR%%/completions/break.fish
%%DATADIR%%/completions/btdownloadcurses.py.fish
@@ -73,6 +76,7 @@ etc/fish/fish_inputrc
%%DATADIR%%/completions/cd.fish
%%DATADIR%%/completions/cdrecord.fish
%%DATADIR%%/completions/chgrp.fish
+%%DATADIR%%/completions/chmod.fish
%%DATADIR%%/completions/chown.fish
%%DATADIR%%/completions/chsh.fish
%%DATADIR%%/completions/command.fish
@@ -80,6 +84,8 @@ etc/fish/fish_inputrc
%%DATADIR%%/completions/complete.fish
%%DATADIR%%/completions/configure.fish
%%DATADIR%%/completions/continue.fish
+%%DATADIR%%/completions/cowsay.fish
+%%DATADIR%%/completions/cowthink.fish
%%DATADIR%%/completions/cp.fish
%%DATADIR%%/completions/cut.fish
%%DATADIR%%/completions/cvs.fish
@@ -92,6 +98,7 @@ etc/fish/fish_inputrc
%%DATADIR%%/completions/dvipdf.fish
%%DATADIR%%/completions/dvipdfm.fish
%%DATADIR%%/completions/echo.fish
+%%DATADIR%%/completions/effectv.fish
%%DATADIR%%/completions/eix-sync.fish
%%DATADIR%%/completions/eix.fish
%%DATADIR%%/completions/elatex.fish
@@ -101,21 +108,26 @@ etc/fish/fish_inputrc
%%DATADIR%%/completions/equery.fish
%%DATADIR%%/completions/etex.fish
%%DATADIR%%/completions/eval.fish
+%%DATADIR%%/completions/evince.fish
%%DATADIR%%/completions/exec.fish
%%DATADIR%%/completions/exit.fish
%%DATADIR%%/completions/fg.fish
%%DATADIR%%/completions/file.fish
%%DATADIR%%/completions/find.fish
%%DATADIR%%/completions/fish.fish
+%%DATADIR%%/completions/fish_indent.fish
%%DATADIR%%/completions/flac.fish
%%DATADIR%%/completions/function.fish
%%DATADIR%%/completions/functions.fish
%%DATADIR%%/completions/fusermount.fish
%%DATADIR%%/completions/gcc.fish
+%%DATADIR%%/completions/gdb.fish
%%DATADIR%%/completions/gem.fish
+%%DATADIR%%/completions/git.fish
%%DATADIR%%/completions/gpg.fish
%%DATADIR%%/completions/gprof.fish
%%DATADIR%%/completions/grep.fish
+%%DATADIR%%/completions/groupadd.fish
%%DATADIR%%/completions/gunzip.fish
%%DATADIR%%/completions/gzip.fish
%%DATADIR%%/completions/help.fish
@@ -123,6 +135,7 @@ etc/fish/fish_inputrc
%%DATADIR%%/completions/iconv.fish
%%DATADIR%%/completions/id.fish
%%DATADIR%%/completions/ifconfig.fish
+%%DATADIR%%/completions/invoke-rc.d.fish
%%DATADIR%%/completions/jobs.fish
%%DATADIR%%/completions/kill.fish
%%DATADIR%%/completions/la.fish
@@ -131,21 +144,26 @@ etc/fish/fish_inputrc
%%DATADIR%%/completions/ll.fish
%%DATADIR%%/completions/locate.fish
%%DATADIR%%/completions/ls.fish
+%%DATADIR%%/completions/m4.fish
%%DATADIR%%/completions/make.fish
%%DATADIR%%/completions/makedepend.fish
+%%DATADIR%%/completions/makepkg.fish
%%DATADIR%%/completions/man.fish
%%DATADIR%%/completions/mimedb.fish
%%DATADIR%%/completions/modprobe.fish
%%DATADIR%%/completions/mount.fish
%%DATADIR%%/completions/mplayer.fish
+%%DATADIR%%/completions/msgfmt.fish
%%DATADIR%%/completions/mutt.fish
%%DATADIR%%/completions/mv.fish
+%%DATADIR%%/completions/netcat.fish
%%DATADIR%%/completions/nextd.fish
%%DATADIR%%/completions/nice.fish
%%DATADIR%%/completions/not.fish
%%DATADIR%%/completions/oggenc.fish
%%DATADIR%%/completions/omega.fish
%%DATADIR%%/completions/or.fish
+%%DATADIR%%/completions/pacman.fish
%%DATADIR%%/completions/patch.fish
%%DATADIR%%/completions/pdfelatex.fish
%%DATADIR%%/completions/pdfetex.fish
@@ -154,14 +172,22 @@ etc/fish/fish_inputrc
%%DATADIR%%/completions/perl.fish
%%DATADIR%%/completions/pine.fish
%%DATADIR%%/completions/ping.fish
+%%DATADIR%%/completions/pkgadd.fish
+%%DATADIR%%/completions/pkginfo.fish
+%%DATADIR%%/completions/pkgmk.fish
+%%DATADIR%%/completions/pkgrm.fish
+%%DATADIR%%/completions/ports.fish
%%DATADIR%%/completions/prevd.fish
+%%DATADIR%%/completions/prt-get.fish
%%DATADIR%%/completions/ps.fish
%%DATADIR%%/completions/ps2pdf.fish
%%DATADIR%%/completions/psub.fish
%%DATADIR%%/completions/pushd.fish
%%DATADIR%%/completions/python.fish
+%%DATADIR%%/completions/quilt.fish
%%DATADIR%%/completions/random.fish
%%DATADIR%%/completions/read.fish
+%%DATADIR%%/completions/rejmerge.fish
%%DATADIR%%/completions/renice.fish
%%DATADIR%%/completions/return.fish
%%DATADIR%%/completions/rm.fish
@@ -169,6 +195,7 @@ etc/fish/fish_inputrc
%%DATADIR%%/completions/rpm.fish
%%DATADIR%%/completions/rsync.fish
%%DATADIR%%/completions/ruby.fish
+%%DATADIR%%/completions/scons.fish
%%DATADIR%%/completions/scp.fish
%%DATADIR%%/completions/screen.fish
%%DATADIR%%/completions/sed.fish
@@ -200,6 +227,7 @@ etc/fish/fish_inputrc
%%DATADIR%%/completions/unrar.fish
%%DATADIR%%/completions/update-eix-remote.fish
%%DATADIR%%/completions/update-eix.fish
+%%DATADIR%%/completions/useradd.fish
%%DATADIR%%/completions/valgrind.fish
%%DATADIR%%/completions/vared.fish
%%DATADIR%%/completions/vi.fish
@@ -207,12 +235,14 @@ etc/fish/fish_inputrc
%%DATADIR%%/completions/w.fish
%%DATADIR%%/completions/wajig.fish
%%DATADIR%%/completions/wc.fish
+%%DATADIR%%/completions/wesnoth.fish
%%DATADIR%%/completions/wget.fish
%%DATADIR%%/completions/whatis.fish
%%DATADIR%%/completions/which.fish
%%DATADIR%%/completions/who.fish
%%DATADIR%%/completions/wpa_cli.fish
%%DATADIR%%/completions/xargs.fish
+%%DATADIR%%/completions/xgettext.fish
%%DATADIR%%/completions/xmms.fish
%%DATADIR%%/completions/xpdf.fish
%%DATADIR%%/completions/xprop.fish
@@ -222,16 +252,22 @@ etc/fish/fish_inputrc
%%DATADIR%%/completions/zcat.fish
%%DATADIR%%/completions/zip.fish
%%DATADIR%%/config.fish
-%%DATADIR%%/config_interactive.fish
%%DATADIR%%/functions/N_.fish
%%DATADIR%%/functions/_.fish
%%DATADIR%%/functions/__fish_append.fish
+%%DATADIR%%/functions/__fish_bind_test1.fish
+%%DATADIR%%/functions/__fish_bind_test2.fish
+%%DATADIR%%/functions/__fish_commandline_test.fish
%%DATADIR%%/functions/__fish_complete_ant_targets.fish
%%DATADIR%%/functions/__fish_complete_bittorrent.fish
%%DATADIR%%/functions/__fish_complete_cd.fish
+%%DATADIR%%/functions/__fish_complete_command.fish
%%DATADIR%%/functions/__fish_complete_directories.fish
+%%DATADIR%%/functions/__fish_complete_file_url.fish
+%%DATADIR%%/functions/__fish_complete_groups.fish
%%DATADIR%%/functions/__fish_complete_ls.fish
%%DATADIR%%/functions/__fish_complete_man.fish
+%%DATADIR%%/functions/__fish_complete_mime.fish
%%DATADIR%%/functions/__fish_complete_pids.fish
%%DATADIR%%/functions/__fish_complete_ssh.fish
%%DATADIR%%/functions/__fish_complete_subcommand.fish
@@ -240,30 +276,53 @@ etc/fish/fish_inputrc
%%DATADIR%%/functions/__fish_complete_tar.fish
%%DATADIR%%/functions/__fish_complete_tex.fish
%%DATADIR%%/functions/__fish_complete_unrar.fish
+%%DATADIR%%/functions/__fish_complete_users.fish
%%DATADIR%%/functions/__fish_complete_vi.fish
+%%DATADIR%%/functions/__fish_config_interactive.fish
%%DATADIR%%/functions/__fish_contains_opt.fish
+%%DATADIR%%/functions/__fish_crux_packages.fish
%%DATADIR%%/functions/__fish_describe_command.fish
+%%DATADIR%%/functions/__fish_filter_ant_targets.fish
%%DATADIR%%/functions/__fish_filter_mime.fish
+%%DATADIR%%/functions/__fish_git_branch_prompt.fish
%%DATADIR%%/functions/__fish_gnu_complete.fish
%%DATADIR%%/functions/__fish_is_first_token.fish
%%DATADIR%%/functions/__fish_list_current_token.fish
%%DATADIR%%/functions/__fish_move_last.fish
%%DATADIR%%/functions/__fish_no_arguments.fish
+%%DATADIR%%/functions/__fish_not_contain_opt.fish
+%%DATADIR%%/functions/__fish_paginate.fish
+%%DATADIR%%/functions/__fish_ports_dirs.fish
+%%DATADIR%%/functions/__fish_print_addresses.fish
+%%DATADIR%%/functions/__fish_print_debian_services.fish
+%%DATADIR%%/functions/__fish_print_encodings.fish
%%DATADIR%%/functions/__fish_print_filesystems.fish
%%DATADIR%%/functions/__fish_print_function_prototypes.fish
%%DATADIR%%/functions/__fish_print_help.fish
%%DATADIR%%/functions/__fish_print_hostnames.fish
+%%DATADIR%%/functions/__fish_print_interfaces.fish
+%%DATADIR%%/functions/__fish_print_make_targets.fish
%%DATADIR%%/functions/__fish_print_packages.fish
+%%DATADIR%%/functions/__fish_print_users.fish
+%%DATADIR%%/functions/__fish_prt_no_subcommand.fish
+%%DATADIR%%/functions/__fish_prt_packages.fish
+%%DATADIR%%/functions/__fish_prt_ports.fish
+%%DATADIR%%/functions/__fish_prt_use_package.fish
+%%DATADIR%%/functions/__fish_prt_use_port.fish
%%DATADIR%%/functions/__fish_seen_subcommand_from.fish
%%DATADIR%%/functions/__fish_test_arg.fish
%%DATADIR%%/functions/__fish_use_subcommand.fish
%%DATADIR%%/functions/alias.fish
%%DATADIR%%/functions/cd.fish
-%%DATADIR%%/functions/contains.fish
%%DATADIR%%/functions/delete-or-exit.fish
%%DATADIR%%/functions/dirh.fish
%%DATADIR%%/functions/dirs.fish
+%%DATADIR%%/functions/down-or-search.fish
+%%DATADIR%%/functions/eval.fish
+%%DATADIR%%/functions/fish_default_key_bindings.fish
%%DATADIR%%/functions/fish_prompt.fish
+%%DATADIR%%/functions/funced.fish
+%%DATADIR%%/functions/funcsave.fish
%%DATADIR%%/functions/grep.fish
%%DATADIR%%/functions/help.fish
%%DATADIR%%/functions/isatty.fish
@@ -281,12 +340,12 @@ etc/fish/fish_inputrc
%%DATADIR%%/functions/psub.fish
%%DATADIR%%/functions/pushd.fish
%%DATADIR%%/functions/pwd.fish
-%%DATADIR%%/functions/save_function.fish
%%DATADIR%%/functions/setenv.fish
%%DATADIR%%/functions/sgrep.fish
%%DATADIR%%/functions/trap.fish
%%DATADIR%%/functions/type.fish
%%DATADIR%%/functions/umask.fish
+%%DATADIR%%/functions/up-or-search.fish
%%DATADIR%%/functions/vared.fish
%%NLS%%share/locale/de/LC_MESSAGES/fish.mo
%%NLS%%share/locale/en/LC_MESSAGES/fish.mo
@@ -295,7 +354,6 @@ etc/fish/fish_inputrc
@dirrm %%DATADIR%%/functions
@dirrm %%DATADIR%%/completions
@dirrm %%DATADIR%%
-@dirrm %%DOCSDIR%%
-@dirrm etc/fish
+@dirrm %%ETCDIR%%
@exec cp /etc/shells /etc/shells.bak; (grep -v %D/bin/fish /etc/shells.bak; echo %D/bin/fish) > /etc/shells; rm -f /etc/shells.bak
@unexec cp /etc/shells /etc/shells.bak; (grep -v %D/bin/fish /etc/shells.bak) > /etc/shells; rm -f /etc/shells.bak