aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-23 07:40:59 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-23 07:40:59 +0000
commit66fb8f0b565f66dc45b419fbae9a367284d0be19 (patch)
tree48f9b98405a97c6869f4bfdc22fe04ace80f3082 /shells
parent0761ade923b1268c3bb39c5c3703b02de13b8547 (diff)
downloadports-66fb8f0b565f66dc45b419fbae9a367284d0be19.tar.gz
ports-66fb8f0b565f66dc45b419fbae9a367284d0be19.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile1
-rw-r--r--shells/p5-Bash-Completion/Makefile47
-rw-r--r--shells/p5-Bash-Completion/distinfo2
-rw-r--r--shells/p5-Bash-Completion/pkg-descr21
-rw-r--r--shells/p5-Bash-Completion/pkg-plist16
5 files changed, 87 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index 97acb5286337..6085ecd8efc9 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -25,6 +25,7 @@
SUBDIR += mksh
SUBDIR += nologinmsg
SUBDIR += osh
+ SUBDIR += p5-Bash-Completion
SUBDIR += p5-Shell-Perl
SUBDIR += p5-Term-ShellUI
SUBDIR += pdksh
diff --git a/shells/p5-Bash-Completion/Makefile b/shells/p5-Bash-Completion/Makefile
new file mode 100644
index 000000000000..74ced6e17009
--- /dev/null
+++ b/shells/p5-Bash-Completion/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: p5-Bash-Completion
+# Date created: 2011-10-23
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Bash-Completion
+PORTVERSION= 0.008
+CATEGORIES= shells perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MELO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Extensible system to provide bash completion
+
+BUILD_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Module-Load>=0.22:${PORTSDIR}/devel/p5-Module-Load
+RUN_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Module-Load>=0.22:${PORTSDIR}/devel/p5-Module-Load
+
+TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
+
+PERL_CONFIGURE= yes
+
+MAN1= bash-complete.1 \
+ setup-bash-complete.1
+MAN3= App::BashComplete.3 \
+ Bash::Completion.3 \
+ Bash::Completion::Plugin.3 \
+ Bash::Completion::Plugins::BashComplete.3 \
+ Bash::Completion::Plugins::Perldoc.3 \
+ Bash::Completion::Request.3 \
+ Bash::Completion::Utils.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/shells/p5-Bash-Completion/distinfo b/shells/p5-Bash-Completion/distinfo
new file mode 100644
index 000000000000..7d4fa69b9f7d
--- /dev/null
+++ b/shells/p5-Bash-Completion/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Bash-Completion-0.008.tar.gz) = 121133adc318112fade136b6ec1f523f4646c67579b9ac39bfad444dd65cedbc
+SIZE (Bash-Completion-0.008.tar.gz) = 16561
diff --git a/shells/p5-Bash-Completion/pkg-descr b/shells/p5-Bash-Completion/pkg-descr
new file mode 100644
index 000000000000..9b280927135f
--- /dev/null
+++ b/shells/p5-Bash-Completion/pkg-descr
@@ -0,0 +1,21 @@
+bash completion should just work when you install new commands. Bash::Completion
+is a system to use and write bash completion rules.
+
+For end-users, you just need to add this line to your .bashrc or .bash_profile:
+
+ setup-bash-complete
+
+This will load all the installed Bash::Completion plugins, make sure they should
+be activated and generate the proper bash code to setup bash completion for
+them.
+
+If you later install a new command line tool, and it has a
+Bash::Completion::Plugin -based plugin, all your new shells will have bash
+completion rules for it. You can also force immediate setup by running the same
+command:
+
+ setup-bash-complete
+
+To write a new Bash::Completion plugin, see Bash::Completion::Plugin.
+
+WWW: http://search.cpan.org/dist/Bash-Completion/
diff --git a/shells/p5-Bash-Completion/pkg-plist b/shells/p5-Bash-Completion/pkg-plist
new file mode 100644
index 000000000000..eb1f69fdefcd
--- /dev/null
+++ b/shells/p5-Bash-Completion/pkg-plist
@@ -0,0 +1,16 @@
+bin/bash-complete
+bin/setup-bash-complete
+%%SITE_PERL%%/App/BashComplete.pm
+%%SITE_PERL%%/Bash/Completion.pm
+%%SITE_PERL%%/Bash/Completion/Plugin.pm
+%%SITE_PERL%%/Bash/Completion/Plugins/BashComplete.pm
+%%SITE_PERL%%/Bash/Completion/Plugins/Perldoc.pm
+%%SITE_PERL%%/Bash/Completion/Request.pm
+%%SITE_PERL%%/Bash/Completion/Utils.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Bash/Completion/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Bash/Completion
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Bash
+@dirrm %%SITE_PERL%%/Bash/Completion/Plugins
+@dirrm %%SITE_PERL%%/Bash/Completion
+@dirrmtry %%SITE_PERL%%/Bash
+@dirrmtry %%SITE_PERL%%/App