aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-12 13:48:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-12 13:48:21 +0000
commita77799da2515bc581f993137095af5e09ef07fea (patch)
tree4eefb463f3f43208a3319b793b28a4cab3218bf4 /shells
parent86aa69222e1c95b35095689f86292592ce0a5a5b (diff)
downloadports-a77799da2515bc581f993137095af5e09ef07fea.tar.gz
ports-a77799da2515bc581f993137095af5e09ef07fea.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/osh/Makefile29
-rw-r--r--shells/osh/distinfo6
2 files changed, 30 insertions, 5 deletions
diff --git a/shells/osh/Makefile b/shells/osh/Makefile
index 131086bf5b62..dd20ead1323b 100644
--- a/shells/osh/Makefile
+++ b/shells/osh/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= osh
-DISTVERSION= 20090527
+DISTVERSION= 20091127
CATEGORIES= shells
MASTER_SITES= http://v6shell.org/src/ \
http://freebsd.unixfreunde.de/sources/
@@ -14,8 +14,33 @@ MASTER_SITES= http://v6shell.org/src/ \
MAINTAINER= miwi@FreeBSD.org
COMMENT= An implementation of the UNIX 6th Edition shell
+MAKE_ENV+= DOCDIR=${DOCSDIR} \
+ DESTEXPDIR=${EXAMPLESDIR} \
+ MANDIR=${MANPREFIX}/man/man1
+
MAN1= fd2.1 goto.1 if.1 osh.1 sh6.1 glob6.1
+PORTDOCS= *
+PORTEXAMPLES= *
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -E -e 's|(DESTEXPDIR)=|\1?=|' \
+ ${WRKSRC}/Makefile
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e /^install-doc/d \
+ -e /\ $$\(DESTDOCDIR\)/d \
+ -e 's/install-doc//' \
+ ${WRKSRC}/Makefile
+.endif
+.if defined(NOPORTEXAMPLES)
+ @${REINPLACE_CMD} -e /^install-exp/d \
+ -e /\ $$\(DESTEXPDIR\)/d \
+ -e 's/install-exp//' \
+ ${WRKSRC}/Makefile
+.endif
+
post-install:
@${ECHO_MSG} "updating /etc/shells"
@${CP} /etc/shells /etc/shells.bak
@@ -23,4 +48,4 @@ post-install:
${ECHO_CMD} ${PREFIX}/bin/osh) > /etc/shells
@${RM} /etc/shells.bak
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/shells/osh/distinfo b/shells/osh/distinfo
index 5899ff520b16..26994167e3ed 100644
--- a/shells/osh/distinfo
+++ b/shells/osh/distinfo
@@ -1,3 +1,3 @@
-MD5 (osh-20090527.tar.gz) = 179f79cfe6eb30036189e5ff111aa4ec
-SHA256 (osh-20090527.tar.gz) = 3fb3337d2b3264331ff1542de8ae675a6d77245c70d2bff8e07dee204a1d39ab
-SIZE (osh-20090527.tar.gz) = 92440
+MD5 (osh-20091127.tar.gz) = 3af1073896d5ce099ce0b09f156ffdfc
+SHA256 (osh-20091127.tar.gz) = 250b3e2bd4a8e2dd9eb9ed4d50e4839ee03427a9b04c0b97e92a889e6dc433f4
+SIZE (osh-20091127.tar.gz) = 98780