aboutsummaryrefslogtreecommitdiff
path: root/sysutils/44bsd-more
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2007-06-22 06:53:11 +0000
committerXin LI <delphij@FreeBSD.org>2007-06-22 06:53:11 +0000
commitd6a6f8552aaee8bda1b0a5217f6fc05f757d3f14 (patch)
tree1e9e9e89ae166ce2372bbe36a16b5155dd7e5bed /sysutils/44bsd-more
parent885d88057236943a7224b3af2222e7d28da91e3b (diff)
downloadports-d6a6f8552aaee8bda1b0a5217f6fc05f757d3f14.tar.gz
ports-d6a6f8552aaee8bda1b0a5217f6fc05f757d3f14.zip
Notes
Diffstat (limited to 'sysutils/44bsd-more')
-rw-r--r--sysutils/44bsd-more/Makefile4
-rw-r--r--sysutils/44bsd-more/files/patch-main.c21
-rw-r--r--sysutils/44bsd-more/files/patch-ncommand.c18
3 files changed, 37 insertions, 6 deletions
diff --git a/sysutils/44bsd-more/Makefile b/sysutils/44bsd-more/Makefile
index 00cce5e51963..6aa33745b358 100644
--- a/sysutils/44bsd-more/Makefile
+++ b/sysutils/44bsd-more/Makefile
@@ -23,10 +23,6 @@ RELDATE= 20000521
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-extract:
-cd ${WRKSRC} && co RCS/*,v
diff --git a/sysutils/44bsd-more/files/patch-main.c b/sysutils/44bsd-more/files/patch-main.c
index 3e000dad57d9..00662f7f75d1 100644
--- a/sysutils/44bsd-more/files/patch-main.c
+++ b/sysutils/44bsd-more/files/patch-main.c
@@ -1,5 +1,5 @@
---- main.c.orig Tue Aug 5 17:17:15 2003
-+++ main.c Tue Aug 5 17:21:34 2003
+--- ./main.c.orig 2007-06-22 14:48:44.602177005 +0800
++++ ./main.c 2007-06-22 14:48:44.620758150 +0800
@@ -33,9 +33,9 @@
*/
@@ -12,3 +12,20 @@
Regents of the University of California. All rights reserved.\n";
#endif /* not lint */
+@@ -68,6 +68,8 @@
+ #include "less.h"
+ #include "pathnames.h"
+
++static int str_read(void *, char *, size_t);
++
+ int ispipe;
+ char *current_file, *previous_file, *current_name, *next_name;
+ int any_display;
+@@ -410,7 +412,6 @@
+ char *c;
+ int readrc();
+ int savederrno;
+- static int str_read();
+
+ /* The default builtin rc file */
+ if ((c = getenv("HOME")) &&
diff --git a/sysutils/44bsd-more/files/patch-ncommand.c b/sysutils/44bsd-more/files/patch-ncommand.c
new file mode 100644
index 000000000000..39167e12cf95
--- /dev/null
+++ b/sysutils/44bsd-more/files/patch-ncommand.c
@@ -0,0 +1,18 @@
+--- ./ncommand.c.orig 2007-06-22 14:48:44.603814341 +0800
++++ ./ncommand.c 2007-06-22 14:48:44.631081101 +0800
+@@ -231,6 +231,7 @@
+ */
+
+ static char *readvar();
++static const char *getvar(char *, int);
+
+ #define NCTXTS 128
+ void *getstr_ctxts[NCTXTS]; /* could easily be made dynamic... */
+@@ -613,7 +614,6 @@
+ {
+ int vlength;
+ char *vstart;
+- static char *getvar();
+
+ if (**line != '{') {
+ SETERR (E_BADVAR);