aboutsummaryrefslogtreecommitdiff
path: root/sysutils/LPRng/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-30 18:18:38 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-30 18:18:38 +0000
commit46737ce94ddcf8cdc91502d4fdee4f6e2be57993 (patch)
tree18c0795a37684e1e85d33012e0330ec3a49b766b /sysutils/LPRng/Makefile
parent296c381b708db53914e30f5ccffd28ba78cab7c3 (diff)
downloadports-46737ce94ddcf8cdc91502d4fdee4f6e2be57993.tar.gz
ports-46737ce94ddcf8cdc91502d4fdee4f6e2be57993.zip
Notes
Diffstat (limited to 'sysutils/LPRng/Makefile')
-rw-r--r--sysutils/LPRng/Makefile32
1 files changed, 18 insertions, 14 deletions
diff --git a/sysutils/LPRng/Makefile b/sysutils/LPRng/Makefile
index d5d14be98359..9433f2b885bc 100644
--- a/sysutils/LPRng/Makefile
+++ b/sysutils/LPRng/Makefile
@@ -6,37 +6,41 @@
#
PORTNAME= LPRng
-PORTVERSION= 3.6.26
+PORTVERSION= 3.7.5
CATEGORIES= sysutils print
-MASTER_SITES= ftp://ftp.astart.com/pub/LPRng/LPRng/
+MASTER_SITES= ftp://ftp.lprng.com/pub/%SUBDIR%/ \
+ ftp://ftp.astart.com/pub/%SUBDIR%/ \
+ ftp://ftp.cise.ufl.edu/pub/mirrors/%SUBDIR%/ \
+ ftp://ftp.cs.umn.edu/pub/%SUBDIR%/ \
+ ftp://ftp.sage-au.org.au/pub/printing/spooler/lprng/LPRng/ \
+ ftp://ftp.informatik.uni-hamburg.de/pub/os/unix/utils/%SUBDIR%/ \
+ ftp://ftp.uni-paderborn.de/pub/unix/printer/%SUBDIR%/
+MASTER_SITE_SUBDIR= LPRng/LPRng
EXTRACT_SUFX= .tgz
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= desmo@bandwidth.org
-PLIST_SUB+= LPRNG_VER=${PORTVERSION}
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
-MAKEFILE= Makefile.bsd
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= \
--with-sbindir=${PREFIX}/sbin \
--with-filterdir=${PREFIX}/libexec/filters \
- --with-lpd_conf_path=/etc/lpd.conf \
- --with-lpd_perms_path=/etc/lpd.perms \
- --with-printcap_path=/etc/printcap
-USE_GMAKE= yes
+ --with-lpd_conf_path=${PREFIX}/etc/lpd.conf \
+ --with-lpd_perms_path=${PREFIX}/etc/lpd.perms \
+ --with-printcap_path=/etc/printcap \
+ --enable-gdbm=${LOCALBASE}
MAN1= cancel.1 lp.1 lpbanner.1 lpf.1 \
- lpq.1 lpr.1 lpraccnt.1 lprm.1 lpstat.1 monitor.1 \
+ lpq.1 lpr.1 lprm.1 lpstat.1 monitor.1 \
pclbanner.1 psbanner.1
MAN5= lpd.conf.5 lpd.perms.5 printcap.5
MAN8= checkpc.8 lpc.8 lpd.8
MANCOMPRESSED= yes
post-install:
- ${INSTALL} -d -g bin -o bin -m 0555 ${PREFIX}/share/doc/LPRng
- ${INSTALL} -c -g bin -o bin -m 0444 ${WRKSRC}/HOWTO/* ${PREFIX}/share/doc/LPRng
+ ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 0555 ${DOCSDIR}
+ ${INSTALL} -c -o ${SHAREOWN} -g ${SHAREGRP} -m 0444 ${WRKSRC}/HOWTO/* ${DOCSDIR}
@${CAT} ${PKGMESSAGE} | ${SED} -e "s|@@PREFIX@@|${PREFIX}|g"
.include <bsd.port.mk>