aboutsummaryrefslogtreecommitdiff
path: root/sysutils/LPRng/Makefile
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-03-23 16:32:36 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-03-23 16:32:36 +0000
commit713ff33f3fbb2c30fb0fe03f576477b0c255259c (patch)
tree14497e60564ef5d2dabee56667a867cb19e6cc26 /sysutils/LPRng/Makefile
parentda69133c723d24d702010a1d8a9dc0479fb7e573 (diff)
Notes
Diffstat (limited to 'sysutils/LPRng/Makefile')
-rw-r--r--sysutils/LPRng/Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/sysutils/LPRng/Makefile b/sysutils/LPRng/Makefile
index 83fa189a2588..46e63c1aaf2d 100644
--- a/sysutils/LPRng/Makefile
+++ b/sysutils/LPRng/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= LPRng
-PORTVERSION= 3.8.10
+PORTVERSION= 3.8.20
CATEGORIES= sysutils print
MASTER_SITES= ftp://ftp.lprng.com/pub/%SUBDIR%/ \
ftp://ftp.astart.com/pub/%SUBDIR%/ \
@@ -24,6 +24,8 @@ COMMENT= An Enhanced Printer Spooler
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+
CONFIGURE_ARGS= \
--with-sbindir=${PREFIX}/sbin \
--with-filterdir=${PREFIX}/libexec/filters \
@@ -31,22 +33,34 @@ CONFIGURE_ARGS= \
--with-lpd_perms_path=${PREFIX}/etc/lpd.perms \
--with-printcap_path=/etc/printcap \
--enable-gdbm=${LOCALBASE}
-USE_LIBTOOL= yes
MAN1= cancel.1 lp.1 lpbanner.1 lpf.1 \
- lpq.1 lpr.1 lprm.1 lpstat.1 monitor.1 \
- pclbanner.1 psbanner.1
+ lpq.1 lpr.1 lprm.1 lprng_certs.1 lprng_index_certs.1 \
+ lpstat.1 monitor.1 pclbanner.1 psbanner.1
MAN5= lpd.conf.5 lpd.perms.5 printcap.5
MAN8= checkpc.8 lpc.8 lpd.8
MANCOMPRESSED= yes
DOC_FILES= CHANGES LPRng-HOWTO.* *.jpg LISA98.ppt
+HTML_FILES= LPRng.jpg LPRngT-L.jpg LPRngT-S.jpg chooser.png clients.png \
+ configfiles.png filter.png index.html network.png parallel.png \
+ pooling.png printserver.png samba.png serial.png spooler.png \
+ x_add.png x_advanced.png x_checkpc.png x_edit.png \
+ x_ifhpfilter.png x_nup.png x_open.png x_printcaps.png \
+ x_reread.png x_results.png x_smb.png x_write.png
+OTHER_FILES= Cookbook.pdf
post-install:
@${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 0555 ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/HTML
+ @${MKDIR} ${DOCSDIR}/PDF
+ @${INSTALL_DATA} ${WRKSRC}/PrintingCookbook/PDF/${OTHER_FILES} ${DOCSDIR}/PDF
.for file in ${DOC_FILES}
@${INSTALL_DATA} ${WRKSRC}/HOWTO/${file} ${DOCSDIR}
.endfor
+.for file in ${HTML_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/PrintingCookbook/HTML/${file} ${DOCSDIR}/HTML
+.endfor
@${CAT} ${PKGMESSAGE} | ${SED} -e "s|@@PREFIX@@|${PREFIX}|g"
.include <bsd.port.mk>