aboutsummaryrefslogtreecommitdiff
path: root/sysutils/UEFITool
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2017-03-20 09:43:51 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2017-03-20 09:43:51 +0000
commit0624c3b769880ee5f06d3ded12e538e71e2455dd (patch)
treeb58b7d858eb29bd221b67415f320c41696cd557a /sysutils/UEFITool
parent5cd92ee25505240010d148adc010c0e9987ff13e (diff)
downloadports-0624c3b769880ee5f06d3ded12e538e71e2455dd.tar.gz
ports-0624c3b769880ee5f06d3ded12e538e71e2455dd.zip
Notes
Diffstat (limited to 'sysutils/UEFITool')
-rw-r--r--sysutils/UEFITool/Makefile31
-rw-r--r--sysutils/UEFITool/distinfo3
-rw-r--r--sysutils/UEFITool/pkg-descr6
3 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/UEFITool/Makefile b/sysutils/UEFITool/Makefile
new file mode 100644
index 000000000000..ed2f2a185ac2
--- /dev/null
+++ b/sysutils/UEFITool/Makefile
@@ -0,0 +1,31 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= UEFITool
+PORTVERSION= 40
+CATEGORIES= sysutils
+
+MAINTAINER= pkubaj@anongoth.pl
+COMMENT= UEFI images parser
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= LongSoft
+GH_TAGNAME= A${PORTVERSION}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${GH_TAGNAME}/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+USES= qmake:outsource
+USE_GL= gl
+USE_QT5= buildtools_build core gui widgets qmake_build
+
+pre-install:
+ ${STRIP_CMD} ${WRKDIR}/.build/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/.build/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/UEFITool/distinfo b/sysutils/UEFITool/distinfo
new file mode 100644
index 000000000000..68963d411f7f
--- /dev/null
+++ b/sysutils/UEFITool/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1489654627
+SHA256 (LongSoft-UEFITool-40-A40_GH0.tar.gz) = 8271ed0a7c91370fbf92654fe5bc42f2cce02f27334377f9d5504e17c2007a61
+SIZE (LongSoft-UEFITool-40-A40_GH0.tar.gz) = 419087
diff --git a/sysutils/UEFITool/pkg-descr b/sysutils/UEFITool/pkg-descr
new file mode 100644
index 000000000000..4083fce90d33
--- /dev/null
+++ b/sysutils/UEFITool/pkg-descr
@@ -0,0 +1,6 @@
+UEFITool is a cross-platform C++/Qt program for parsing,
+extracting and modifying UEFI firmware images.
+It supports parsing of full BIOS images
+starting with the flash descriptor or any binary files containing UEFI volumes.
+
+WWW: https://github.com/LongSoft/UEFITool