aboutsummaryrefslogtreecommitdiff
path: root/sysutils/acerhdf-kmod
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-07-20 08:26:51 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-07-20 08:26:51 +0000
commit612415a3905bef6ee1f216c458ad241bee221df5 (patch)
tree3be46f9dd79ca6754c1f6805b452a081d5fbbc2e /sysutils/acerhdf-kmod
parent22739efb447afdac28f15c873060e1cab682c2b4 (diff)
downloadports-612415a3905bef6ee1f216c458ad241bee221df5.tar.gz
ports-612415a3905bef6ee1f216c458ad241bee221df5.zip
Notes
Diffstat (limited to 'sysutils/acerhdf-kmod')
-rw-r--r--sysutils/acerhdf-kmod/Makefile32
-rw-r--r--sysutils/acerhdf-kmod/distinfo2
-rw-r--r--sysutils/acerhdf-kmod/pkg-descr12
-rw-r--r--sysutils/acerhdf-kmod/pkg-message11
-rw-r--r--sysutils/acerhdf-kmod/pkg-plist2
5 files changed, 59 insertions, 0 deletions
diff --git a/sysutils/acerhdf-kmod/Makefile b/sysutils/acerhdf-kmod/Makefile
new file mode 100644
index 000000000000..bef5381b9f24
--- /dev/null
+++ b/sysutils/acerhdf-kmod/Makefile
@@ -0,0 +1,32 @@
+# Created by: Tobias Kortkamp <tobias.kortkamp@gmail.com>
+# $FreeBSD$
+
+PORTNAME= acerhdf-kmod
+PORTVERSION= 0.1.1
+DISTVERSIONPREFIX= v
+CATEGORIES= sysutils
+
+MAINTAINER= tobias.kortkamp@gmail.com
+COMMENT= Acer Aspire One fan control
+
+LICENSE= GPLv2
+
+USES= kmod
+KMODNAME= acerhdf
+MANDIR= ${PREFIX}/man/man4
+
+USE_GITHUB= yes
+GH_PROJECT= kmod-acerhdf
+GH_ACCOUNT= t6
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1001000
+IGNORE= does not support FreeBSD versions older than 10.1
+.endif
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/${KMODNAME}.4 ${STAGEDIR}${MANDIR}
+ ${INSTALL_KLD} ${WRKSRC}/${KMODNAME}.ko ${STAGEDIR}${KMODDIR}
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/acerhdf-kmod/distinfo b/sysutils/acerhdf-kmod/distinfo
new file mode 100644
index 000000000000..d0496706aaea
--- /dev/null
+++ b/sysutils/acerhdf-kmod/distinfo
@@ -0,0 +1,2 @@
+SHA256 (t6-kmod-acerhdf-v0.1.1_GH0.tar.gz) = 2947bfa7714eee18d5498b768bca90fed7dd1e720d4ef124245268f54576b1d5
+SIZE (t6-kmod-acerhdf-v0.1.1_GH0.tar.gz) = 7594
diff --git a/sysutils/acerhdf-kmod/pkg-descr b/sysutils/acerhdf-kmod/pkg-descr
new file mode 100644
index 000000000000..eeff293c4db1
--- /dev/null
+++ b/sysutils/acerhdf-kmod/pkg-descr
@@ -0,0 +1,12 @@
+The acerhdf kernel module allows you to control the fans of some of
+the Acer Aspire One netbook models. This includes the models Acer
+AO521, Acer AO531h, Acer AO751h Acer Aspire 1410, Acer Aspire 1810T,
+Acer Aspire 1810TZ, Acer Aspire 1825PTZ, Acer Aspire 5315, Acer Aspire
+5739G, Acer Aspire 5755G, Acer Aspire One 753, Acer Aspire One A110,
+Acer Aspire One A150, Acer Extensa 5420, Acer LT-10Q, Acer TM8573T,
+Acer TravelMate 7730G, Gateway AOA110, Gateway AOA150, Gateway LT31,
+Packard Bell AOA110, Packard Bell AOA150, Packard Bell DOA150, Packard
+Bell DOTMA, Packard Bell DOTMU, Packard Bell DOTVR46, and Packard Bell
+ENBFT.
+
+WWW: https://github.com/t6/kmod-acerhdf
diff --git a/sysutils/acerhdf-kmod/pkg-message b/sysutils/acerhdf-kmod/pkg-message
new file mode 100644
index 000000000000..4cdecff890df
--- /dev/null
+++ b/sysutils/acerhdf-kmod/pkg-message
@@ -0,0 +1,11 @@
+The acerhdf fan control is disabled by default. To enable it add the
+following settings to /boot/loader.conf
+
+ acerhdf_load="YES"
+
+and to /etc/sysctl.conf
+
+ dev.acerhdf.0.enabled=1
+
+Refer to acerhdf(4) for additonal settings. Choose wisely and be
+careful that your system does not overheat!
diff --git a/sysutils/acerhdf-kmod/pkg-plist b/sysutils/acerhdf-kmod/pkg-plist
new file mode 100644
index 000000000000..970faf474c1c
--- /dev/null
+++ b/sysutils/acerhdf-kmod/pkg-plist
@@ -0,0 +1,2 @@
+/%%KMODDIR%%/acerhdf.ko
+man/man4/acerhdf.4.gz