aboutsummaryrefslogtreecommitdiff
path: root/sysutils/afio
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-22 11:14:57 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-22 11:14:57 +0000
commit64e88d1acf13b52c1188c437367b3651ac16170f (patch)
tree31b4f00f599fbbb02a719bd2de007a80c09d00ee /sysutils/afio
parenteabe5ffb0c78f15cb87cde1b5a6a8a1f05fbaadd (diff)
downloadports-64e88d1acf13b52c1188c437367b3651ac16170f.tar.gz
ports-64e88d1acf13b52c1188c437367b3651ac16170f.zip
Notes
Diffstat (limited to 'sysutils/afio')
-rw-r--r--sysutils/afio/Makefile15
-rw-r--r--sysutils/afio/distinfo6
-rw-r--r--sysutils/afio/files/patch-aa196
-rw-r--r--sysutils/afio/files/patch-ab116
-rw-r--r--sysutils/afio/pkg-plist32
5 files changed, 245 insertions, 120 deletions
diff --git a/sysutils/afio/Makefile b/sysutils/afio/Makefile
index 69260a852f61..91bba3726b60 100644
--- a/sysutils/afio/Makefile
+++ b/sysutils/afio/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= afio
-PORTVERSION= 2.4.7
-PORTREVISION= 1
+PORTVERSION= 2.5
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= system/backup
@@ -23,12 +22,12 @@ post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@(cd ${WRKSRC} ; ${INSTALL_MAN} README SCRIPTS ${DOCSDIR})
- @${MKDIR} ${PREFIX}/share/examples/afio
- @${INSTALL_SCRIPT} ${FILESDIR}/afiodump.example ${PREFIX}/share/examples/afio
- @${INSTALL_DATA} ${WRKSRC}/script1/DONTDUMP ${PREFIX}/share/examples/afio
- @${INSTALL_SCRIPT} ${WRKSRC}/script2/* ${PREFIX}/share/examples/afio
- @${INSTALL_SCRIPT} ${WRKSRC}/script3/* ${PREFIX}/share/examples/afio
- @${INSTALL_SCRIPT} ${WRKSRC}/script4/* ${PREFIX}/share/examples/afio
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_SCRIPT} ${FILESDIR}/afiodump.example ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/script1/DONTDUMP ${EXAMPLESDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/script2/* ${EXAMPLESDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/script3/* ${EXAMPLESDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/script4/* ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/sysutils/afio/distinfo b/sysutils/afio/distinfo
index c5109a9eee8c..ad3d666e4a71 100644
--- a/sysutils/afio/distinfo
+++ b/sysutils/afio/distinfo
@@ -1,3 +1,3 @@
-MD5 (afio-2.4.7.tgz) = 28fd6daa7805ee2263879ff1b9c96a9e
-SHA256 (afio-2.4.7.tgz) = a00a5c26c2f323ca87cb82278915391537ac25327d27510bbca3b8b482e36899
-SIZE (afio-2.4.7.tgz) = 91224
+SIZE (afio-2.5.tgz) = 179184
+MD5 (afio-2.5.tgz) = 8c6665e0f875dcd8e1bdb18644b59688
+SHA256 (afio-2.5.tgz) = e7801a0f0a8dcbae41f4156dee5dae2a34a558d6c3ceac517efad4fed610ff2e
diff --git a/sysutils/afio/files/patch-aa b/sysutils/afio/files/patch-aa
index 4f46eba8cab4..e3afe85d5bac 100644
--- a/sysutils/afio/files/patch-aa
+++ b/sysutils/afio/files/patch-aa
@@ -1,60 +1,136 @@
---- Makefile.orig Thu Nov 25 22:42:26 1999
-+++ Makefile Thu Jan 27 15:03:54 2000
-@@ -26,14 +26,14 @@
- c = -DHAVEMEMCMP
- ## Define DEFFMTCMD to being how to format the media you use the most
- ## This is the DEFault FoRMat CoManD.
--d = -DDEFFMTCMD='"fdformat /dev/fd0H1440"'
-+d = -DDEFFMTCMD='"/usr/bin/fdformat -f 1440 /dev/fd0.1440"'
- ## Define LONGZFILE if you want .Z to be tagged on the end of a 14 char
- ## file name (or longer for BSD) in the archive when the file is compressed
- #e = -DLONGZFILE
-
- ## Define PRG_COMPRESS to get something other than `gzip'.
- # you need to edit compfile.c (-G option) if you change this line.
--f = -DPRG_COMPRESS='"gzip"'
-+f = -DPRG_COMPRESS='"/usr/bin/gzip"'
-
- ## Define HAVEFNMATCH if you want to use the gnu fnmatch() routine for
- # -y -Y -w -W matching.
-@@ -43,6 +43,11 @@
-
- g = -DHAVEFNMATCH
-
-+## Define HAVE_PARAM_H if your system has sys/param.h. This is used for BSD
-+# detection.
-+
-+h = -DHAVE_PARAM_H
-+
- # fnmatch() is in the gnu C library, so it is directly available on
- # Linux. If your system (e.g. SCO) does not have the gnu C library,
- # unpack the archive gnu.fnmatch.tar.gz and uncomment the following
-@@ -56,13 +61,14 @@
-
- #CFLAGS1 = -ggdb
- #CFLAGS1 = -Wall -s -g -O2 -fomit-frame-pointer
--CFLAGS1 = -Wall -O2 -fomit-frame-pointer
-+#CFLAGS1 = -Wall -O2 -fomit-frame-pointer
-+CFLAGS1 = -fomit-frame-pointer -fno-strength-reduce
-
-
--CC=gcc
-+#CC=gcc
-
-
--CFLAGS = ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e $f $g $I
-+CFLAGS += ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e $f $g $h $I
- LDFLAGS =
-
- afio : afio.o compfile.o exten.o match.o $M
-@@ -72,8 +78,8 @@
- rm -f *.o afio
-
- install: afio
-- cp afio /usr/bin
-- cp afio.1 /usr/man/man1
-+ install -cs -o root -g wheel afio ${PREFIX}/bin
-+ install -c -o root -g wheel afio.1 ${PREFIX}/man/man1
-
-
- afio.o : afio.h patchlevel.h
+*** Makefile.orig Sun Dec 21 05:23:51 2003
+--- Makefile Sat Jan 21 17:34:53 2006
+***************
+*** 26,56 ****
+ #b = -UUNIXPC
+ ## Define HAVEMEMCMP if you have memcmp otherwise assumes bcmp
+ c = -DHAVEMEMCMP
+ ## Define DEFFMTCMD to being how to format the media you use the most
+ ## This is the DEFault FoRMat CoManD.
+! d = -DDEFFMTCMD='"fdformat /dev/fd0H1440"'
+ ## Define LONGZFILE if you want .Z to be tagged on the end of a 14 char
+ ## file name (or longer for BSD) in the archive when the file is compressed
+ #e = -DLONGZFILE
+
+ ## Define HAVE_LCHOWN is the system has an lchown call (like chown but does
+ ## not follow symlinks)
+ e2 = -DHAVE_LCHOWN
+
+ ## Define PRG_COMPRESS to get something other than `gzip'.
+ # you need to edit compfile.c (-G option) if you change this line.
+! f = -DPRG_COMPRESS='"gzip"'
+
+ ## Define HAVEFNMATCH if you want to use the gnu fnmatch() routine for
+ # -y -Y -w -W matching.
+ # If it is not defined, a primitive replacement match routine is used that
+ # only supports patterns of the form "cccc" and "cccc*". Make sure that
+ # you change the manual page in this case.
+
+ g = -DHAVEFNMATCH
+
+ # fnmatch() is in the gnu C library, so it is directly available on
+ # Linux. If your system (e.g. SCO) does not have the gnu C library,
+ # unpack the archive gnu.fnmatch.tar.gz and uncomment the following
+ # two lines:
+
+--- 26,61 ----
+ #b = -UUNIXPC
+ ## Define HAVEMEMCMP if you have memcmp otherwise assumes bcmp
+ c = -DHAVEMEMCMP
+ ## Define DEFFMTCMD to being how to format the media you use the most
+ ## This is the DEFault FoRMat CoManD.
+! d = -DDEFFMTCMD='"/usr/sbin/fdformat -f 1440 /dev/fd0"'
+ ## Define LONGZFILE if you want .Z to be tagged on the end of a 14 char
+ ## file name (or longer for BSD) in the archive when the file is compressed
+ #e = -DLONGZFILE
+
+ ## Define HAVE_LCHOWN is the system has an lchown call (like chown but does
+ ## not follow symlinks)
+ e2 = -DHAVE_LCHOWN
+
+ ## Define PRG_COMPRESS to get something other than `gzip'.
+ # you need to edit compfile.c (-G option) if you change this line.
+! f = -DPRG_COMPRESS='"/usr/bin/gzip"'
+
+ ## Define HAVEFNMATCH if you want to use the gnu fnmatch() routine for
+ # -y -Y -w -W matching.
+ # If it is not defined, a primitive replacement match routine is used that
+ # only supports patterns of the form "cccc" and "cccc*". Make sure that
+ # you change the manual page in this case.
+
+ g = -DHAVEFNMATCH
+
++ ## Define HAVE_PARAM_H if your system has sys/param.h. This is used for BSD
++ # detection.
++
++ h = -DHAVE_PARAM_H
++
+ # fnmatch() is in the gnu C library, so it is directly available on
+ # Linux. If your system (e.g. SCO) does not have the gnu C library,
+ # unpack the archive gnu.fnmatch.tar.gz and uncomment the following
+ # two lines:
+
+***************
+*** 69,83 ****
+
+ # even more warnings flags..
+ MW=
+ #MW=-Wtraditional -Wcast-qual -Wcast-align -Wconversion -pedantic -Wlong-long -Wimplicit -Wuninitialized -W -Wshadow -Wsign-compare -Wstrict-prototypes -Wmissing-declarations
+
+! CFLAGS1 = -Wall -Wstrict-prototypes -s -O2 -fomit-frame-pointer ${LARGEFILEFLAGS} ${MW}
+
+! CC=gcc
+
+! CFLAGS = ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e ${e2} $f $g $I
+ LDFLAGS =
+
+ afio : afio.o compfile.o exten.o match.o $M
+ ${CC} ${LDFLAGS} afio.o compfile.o exten.o match.o $M -o afio
+
+--- 74,91 ----
+
+ # even more warnings flags..
+ MW=
+ #MW=-Wtraditional -Wcast-qual -Wcast-align -Wconversion -pedantic -Wlong-long -Wimplicit -Wuninitialized -W -Wshadow -Wsign-compare -Wstrict-prototypes -Wmissing-declarations
+
+! #CFLAGS1 = -Wall -Wstrict-prototypes -s -O2 -fomit-frame-pointer ${LARGEFILEFLAGS} ${MW}
+! CFLAGS1 = -fomit-frame-pointer -fno-strength-reduce
+
+! #CC=gcc
+! CC=cc
+
+! #CFLAGS = ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e ${e2} $f $g $I
+! CFLAGS += ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e $f $g $h $I
+ LDFLAGS =
+
+ afio : afio.o compfile.o exten.o match.o $M
+ ${CC} ${LDFLAGS} afio.o compfile.o exten.o match.o $M -o afio
+
+***************
+*** 86,97 ****
+ rm -f regtest/cmpstat regtest/makesparse
+ rm -f regtest/statsize regtest/statsize64
+ cd regtest; /bin/sh regtest.clean
+
+ install: afio
+! cp afio /usr/local/bin
+! cp afio.1 /usr/share/man/man1
+
+ # generate default list of -E extensions from manpage
+ # note: on sun, I had to change awk command below to nawk or gawk
+ # to get it to work.
+ exten_default.h : afio.1
+--- 94,106 ----
+ rm -f regtest/cmpstat regtest/makesparse
+ rm -f regtest/statsize regtest/statsize64
+ cd regtest; /bin/sh regtest.clean
+
+ install: afio
+! install -cs -o root -g wheel afio ${PREFIX}/bin
+! install -c -o root -g wheel afio.1 ${PREFIX}/man/man1
+!
+
+ # generate default list of -E extensions from manpage
+ # note: on sun, I had to change awk command below to nawk or gawk
+ # to get it to work.
+ exten_default.h : afio.1
diff --git a/sysutils/afio/files/patch-ab b/sysutils/afio/files/patch-ab
index fae1131cd3c1..cce0a343ebcc 100644
--- a/sysutils/afio/files/patch-ab
+++ b/sysutils/afio/files/patch-ab
@@ -1,33 +1,83 @@
---- afio.c.orig Tue Oct 9 23:03:53 2001
-+++ afio.c Mon Sep 29 16:34:02 2003
-@@ -613,7 +613,7 @@
- aruntil, arbsize);
- #else
- fprintf (stderr, "Media size %ld is less than block size %d\n",
-- (ulong) aruntil, arbsize);
-+ (u_long) aruntil, arbsize);
- #endif
- usage ();
- }
-@@ -2929,10 +2929,10 @@
- see out().
- */
- if(asb->sb_rdev==0) asb->sb_rdev=(asb->sb_dev << 16) + asb->sb_ino;
-- if (mknod (name, asb->sb_mode, asb->sb_rdev) < 0
-+ if (mkfifo (name, asb->sb_mode) < 0
- && (errno != ENOENT
- || dirneed (name) < 0
-- || mknod (name, asb->sb_mode, asb->sb_rdev) < 0))
-+ || mkfifo (name, asb->sb_mode) < 0))
- return (warn (name, syserr ()));
- break;
- case S_IFDIR:
-@@ -2960,7 +2960,7 @@
- return (warn (name, syserr ()));
- break;
- #endif /* S_IFIFO */
--#ifdef S_IFSOCK
-+#ifdef S_IFSOCK && !defined (__FreeBSD__)
- case S_IFSOCK:
- fd = 0;
- if (exists)
+*** afio.c.orig Sat Dec 20 17:16:13 2003
+--- afio.c Sat Jan 21 17:31:23 2006
+***************
+*** 648,658 ****
+ daniel.andersson@sto.sema.se */
+ fprintf (stderr, "Media size %ld is less than block size %d\n",
+ aruntil, arbsize);
+ #else
+ fprintf (stderr, "Media size %ld is less than block size %d\n",
+! (unsigned long) aruntil, arbsize);
+ #endif
+ usage ();
+ }
+ if (arpad == 0)
+ arpad = arbsize;
+--- 648,658 ----
+ daniel.andersson@sto.sema.se */
+ fprintf (stderr, "Media size %ld is less than block size %d\n",
+ aruntil, arbsize);
+ #else
+ fprintf (stderr, "Media size %ld is less than block size %d\n",
+! (u_long) aruntil, arbsize);
+ #endif
+ usage ();
+ }
+ if (arpad == 0)
+ arpad = arbsize;
+***************
+*** 3155,3168 ****
+ return (warn (name, syserr ()));
+ else
+ exists = 0;
+ }
+
+! if (mknod (name, asb->sb_mode, asb->sb_rdev) < 0
+ && (errno != ENOENT
+ || dirneed (name) < 0
+! || mknod (name, asb->sb_mode, asb->sb_rdev) < 0))
+ return (warn (name, syserr ()));
+ break;
+ case S_IFDIR:
+ if (exists)
+ {
+--- 3155,3168 ----
+ return (warn (name, syserr ()));
+ else
+ exists = 0;
+ }
+
+! if (mkfifo (name, asb->sb_mode) < 0
+ && (errno != ENOENT
+ || dirneed (name) < 0
+! || mkfifo (name, asb->sb_mode) < 0))
+ return (warn (name, syserr ()));
+ break;
+ case S_IFDIR:
+ if (exists)
+ {
+***************
+*** 3194,3204 ****
+ || dirneed (name) < 0
+ || mkfifo (name, asb->sb_mode) < 0))
+ return (warn (name, syserr ()));
+ break;
+ #endif /* S_IFIFO */
+! #ifdef S_IFSOCK
+ case S_IFSOCK:
+ fd = 0;
+ if (exists)
+ if (perm != operm && chmod (name, perm) < 0)
+ return (warn (name, syserr ()));
+--- 3194,3204 ----
+ || dirneed (name) < 0
+ || mkfifo (name, asb->sb_mode) < 0))
+ return (warn (name, syserr ()));
+ break;
+ #endif /* S_IFIFO */
+! #ifdef S_IFSOCK && !defined (__FreeBSD__)
+ case S_IFSOCK:
+ fd = 0;
+ if (exists)
+ if (perm != operm && chmod (name, perm) < 0)
+ return (warn (name, syserr ()));
diff --git a/sysutils/afio/pkg-plist b/sysutils/afio/pkg-plist
index 62460d2b835f..504ace4dd7f0 100644
--- a/sysutils/afio/pkg-plist
+++ b/sysutils/afio/pkg-plist
@@ -1,17 +1,17 @@
bin/afio
-%%PORTDOCS%%share/doc/afio/README
-%%PORTDOCS%%share/doc/afio/SCRIPTS
-%%PORTDOCS%%share/examples/afio/DONTDUMP
-%%PORTDOCS%%share/examples/afio/README
-%%PORTDOCS%%share/examples/afio/afiodump.example
-%%PORTDOCS%%share/examples/afio/backup
-%%PORTDOCS%%share/examples/afio/gnupg_read
-%%PORTDOCS%%share/examples/afio/gnupg_write
-%%PORTDOCS%%share/examples/afio/pgp_read
-%%PORTDOCS%%share/examples/afio/pgp_write
-%%PORTDOCS%%share/examples/afio/restore
-%%PORTDOCS%%share/examples/afio/tapechange
-%%PORTDOCS%%share/examples/afio/x.dot
-%%PORTDOCS%%share/examples/afio/x.home
-%%PORTDOCS%%@dirrm share/doc/afio
-%%PORTDOCS%%@dirrm share/examples/afio
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/SCRIPTS
+%%PORTDOCS%%%%EXAMPLESDIR%%/DONTDUMP
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/afiodump.example
+%%PORTDOCS%%%%EXAMPLESDIR%%/backup
+%%PORTDOCS%%%%EXAMPLESDIR%%/gnupg_read
+%%PORTDOCS%%%%EXAMPLESDIR%%/gnupg_write
+%%PORTDOCS%%%%EXAMPLESDIR%%/pgp_read
+%%PORTDOCS%%%%EXAMPLESDIR%%/pgp_write
+%%PORTDOCS%%%%EXAMPLESDIR%%/restore
+%%PORTDOCS%%%%EXAMPLESDIR%%/tapechange
+%%PORTDOCS%%%%EXAMPLESDIR%%/x.dot
+%%PORTDOCS%%%%EXAMPLESDIR%%/x.home
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%