aboutsummaryrefslogtreecommitdiff
path: root/sysutils/afio
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2019-04-27 15:40:45 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2019-04-27 15:40:45 +0000
commitdee33b4bb2b0734aaff4ef636fc49c5186e174f6 (patch)
tree5859608b56cf2f9321b80aa10d24d01b218f8f0f /sysutils/afio
parent662f2fc7a1c5335c47f59ef4f4c3318b9cb9986a (diff)
downloadports-dee33b4bb2b0734aaff4ef636fc49c5186e174f6.tar.gz
ports-dee33b4bb2b0734aaff4ef636fc49c5186e174f6.zip
Notes
Diffstat (limited to 'sysutils/afio')
-rw-r--r--sysutils/afio/Makefile11
-rw-r--r--sysutils/afio/distinfo5
-rw-r--r--sysutils/afio/files/patch-Makefile32
-rw-r--r--sysutils/afio/files/patch-afio.c94
-rw-r--r--sysutils/afio/files/patch-afio.h4
-rw-r--r--sysutils/afio/files/patch-compfile.c10
-rw-r--r--sysutils/afio/files/pkg-message.in2
-rw-r--r--sysutils/afio/pkg-descr13
8 files changed, 49 insertions, 122 deletions
diff --git a/sysutils/afio/Makefile b/sysutils/afio/Makefile
index 76d07efc2958..b339243fac3b 100644
--- a/sysutils/afio/Makefile
+++ b/sysutils/afio/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= afio
-PORTVERSION= 2.5
-PORTREVISION= 1
+PORTVERSION= 2.5.2
CATEGORIES= sysutils
-MASTER_SITES= SUNSITE/system/backup
+MASTER_SITES= http://members.chello.nl/~k.holtman/
MAINTAINER= portmaster@BSDforge.com
COMMENT= Archiver and backup program with builtin compression
@@ -13,8 +12,10 @@ COMMENT= Archiver and backup program with builtin compression
LICENSE= ART20 BSD2CLAUSE
LICENSE_COMB= multi
-USES= tar:tgz shebangfix
-SHEBANG_FILES= script1/backup script2/backup
+USES= tar:tgz
+
+EXAMPLES_USES= shebangfix
+EXAMPLES_SHEBANG_FILES= ${WRKSRC}/script1/backup ${WRKSRC}/script2/backup
ALL_TARGET= ${PORTNAME}
diff --git a/sysutils/afio/distinfo b/sysutils/afio/distinfo
index 354877b30cb2..cad15e9ddc38 100644
--- a/sysutils/afio/distinfo
+++ b/sysutils/afio/distinfo
@@ -1,2 +1,3 @@
-SHA256 (afio-2.5.tgz) = e7801a0f0a8dcbae41f4156dee5dae2a34a558d6c3ceac517efad4fed610ff2e
-SIZE (afio-2.5.tgz) = 179184
+TIMESTAMP = 1555483777
+SHA256 (afio-2.5.2.tgz) = c64ca14109df547e25702c9f3a9ca877881cd4bf38dcbe90fbd09c8d294f42b9
+SIZE (afio-2.5.2.tgz) = 194030
diff --git a/sysutils/afio/files/patch-Makefile b/sysutils/afio/files/patch-Makefile
index 565e41d06545..f9ab01181701 100644
--- a/sysutils/afio/files/patch-Makefile
+++ b/sysutils/afio/files/patch-Makefile
@@ -1,9 +1,9 @@
---- Makefile.orig 2003-12-21 10:23:51 UTC
+--- Makefile.orig 2018-11-30 14:25:04 UTC
+++ Makefile
@@ -28,7 +28,7 @@ SHELL=/bin/sh
c = -DHAVEMEMCMP
## Define DEFFMTCMD to being how to format the media you use the most
- ## This is the DEFault FoRMat CoManD.
+ ## This is the DEFault FoRMat CoManD.
-d = -DDEFFMTCMD='"fdformat /dev/fd0H1440"'
+d = -DDEFFMTCMD='"/usr/sbin/fdformat -f 1440 /dev/fd0"'
## Define LONGZFILE if you want .Z to be tagged on the end of a 14 char
@@ -25,30 +25,31 @@
+## Define HAVE_PARAM_H if your system has sys/param.h. This is used for BSD
+# detection.
+
-+h = -DHAVE_PARAM_H
++h = -DHAVE_PARAM_H
+
# fnmatch() is in the gnu C library, so it is directly available on
# Linux. If your system (e.g. SCO) does not have the gnu C library,
# unpack the archive gnu.fnmatch.tar.gz and uncomment the following
-@@ -71,11 +76,14 @@ LARGEFILEFLAGS=-D_FILE_OFFSET_BITS=64 -D
- MW=
+@@ -74,13 +79,15 @@ MW=-Wformat -Werror=format-security -Wal
+ #code can be reviewed manually
#MW=-Wtraditional -Wcast-qual -Wcast-align -Wconversion -pedantic -Wlong-long -Wimplicit -Wuninitialized -W -Wshadow -Wsign-compare -Wstrict-prototypes -Wmissing-declarations
--CFLAGS1 = -Wall -Wstrict-prototypes -s -O2 -fomit-frame-pointer ${LARGEFILEFLAGS} ${MW}
-+#CFLAGS1 = -Wall -Wstrict-prototypes -s -O2 -fomit-frame-pointer ${LARGEFILEFLAGS} ${MW}
-+CFLAGS1 = -fomit-frame-pointer -fno-strength-reduce
+-CFLAGS1 = -Wall -Wstrict-prototypes -s -O2 -fomit-frame-pointer -Wno-unused-result $(LARGEFILEFLAGS) $(MW)
++#CFLAGS1 = -Wall -Wstrict-prototypes -s -O2 -fomit-frame-pointer -Wno-unused-result $(LARGEFILEFLAGS) $(MW)
++CFLAGS1 = -fomit-frame-pointer
-CC=gcc
+#CC=gcc
-+#CC=cc
--CFLAGS = ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e ${e2} $f $g $I
-+#CFLAGS = ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e ${e2} $f $g $I
-+CFLAGS += ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e $f $g $h $I
- LDFLAGS =
+ # also using contents of usin CPPFLAGS, CFLAGS, LDFLAGS out of environment
+ # variables, if they exist
+-CFLAGS += $(CFLAGS1) $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e $(e2) $f $g $I
++#CFLAGS += $(CFLAGS1) $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e $(e2) $f $g $I
++CFLAGS += $(CFLAGS1) $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e $f $g $I
+ LDFLAGS +=
+ CPPFLAGS +=
- afio : afio.o compfile.o exten.o match.o $M
-@@ -88,8 +96,9 @@ clean:
+@@ -95,8 +102,8 @@ clean:
cd regtest; /bin/sh regtest.clean
install: afio
@@ -56,7 +57,6 @@
- cp afio.1 /usr/share/man/man1
+ ${BSD_INSTALL_PROGRAM} afio ${DESTDIR}${PREFIX}/bin
+ ${BSD_INSTALL_MAN} afio.1 ${DESTDIR}${PREFIX}/man/man1
-+
# generate default list of -E extensions from manpage
# note: on sun, I had to change awk command below to nawk or gawk
diff --git a/sysutils/afio/files/patch-afio.c b/sysutils/afio/files/patch-afio.c
index cce0a343ebcc..cc5b668e0dc9 100644
--- a/sysutils/afio/files/patch-afio.c
+++ b/sysutils/afio/files/patch-afio.c
@@ -1,83 +1,11 @@
-*** afio.c.orig Sat Dec 20 17:16:13 2003
---- afio.c Sat Jan 21 17:31:23 2006
-***************
-*** 648,658 ****
- daniel.andersson@sto.sema.se */
- fprintf (stderr, "Media size %ld is less than block size %d\n",
- aruntil, arbsize);
- #else
- fprintf (stderr, "Media size %ld is less than block size %d\n",
-! (unsigned long) aruntil, arbsize);
- #endif
- usage ();
- }
- if (arpad == 0)
- arpad = arbsize;
---- 648,658 ----
- daniel.andersson@sto.sema.se */
- fprintf (stderr, "Media size %ld is less than block size %d\n",
- aruntil, arbsize);
- #else
- fprintf (stderr, "Media size %ld is less than block size %d\n",
-! (u_long) aruntil, arbsize);
- #endif
- usage ();
- }
- if (arpad == 0)
- arpad = arbsize;
-***************
-*** 3155,3168 ****
- return (warn (name, syserr ()));
- else
- exists = 0;
- }
-
-! if (mknod (name, asb->sb_mode, asb->sb_rdev) < 0
- && (errno != ENOENT
- || dirneed (name) < 0
-! || mknod (name, asb->sb_mode, asb->sb_rdev) < 0))
- return (warn (name, syserr ()));
- break;
- case S_IFDIR:
- if (exists)
- {
---- 3155,3168 ----
- return (warn (name, syserr ()));
- else
- exists = 0;
- }
-
-! if (mkfifo (name, asb->sb_mode) < 0
- && (errno != ENOENT
- || dirneed (name) < 0
-! || mkfifo (name, asb->sb_mode) < 0))
- return (warn (name, syserr ()));
- break;
- case S_IFDIR:
- if (exists)
- {
-***************
-*** 3194,3204 ****
- || dirneed (name) < 0
- || mkfifo (name, asb->sb_mode) < 0))
- return (warn (name, syserr ()));
- break;
- #endif /* S_IFIFO */
-! #ifdef S_IFSOCK
- case S_IFSOCK:
- fd = 0;
- if (exists)
- if (perm != operm && chmod (name, perm) < 0)
- return (warn (name, syserr ()));
---- 3194,3204 ----
- || dirneed (name) < 0
- || mkfifo (name, asb->sb_mode) < 0))
- return (warn (name, syserr ()));
- break;
- #endif /* S_IFIFO */
-! #ifdef S_IFSOCK && !defined (__FreeBSD__)
- case S_IFSOCK:
- fd = 0;
- if (exists)
- if (perm != operm && chmod (name, perm) < 0)
- return (warn (name, syserr ()));
+--- afio.c.orig 2018-11-30 14:25:04 UTC
++++ afio.c
+@@ -3423,7 +3423,7 @@ openotty (name, asb, linkp, ispass, dozf
+ return (warn (name, syserr ()));
+ break;
+ #endif /* S_IFIFO */
+-#ifdef S_IFSOCK
++#ifdef S_IFSOCK && !defined (__FreeBSD__)
+ case S_IFSOCK:
+ fd = 0;
+ if (exists)
diff --git a/sysutils/afio/files/patch-afio.h b/sysutils/afio/files/patch-afio.h
index efc88a9b950c..cb129dc0ef75 100644
--- a/sysutils/afio/files/patch-afio.h
+++ b/sysutils/afio/files/patch-afio.h
@@ -1,5 +1,5 @@
---- afio.h.orig Sun Sep 20 04:04:54 1998
-+++ afio.h Wed Dec 9 01:33:32 1998
+--- afio.h.orig 2018-11-30 14:25:04 UTC
++++ afio.h
@@ -1,5 +1,9 @@
/* afio.h defines for afio. */
diff --git a/sysutils/afio/files/patch-compfile.c b/sysutils/afio/files/patch-compfile.c
index 53c760f3c328..0033891212fe 100644
--- a/sysutils/afio/files/patch-compfile.c
+++ b/sysutils/afio/files/patch-compfile.c
@@ -1,11 +1,11 @@
---- compfile.c.orig Thu Nov 25 22:22:28 1999
-+++ compfile.c Thu Jan 27 14:36:31 2000
-@@ -207,7 +207,7 @@
+--- compfile.c.orig 2018-11-30 14:25:04 UTC
++++ compfile.c
+@@ -224,7 +224,7 @@ void waitforgzip()
* version;
*/
--#if ( defined(sun) && defined(__svr4__) )
-+#if ( defined(sun) && defined(__svr4__) || defined(__FreeBSD__) )
+-#if ( defined(sun) && defined(__svr4__) ) || defined(__CYGWIN32__)
++#if ( defined(sun) && defined(__svr4__) ) || defined(__FreeBSD__)
#include <dirent.h>
#else
#include <sys/dir.h>
diff --git a/sysutils/afio/files/pkg-message.in b/sysutils/afio/files/pkg-message.in
index 00fb4440a153..4058c152c6fc 100644
--- a/sysutils/afio/files/pkg-message.in
+++ b/sysutils/afio/files/pkg-message.in
@@ -5,7 +5,7 @@
PLEASE SEE
- %%PREFIX%%/share/docs/afio/README
+ %%PREFIX%%/share/doc/afio/README
for details.
diff --git a/sysutils/afio/pkg-descr b/sysutils/afio/pkg-descr
index 18706efdf425..d4153ad2c43e 100644
--- a/sysutils/afio/pkg-descr
+++ b/sysutils/afio/pkg-descr
@@ -1,9 +1,6 @@
-Afio makes cpio-format archives. It deals fairly gracefully
-with potential input data corruption. Supports multi-volume
-archives during interactive operation. Afio can make
-compressed archives that are much safer than compressed tar,
-or cpio archives. Afio has a tremendous number of options.
-Afio might be best used as an `archive engine' in a backup
-script.
+Afio makes cpio-format archives. It deals somewhat gracefully with input data
+corruption, supports multi-volume archives during interactive operation, and
+can make compressed archives that are much safer than compressed tar or cpio
+archives. Afio is best used as an `archive engine' in a backup script.
-WWW: https://BSDforge.com/projects/sysutils/afio/
+WWW: http://members.chello.nl/k.holtman/afio.html