aboutsummaryrefslogtreecommitdiff
path: root/sysutils/amazon-ssm-plugin/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2023-03-21 06:08:26 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2023-03-21 06:08:26 +0000
commitcba814b84587e1b03545aea0c68d8ac63b318ccf (patch)
tree21413f03e33f1fd6c28606a821ac49f9fc3c7a05 /sysutils/amazon-ssm-plugin/Makefile
parentd8dd1f531d8f6df9089074d166dbaa02c8aff7d3 (diff)
downloadports-cba814b84587e1b03545aea0c68d8ac63b318ccf.tar.gz
ports-cba814b84587e1b03545aea0c68d8ac63b318ccf.zip
Diffstat (limited to 'sysutils/amazon-ssm-plugin/Makefile')
-rw-r--r--sysutils/amazon-ssm-plugin/Makefile31
1 files changed, 24 insertions, 7 deletions
diff --git a/sysutils/amazon-ssm-plugin/Makefile b/sysutils/amazon-ssm-plugin/Makefile
index 21b252ef1eef..f299a8ed3e01 100644
--- a/sysutils/amazon-ssm-plugin/Makefile
+++ b/sysutils/amazon-ssm-plugin/Makefile
@@ -1,6 +1,6 @@
PORTNAME= amazon-ssm-plugin
-DISTVERSION= 1.2.398.0
-PORTREVISION= 3
+DISTVERSION= 1.2.463.0
+PORTREVISION= 0
CATEGORIES= sysutils
MAINTAINER= nork@FreeBSD.org
@@ -10,6 +10,8 @@ WWW= https://github.com/aws/session-manager-plugin/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 riscv64
+
RUN_DEPENDS= aws:devel/py-awscli@${PY_FLAVOR}
USES= go python:env
@@ -22,6 +24,19 @@ GH_ACCOUNT= aws
GH_PROJECT= session-manager-plugin
GH_TAGNAME= ${DISTVERSION}
GH_SUBDIR= ${GH_PROJECT}
+GH_TUPLE= eiannone:keyboard:6d2a597fd0f1:eiannone_keyboard/vendor/github.com/eiannone/keyboard \
+ fsnotify:fsnotify:v1.4.7:fsnotify_fsnotify/vendor/github.com/fsnotify/fsnotify \
+ golang:sync:43a5402ce75a:golang_sync/vendor/golang.org/x/sync \
+ golang:sys:v0.6.0:golang_sys/vendor/golang.org/x/sys \
+ gorilla:websocket:e8629af678b7:gorilla_websocket/vendor/github.com/gorilla/websocket \
+ jmespath:go-jmespath:c2b33e8439af:jmespath_go_jmespath/vendor/github.com/jmespath/go-jmespath \
+ stretchr:objx:cbeaeb16a013:stretchr_objx/vendor/github.com/stretchr/objx \
+ stretchr:testify:6cb3b85ef5a0:stretchr_testify/vendor/github.com/stretchr/testify \
+ twinj:uuid:70cac2bcd273:twinj_uuid/vendor/github.com/twinj/uuid \
+ xtaci:smux:09e2c01560df:xtaci_smux/vendor/github.com/xtaci/smux
+#customized# aws:aws-sdk-go:v1.40.17:aws_aws_sdk_go/vendor/github.com/aws/aws-sdk-go
+#customized# cihub:seelog:c510775bb50d:cihub_seelog/vendor/github.com/cihub/seelog
+#not found# golang:crypto:UNKNOWN:golang_org/vendor/golang.org/x/crypto
PORTDOCS= NOTICE README.md RELEASENOTES.md THIRD-PARTY VERSION
PLIST_FILES= ${ETCDIR}/sessionmanagerplugin/seelog.xml.template \
@@ -35,11 +50,13 @@ LOGDIR= ${DESTDIR}/var/log/${PORTNAME}
OPTIONS_DEFINE= DOCS
post-extract:
- ${MKDIR} ${WRKDIR}/src
- ${LN} -s ${WRKSRC} ${GO_WRKSRC}
- ${MKDIR} ${WRKSRC}/vendor/src/github.com/aws/session-manager-plugin
- ${LN} -s ${WRKSRC}/vendor/src/* ${GO_WRKSRC}/vendor/
- ${LN} -s ${WRKSRC}/src ${GO_WRKSRC}/vendor/github.com/aws/session-manager-plugin/
+ @${MKDIR} ${WRKDIR}/src
+ @${LN} -s ${WRKSRC} ${GO_WRKSRC}
+ ${MKDIR} ${WRKSRC}/vendor/github.com/aws/session-manager-plugin
+ ${LN} -s ../../../../src ${GO_WRKSRC}/vendor/github.com/aws/session-manager-plugin/
+ ${LN} -s ../src/github.com/cihub ${GO_WRKSRC}/vendor/github.com/
+ ${LN} -s ../../src/github.com/aws/aws-sdk-go ${GO_WRKSRC}/vendor/github.com/aws/
+# ${LN} -s ../../src/golang.org/x/crypto ${GO_WRKSRC}/vendor/golang.org/x/
post-patch:
${REINPLACE_CMD} -e 's|%%VERSION%%|${DISTVERSION}|' ${WRKSRC}/src/version/version.go