aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ansible
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-05-23 16:36:28 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-05-23 16:36:28 +0000
commit0e063ae0608425c8530ebff2510883fcea9bedaa (patch)
treec3e03ba092f0519bc8b00d8f806340ee823360a3 /sysutils/ansible
parenta1bfd94e05d25d5c8b00f5fabcf8f2c2006befa7 (diff)
downloadports-0e063ae0608425c8530ebff2510883fcea9bedaa.tar.gz
ports-0e063ae0608425c8530ebff2510883fcea9bedaa.zip
Notes
Diffstat (limited to 'sysutils/ansible')
-rw-r--r--sysutils/ansible/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index 607acd917082..e5c849ad5952 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -19,6 +19,9 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
+USES= shebangfix
+SHEBANG_FILES= ${WRKSRC}/library/*
+
SUB_FILES= pkg-message
PORTEXAMPLES= *
MAN1= ansible-doc.1 ansible-playbook.1 ansible-pull.1 ansible.1
@@ -40,8 +43,6 @@ post-patch-script:
${WRKSRC}/lib/ansible/constants.py \
${WRKSRC}/lib/ansible/playbook/__init__.py \
${WRKSRC}/lib/ansible/runner/__init__.py
- @${REINPLACE_CMD} -e "s|/usr/bin/python|/usr/bin/env python|" \
- ${WRKSRC}/library/*
pre-install-script:
@(cd ${WRKSRC} && ${FIND} . -type f -name '*.bak' -exec ${RM} {} +)