aboutsummaryrefslogtreecommitdiff
path: root/sysutils/anteater
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-12 07:56:38 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-12 07:56:38 +0000
commit08bbf433887d34f4407297a672db6496258cbec8 (patch)
tree76ce9b35a42efa97d3b1b4db466e7c8818a1184d /sysutils/anteater
parentda3b7d8a4ef14f85fbfeb8896e9c43e9d0319a59 (diff)
downloadports-08bbf433887d34f4407297a672db6496258cbec8.tar.gz
ports-08bbf433887d34f4407297a672db6496258cbec8.zip
Notes
Diffstat (limited to 'sysutils/anteater')
-rw-r--r--sysutils/anteater/Makefile14
-rw-r--r--sysutils/anteater/distinfo2
-rw-r--r--sysutils/anteater/files/patch-anteater_asciireport.cpp31
-rw-r--r--sysutils/anteater/files/patch-anteater_clp.cpp14
-rw-r--r--sysutils/anteater/files/patch-anteater_htmlreport.cpp14
-rw-r--r--sysutils/anteater/files/patch-anteater_report.cpp14
6 files changed, 6 insertions, 83 deletions
diff --git a/sysutils/anteater/Makefile b/sysutils/anteater/Makefile
index 79b3e8e16cc8..7c6d3a019c97 100644
--- a/sysutils/anteater/Makefile
+++ b/sysutils/anteater/Makefile
@@ -7,21 +7,17 @@
#
PORTNAME= anteater
-PORTVERSION= 0.4
+PORTVERSION= 0.4.1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.profzone.ch/drzoom/anteater/
MAINTAINER= ports@FreeBSD.org
COMMENT= A MTA log analyzer
+USE_BZIP2= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-.include <bsd.port.pre.mk>
+MAN1= anteater.1
-# You will still get configure errors on -STABLE
-# if you set CXX to a GCC3 incarnation!
-.if ${OSVERSION} < 500035
-CONFIGURE_ARGS= --enable-strstream
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/anteater/distinfo b/sysutils/anteater/distinfo
index 36003f5b2802..6455d14006f3 100644
--- a/sysutils/anteater/distinfo
+++ b/sysutils/anteater/distinfo
@@ -1 +1 @@
-MD5 (anteater-0.4.tar.gz) = b6e5438ae0255760af8e49013d900d3a
+MD5 (anteater-0.4.1.tar.bz2) = fbd67606469359ea696b28352414e784
diff --git a/sysutils/anteater/files/patch-anteater_asciireport.cpp b/sysutils/anteater/files/patch-anteater_asciireport.cpp
deleted file mode 100644
index 861baf9845df..000000000000
--- a/sysutils/anteater/files/patch-anteater_asciireport.cpp
+++ /dev/null
@@ -1,31 +0,0 @@
-
-$FreeBSD$
-
---- anteater/asciireport.cpp.orig Thu May 24 19:35:02 2001
-+++ anteater/asciireport.cpp Tue Nov 5 13:20:12 2002
-@@ -297,7 +297,7 @@
- if( !nextField() ) printSpace();
- }
-
--void asciiReport::skipField( const bool realline = true )
-+void asciiReport::skipField( const bool realline)
- {
- if( col_list.size() == 0 ) return; // Fehler.
- if( realline ) checkAutoField();
-@@ -366,14 +366,14 @@
- }
-
- /** Gibt width anzahl spaces aus. */
--void asciiReport::printSpace( const int width = 1 )
-+void asciiReport::printSpace( const int width)
- {
- int i;
- for( i = 0; i < width; i++ ) (*os).put( ' ' );
- }
-
- /** Zeichnet eine Linie über die gesammte Breite mit zeichen ch. */
--void asciiReport::printLine( const char ch = '-', const int size = -1 )
-+void asciiReport::printLine( const char ch, const int size)
- {
- int i;
- for( i = 0; i < ( size == -1 ? ScreenWidth : size ) ; i++ ) (*os).put( ch );
diff --git a/sysutils/anteater/files/patch-anteater_clp.cpp b/sysutils/anteater/files/patch-anteater_clp.cpp
deleted file mode 100644
index 4dada436efcf..000000000000
--- a/sysutils/anteater/files/patch-anteater_clp.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- anteater/clp.cpp.orig Thu May 24 19:28:50 2001
-+++ anteater/clp.cpp Tue Nov 5 13:20:12 2002
-@@ -502,7 +502,7 @@
- return true;
- };
-
--bool clp::parseError( const std::string &wrong, const long line = 0 )
-+bool clp::parseError( const std::string &wrong, const long line)
- {
- std::cerr << "Ooops! I don't understand your parameter \"" << wrong << "\"..." << std::endl;
- std::cerr << "Please check the syntax or read the manual." << std::endl << std::endl;
diff --git a/sysutils/anteater/files/patch-anteater_htmlreport.cpp b/sysutils/anteater/files/patch-anteater_htmlreport.cpp
deleted file mode 100644
index 395295321adb..000000000000
--- a/sysutils/anteater/files/patch-anteater_htmlreport.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- anteater/htmlreport.cpp.orig Thu May 24 19:14:00 2001
-+++ anteater/htmlreport.cpp Tue Nov 5 13:20:12 2002
-@@ -244,7 +244,7 @@
- nextField();
- }
-
--void htmlReport::skipField( const bool realline = true )
-+void htmlReport::skipField( const bool realline)
- {
- if( col_list.size() == 0 ) return; // Fehler.
- if( realline ) checkAutoField();
diff --git a/sysutils/anteater/files/patch-anteater_report.cpp b/sysutils/anteater/files/patch-anteater_report.cpp
deleted file mode 100644
index b9190241d14b..000000000000
--- a/sysutils/anteater/files/patch-anteater_report.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- anteater/report.cpp.orig Thu May 24 19:43:41 2001
-+++ anteater/report.cpp Tue Nov 5 13:20:12 2002
-@@ -132,7 +132,7 @@
- }
-
- void Report::addCol( const int colSize, const colTyp_e colTyp, const colAlign_e colAlign,
-- const std::string &colTitle, const colStyle_e colStyle, const unsigned long colFlags = 0 )
-+ const std::string &colTitle, const colStyle_e colStyle, const unsigned long colFlags)
- {
- if( Type == TABLE )
- {