aboutsummaryrefslogtreecommitdiff
path: root/sysutils/apcupsd/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-17 20:08:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-17 20:08:14 +0000
commit4eb9febf5af05fb1dbe70c83d9cff6e99fa28345 (patch)
tree4144287beb542a1ccb4a87a7f20c79155ee72673 /sysutils/apcupsd/Makefile
parent195e7a93dc6fc7324caeca34f5918d2a1b6b7fb4 (diff)
downloadports-4eb9febf5af05fb1dbe70c83d9cff6e99fa28345.tar.gz
ports-4eb9febf5af05fb1dbe70c83d9cff6e99fa28345.zip
Notes
Diffstat (limited to 'sysutils/apcupsd/Makefile')
-rw-r--r--sysutils/apcupsd/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/sysutils/apcupsd/Makefile b/sysutils/apcupsd/Makefile
index 665ff11b9f36..542cf787b033 100644
--- a/sysutils/apcupsd/Makefile
+++ b/sysutils/apcupsd/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A daemon for controlling APC UPS
USE_GETTEXT= yes
@@ -32,9 +32,14 @@ OPTIONS= CLIENT_ONLY "Build apcupsd client only (no network server)" off
OPTIONS+= CGI "Compile with CGI programms to show status" off
OPTIONS+= USB "Compile with USB Support (READ MANUAL!!!)" off
OPTIONS+= SNMP "Compile with SNMP Support (READ MANUAL!!!)" off
+OPTIONS+= NOPTHREADS "Compile without pthreads support (READ MANUAL!!!)" off
.include <bsd.port.pre.mk>
+.if defined(WITH_NOPTHREADS)
+CONFIGURE_ARGS+=--disable-pthreads
+.endif
+
.if defined(WITH_USB)
CONFIGURE_ARGS+=--enable-usb
.endif
@@ -82,6 +87,7 @@ pre-everything::
@${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want a network client."
@${ECHO_MSG} " WITH_USB=yes to compile with USB support (READ MANUAL!!!)"
@${ECHO_MSG} " WITH_SNMP=yes to compile with SNMP support (READ MANUAL!!!)"
+ @${ECHO_MSG} " WITH_NOPTHREADS=yes to compile without pthreads support (READ MANUAL!!!)"
@${ECHO_MSG} ""
.if defined(WITH_CGI)
@${ECHO_MSG} "===> Building with CGI support."