aboutsummaryrefslogtreecommitdiff
path: root/sysutils/apcupsd
diff options
context:
space:
mode:
authorLars Koeller <lkoeller@FreeBSD.org>2004-02-03 20:18:25 +0000
committerLars Koeller <lkoeller@FreeBSD.org>2004-02-03 20:18:25 +0000
commit847dacfab13a0af79217eefbfb68db056cada4fe (patch)
tree00f8cd8d3e6315ab55504c109c2e548c06a1c97c /sysutils/apcupsd
parent5a6b4f259b0a0620ae36cbbae9e9d97ee25d7931 (diff)
downloadports-847dacfab13a0af79217eefbfb68db056cada4fe.tar.gz
ports-847dacfab13a0af79217eefbfb68db056cada4fe.zip
Notes
Diffstat (limited to 'sysutils/apcupsd')
-rw-r--r--sysutils/apcupsd/Makefile34
-rw-r--r--sysutils/apcupsd/distinfo2
-rw-r--r--sysutils/apcupsd/pkg-message2
-rw-r--r--sysutils/apcupsd/pkg-plist12
4 files changed, 32 insertions, 18 deletions
diff --git a/sysutils/apcupsd/Makefile b/sysutils/apcupsd/Makefile
index f281ba053c39..04edfa0190e8 100644
--- a/sysutils/apcupsd/Makefile
+++ b/sysutils/apcupsd/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= apcupsd
-PORTVERSION= 3.10.9
-PORTREVISION= 3
+PORTVERSION= 3.10.11
+#PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,8 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= Lars.Koeller@Uni-Bielefeld.de
COMMENT= A daemon for controlling APC UPS
-LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext-old \
- gd.4:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= intl.6:${PORTSDIR}/devel/gettext
USE_REINPLACE= yes
@@ -28,8 +27,20 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --sbindir=${PREFIX}/sbin \
--with-nologin=/var/run \
--disable-install-distdir --enable-usb \
--sysconfdir=${PREFIX}/etc/apcupsd \
- --with-serial-dev=/dev/usv \
- --enable-cgi --with-cgi-bin=${PREFIX}/etc/apcupsd/cgi
+ --with-serial-dev=/dev/usv
+
+# We need this below
+CONF_FILES=apcupsd.conf
+
+.if defined(WITH_CGI)
+CONFIGURE_ARGS+=--enable-cgi --with-cgi-bin=${PREFIX}/etc/apcupsd/cgi
+LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+PLIST_SUB+= CGI=""
+CONF_FILES+= multimon.conf hosts.conf
+.else
+PLIST_SUB+= CGI="@comment "
+.endif
+
.if defined(WITH_CLIENT_ONLY)
CONFIGURE_ARGS+=--enable-net
.else
@@ -59,13 +70,16 @@ PORTDOCS= apcupsd.pdf manual.html manual.css \
wininstall5.png wininstall6.png wininstall7.png
pre-everything::
-.if !defined(WITH_CLIENT_ONLY)
@${ECHO_MSG} ""
@${ECHO_MSG} "You may use the following build options:"
@${ECHO_MSG} ""
- @${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want a network client."
+ @${ECHO_MSG} " WITH_CGI=yes if you want to build CGI support."
+ @${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want a network client."
@${ECHO_MSG} ""
-.else
+.if defined(WITH_CGI)
+ @${ECHO_MSG} "===> Building with CGI support."
+.endif
+.if defined(WITH_CLIENT_ONLY)
@${ECHO_MSG} "===> Building network client."
.endif
@@ -74,7 +88,7 @@ post-configure:
post-install:
# Check if the install presaves the configuration files
- for na in apcupsd.conf hosts.conf multimon.conf; do \
+ for na in ${CONF_FILES}; do \
if [ -f ${PREFIX}/etc/apcupsd/$$na.new ]; then \
${ECHO_CMD} "etc/apcupsd/$$na.new" >> ${TMPPLIST}; \
if cmp -s ${PREFIX}/etc/apcupsd/$$na.new ${PREFIX}/etc/apcupsd/$$na; then \
diff --git a/sysutils/apcupsd/distinfo b/sysutils/apcupsd/distinfo
index dd220b94aa2d..6679139ceb0b 100644
--- a/sysutils/apcupsd/distinfo
+++ b/sysutils/apcupsd/distinfo
@@ -1 +1 @@
-MD5 (apcupsd-3.10.9.tar.gz) = 693a4ecfecf5ae777f3ef4000f58d6fe
+MD5 (apcupsd-3.10.11.tar.gz) = 81ed03c8691a93e8502319c2e9945b71
diff --git a/sysutils/apcupsd/pkg-message b/sysutils/apcupsd/pkg-message
index edcf7e582e4e..20de38c96c12 100644
--- a/sysutils/apcupsd/pkg-message
+++ b/sysutils/apcupsd/pkg-message
@@ -1,5 +1,5 @@
**************************************************
-NOTE:
+NOTE IF you install a apcupsd server:
Change to /dev and create a softlink to usv from
the serial line the USV is connected to, e.g.
diff --git a/sysutils/apcupsd/pkg-plist b/sysutils/apcupsd/pkg-plist
index f6cb0a0081e6..6e834baf8468 100644
--- a/sysutils/apcupsd/pkg-plist
+++ b/sysutils/apcupsd/pkg-plist
@@ -13,10 +13,10 @@ etc/apcupsd/mainsback
etc/apcupsd/masterconnect
etc/apcupsd/mastertimeout
etc/apcupsd/onbattery
-etc/apcupsd/cgi/multimon.cgi
-etc/apcupsd/cgi/multimoncss.cgi
-etc/apcupsd/cgi/upsfstats.cgi
-etc/apcupsd/cgi/upsimage.cgi
-etc/apcupsd/cgi/upsstats.cgi
+%%CGI%%etc/apcupsd/cgi/multimon.cgi
+%%CGI%%etc/apcupsd/cgi/multimoncss.cgi
+%%CGI%%etc/apcupsd/cgi/upsfstats.cgi
+%%CGI%%etc/apcupsd/cgi/upsimage.cgi
+%%CGI%%etc/apcupsd/cgi/upsstats.cgi
etc/rc.d/%%STARTUP_SCRIPT%%
-@dirrm etc/apcupsd/cgi
+%%CGI%%@dirrm etc/apcupsd/cgi