aboutsummaryrefslogtreecommitdiff
path: root/sysutils/archivemount
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-06-15 12:11:22 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-06-15 12:11:22 +0000
commit7b8c843fe1aa87a01438a57b542d86128891fd98 (patch)
treec522618e7ad3f7d8aa5858195f88d46daef80766 /sysutils/archivemount
parent8e58200b71b13bddd8f458a94c6a06a6c7949f4b (diff)
downloadports-7b8c843fe1aa87a01438a57b542d86128891fd98.tar.gz
ports-7b8c843fe1aa87a01438a57b542d86128891fd98.zip
Notes
Diffstat (limited to 'sysutils/archivemount')
-rw-r--r--sysutils/archivemount/Makefile8
-rw-r--r--sysutils/archivemount/distinfo6
-rw-r--r--sysutils/archivemount/files/patch-Makefile13
-rw-r--r--sysutils/archivemount/files/patch-archivemount.c87
4 files changed, 7 insertions, 107 deletions
diff --git a/sysutils/archivemount/Makefile b/sysutils/archivemount/Makefile
index d6b76d133fd6..5a91e33f6f62 100644
--- a/sysutils/archivemount/Makefile
+++ b/sysutils/archivemount/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= archivemount
-PORTVERSION= 0.5.3
+PORTVERSION= 0.6.0
CATEGORIES= sysutils
MASTER_SITES= http://www.cybernoia.de/software/archivemount/
@@ -17,13 +17,13 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
PLIST_FILES= bin/archivemount
+MAN1= archivemount.1
+
+GNU_CONFIGURE= yes
NO_INSTALL_MANPAGES= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_GCC= 4.2+
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/archivemount ${PREFIX}/bin
-
.include <bsd.port.mk>
diff --git a/sysutils/archivemount/distinfo b/sysutils/archivemount/distinfo
index ecc6ca3aae7e..57a00accc2dc 100644
--- a/sysutils/archivemount/distinfo
+++ b/sysutils/archivemount/distinfo
@@ -1,3 +1,3 @@
-MD5 (archivemount-0.5.3.tar.gz) = 1a3b2901388c4854199471e67c303797
-SHA256 (archivemount-0.5.3.tar.gz) = 5bcb193a753395f912bdccff6fd08018ae0fba253a97087bc717ccf87682815a
-SIZE (archivemount-0.5.3.tar.gz) = 20267
+MD5 (archivemount-0.6.0.tar.gz) = fb3ee53b1234b4cc25b5f9ad7e4e3d6d
+SHA256 (archivemount-0.6.0.tar.gz) = 3e491dee36485c7e9be1cd561ccf27c84492b8770ddafa57f18966312cb8caea
+SIZE (archivemount-0.6.0.tar.gz) = 187117
diff --git a/sysutils/archivemount/files/patch-Makefile b/sysutils/archivemount/files/patch-Makefile
deleted file mode 100644
index d26b4f547946..000000000000
--- a/sysutils/archivemount/files/patch-Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.orig 2006-12-28 18:32:47.000000000 +0300
-+++ Makefile 2008-06-20 20:04:50.000000000 +0400
-@@ -12,8 +12,8 @@
- CC = gcc
- all: $(EXE)
-
--CFLAGS += -D_FILE_OFFSET_BITS=64
--LDFLAGS = -larchive -lfuse
-+CFLAGS += -D_FILE_OFFSET_BITS=64 -I/usr/local/include/fuse
-+LDFLAGS = -larchive -liconv -lfuse -pthread -L/usr/local/lib
-
- ifeq ($(DEBUG),1)
- CFLAGS += -ggdb -O0
diff --git a/sysutils/archivemount/files/patch-archivemount.c b/sysutils/archivemount/files/patch-archivemount.c
deleted file mode 100644
index 0a505755f0b4..000000000000
--- a/sysutils/archivemount/files/patch-archivemount.c
+++ /dev/null
@@ -1,87 +0,0 @@
---- archivemount.c.orig 2006-12-28 18:32:47.000000000 +0300
-+++ archivemount.c 2008-06-20 20:31:46.000000000 +0400
-@@ -19,7 +19,7 @@
- #define _GNU_SOURCE 1
- #endif
-
--#define FUSE_USE_VERSION 22
-+#define FUSE_USE_VERSION 25
- #define MAXBUF 4096
-
- #include <fuse.h>
-@@ -31,7 +31,9 @@
- #include <fcntl.h>
- #include <dirent.h>
- #include <errno.h>
-+#ifdef HAVE_STATFS
- #include <sys/statfs.h>
-+#endif
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <time.h>
-@@ -42,6 +44,7 @@
- #include <wchar.h>
- #include <archive.h>
- #include <archive_entry.h>
-+#include <limits.h>
-
- /**********/
- /* macros */
-@@ -433,9 +436,14 @@
- strlen( P_tmpdir ) +
- strlen( "_archivemount" ) +
- strlen( tmppath ) + 8 );
-- sprintf( *location, "%s/archivemount%s_XXXXXX", P_tmpdir, tmppath );
-+ sprintf( *location, "/tmp/archivemount%s_XXXXXX", tmppath );
- free( tmppath );
-- if( ( fh = mkstemp( *location ) == -1 ) ) {
-+
-+ char bsdLocation[PATH_MAX];
-+
-+ strcpy(bsdLocation, *location);
-+
-+ if( ( fh = mkstemp(bsdLocation ) == -1 ) ) {
- log( "Could not create temp file name %s: %s",
- *location, strerror( errno ) );
- free( *location );
-@@ -1449,7 +1457,13 @@
- return tmp;
- }
- /* create temp file */
-- if( mknod( location, mode, rdev ) == -1 ) {
-+ if (S_ISREG( mode )) {
-+ tmp = open( location, O_CREAT | O_EXCL | O_WRONLY, mode );
-+ } else if (S_ISFIFO( mode ))
-+ tmp = mkfifo( location, mode );
-+ else
-+ tmp = mknod( location, mode, rdev );
-+ if( tmp == -1 ) {
- log( "Could not create temporary file %s: %s",
- location, strerror( errno ) );
- free( location );
-@@ -1604,6 +1618,7 @@
- return 0;
- }
-
-+#ifdef HAVE_STATFS
- static int
- ar_statfs( const char *path, struct statfs *stbuf )
- {
-@@ -1613,6 +1628,7 @@
-
- return -ENOSYS;
- }
-+#endif
-
- static int
- ar_rename( const char *from, const char *to )
-@@ -1753,7 +1769,9 @@
- .open = ar_open,
- .read = ar_read,
- .write = ar_write,
-+#ifdef HAVE_STATFS
- .statfs = ar_statfs,
-+#endif
- .release = ar_release,
- .fsync = ar_fsync,
- /*