aboutsummaryrefslogtreecommitdiff
path: root/sysutils/automounter
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-05-12 23:14:21 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-05-12 23:14:21 +0000
commit614651311e4301538c12097eca049732d22e6f66 (patch)
treee59e8db4f159da4ef11c825cc462168dc4f11371 /sysutils/automounter
parent35bd76563df96b743c6ceead3226aef10b6ca2ad (diff)
downloadports-614651311e4301538c12097eca049732d22e6f66.tar.gz
ports-614651311e4301538c12097eca049732d22e6f66.zip
Notes
Diffstat (limited to 'sysutils/automounter')
-rw-r--r--sysutils/automounter/Makefile34
-rw-r--r--sysutils/automounter/distinfo3
-rw-r--r--sysutils/automounter/pkg-descr11
-rw-r--r--sysutils/automounter/pkg-plist3
4 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/automounter/Makefile b/sysutils/automounter/Makefile
new file mode 100644
index 000000000000..719c70d22b29
--- /dev/null
+++ b/sysutils/automounter/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: automounter
+# Date created: 26 March 2008
+# Whom: Dominic Fandrey <kamikaze@bsdforen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= automounter
+PORTVERSION= 1.3
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= bsdadminscripts
+
+MAINTAINER= kamikaze@bsdforen.de
+COMMENT= Provides scripts to dynamically configure amd
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+NO_BUILD= yes
+MANCOMPRESSED= no
+
+.if defined(NOPORTDOCS)
+NOPORTDOCS= -nodoc
+.else
+MAN5= automounter.conf.5
+MAN8= automounter.8
+.endif
+
+plist: patch
+ cd ${WRKSRC}; ./list.sh -nodoc > ${PLIST}
+
+do-install:
+ @cd ${WRKSRC}; ./install.sh -prefix=${PREFIX} ${NOPORTDOCS}
+
+.include <bsd.port.mk>
diff --git a/sysutils/automounter/distinfo b/sysutils/automounter/distinfo
new file mode 100644
index 000000000000..2fa5ad5db53e
--- /dev/null
+++ b/sysutils/automounter/distinfo
@@ -0,0 +1,3 @@
+MD5 (automounter-1.3.tar.gz) = 169619b12ba2de03f5da53c605336883
+SHA256 (automounter-1.3.tar.gz) = 9dc094c65abef9bb25f52ec53332c8e6bd40dea1aa1b8fc64d1ed1b136406bdc
+SIZE (automounter-1.3.tar.gz) = 13405
diff --git a/sysutils/automounter/pkg-descr b/sysutils/automounter/pkg-descr
new file mode 100644
index 000000000000..8098829bf9c6
--- /dev/null
+++ b/sysutils/automounter/pkg-descr
@@ -0,0 +1,11 @@
+A script to dynamically configure amd and populate /media with appropriate
+links, when USB mass storage devices appear. It relies on geom labels, hence
+it only works for properly labeled devices.
+
+It also allows to automatically attach geli encrypted devices and images with
+keys polled from file systems it makes mountable.
+
+WWW: http://sourceforge.net/projects/bsdadminscripts/
+
+- Kamikaze
+kamikaze@bsdforen.de
diff --git a/sysutils/automounter/pkg-plist b/sysutils/automounter/pkg-plist
new file mode 100644
index 000000000000..e59419e19447
--- /dev/null
+++ b/sysutils/automounter/pkg-plist
@@ -0,0 +1,3 @@
+sbin/automounter
+etc/rc.d/automounter
+etc/automounter.conf.sample