aboutsummaryrefslogtreecommitdiff
path: root/sysutils/autopsy/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-06-05 16:11:23 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-06-05 16:11:23 +0000
commite7e7c42c7654250b6ec6141a6756e082d8d53ab2 (patch)
tree2519367cb3075bd0260ac71e84b218849d26acd3 /sysutils/autopsy/Makefile
parent1f7fbee7d86300a8522ce9e3735de7c3fa57d62f (diff)
- Update to version 2.08
- Take maintainership - Better COMMENT - Clean up Makefile header - Mute MKDIRs
Notes
Notes: svn path=/head/; revision=192854
Diffstat (limited to 'sysutils/autopsy/Makefile')
-rw-r--r--sysutils/autopsy/Makefile24
1 files changed, 15 insertions, 9 deletions
diff --git a/sysutils/autopsy/Makefile b/sysutils/autopsy/Makefile
index 46e83697bacd..7132c708b7c7 100644
--- a/sysutils/autopsy/Makefile
+++ b/sysutils/autopsy/Makefile
@@ -1,18 +1,18 @@
-# New ports collection makefile for: autopsy
-# Date created: 2003-08-12
-# Whom: Pieter Danhieux <opr@bsdaemon.be>
+# New ports collection makefile for: autopsy
+# Date created: 2003-08-12
+# Whom: Pieter Danhieux <opr@bsdaemon.be>
#
# $FreeBSD$
#
PORTNAME= autopsy
-PORTVERSION= 2.06
+PORTVERSION= 2.08
CATEGORIES= sysutils security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= The Autopsy Forensic Browser is a GUI for Sleuthkit
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Graphical interface to The Sleuth Kit
BUILD_DEPENDS= ${LOCALBASE}/bin/ifind:${PORTSDIR}/sysutils/sleuthkit
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -21,14 +21,20 @@ USE_PERL5= yes
IS_INTERACTIVE= yes
WEB= pict/*
WEBHELP= help/*
+PERLBITS= lib/*.pm lib/*.pl conf.pl
MAN1= autopsy.1
+pre-configure:
+ @${REINPLACE_CMD} -e 's,lib/,,' ${WRKSRC}/base/autopsy.base
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/autopsy ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/lib/autopsy
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PERLBITS} ${PREFIX}/lib/autopsy
cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${MAN1} ${PREFIX}/man/man1
- ${MKDIR} ${PREFIX}/share/autopsy
- ${MKDIR} ${PREFIX}/share/autopsy/pict
- ${MKDIR} ${PREFIX}/share/autopsy/help
+ @${MKDIR} ${PREFIX}/share/autopsy/pict
+ @${MKDIR} ${PREFIX}/share/autopsy/help
cd ${WRKSRC} && ${INSTALL_DATA} ${WEB} ${PREFIX}/share/autopsy/pict
cd ${WRKSRC} && ${INSTALL_DATA} ${WEBHELP} ${PREFIX}/share/autopsy/help
+
.include <bsd.port.mk>