aboutsummaryrefslogtreecommitdiff
path: root/sysutils/avfs
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-06-22 20:30:22 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-06-22 20:30:22 +0000
commit43f653f7d95559de312fd35d07d0c7f3cb922bef (patch)
tree2f00ca00db77650ae8b43e12785a1f06c8de9e4d /sysutils/avfs
parent0d045014ae5a73a968247b47b2fa552d13cf58b2 (diff)
downloadports-43f653f7d95559de312fd35d07d0c7f3cb922bef.tar.gz
ports-43f653f7d95559de312fd35d07d0c7f3cb922bef.zip
Notes
Diffstat (limited to 'sysutils/avfs')
-rw-r--r--sysutils/avfs/Makefile62
-rw-r--r--sysutils/avfs/distinfo3
-rw-r--r--sysutils/avfs/files/patch-configure8
-rw-r--r--sysutils/avfs/pkg-descr5
-rw-r--r--sysutils/avfs/pkg-plist42
5 files changed, 120 insertions, 0 deletions
diff --git a/sysutils/avfs/Makefile b/sysutils/avfs/Makefile
new file mode 100644
index 000000000000..d346a9bbc010
--- /dev/null
+++ b/sysutils/avfs/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: avfs
+# Date created: 2008-06-14
+# Whom: Evgeny Zhirnov <jirnov@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= avfs
+PORTVERSION= 0.9.8
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= avf
+
+MAINTAINER= jirnov@gmail.com
+COMMENT= A Virtual File System
+
+BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs \
+ ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+NO_INSTALL_MANPAGES= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib -liconv"
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+
+OPTIONS= DEBUG "Enable debug" off \
+ LIBRARY "Enable library" off \
+ FUSE "Enable fuse" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.else
+CONFIGURE_ARGS+= --disable-debug
+.endif
+
+.if defined(WITH_LIBRARY)
+CONFIGURE_ARGS+= --enable-library
+PLIST_SUB+= LIBRARY=""
+.else
+CONFIGURE_ARGS+= --disable-library
+PLIST_SUB+= LIBRARY="@comment "
+.endif
+
+.if defined(WITH_FUSE)
+CONFIGURE_ARGS+= --enable-fuse
+PLIST_SUB+= FUSE=""
+.else
+CONFIGURE_ARGS+= --disable-fuse
+PLIST_SUB+= FUSE="@comment "
+.endif
+
+.if ${OSVERSION} < 600000 # Inherited from fusefs-kmod
+IGNORE= requires FreeBSD 6.x or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/avfs/distinfo b/sysutils/avfs/distinfo
new file mode 100644
index 000000000000..8661e32457f2
--- /dev/null
+++ b/sysutils/avfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (avfs-0.9.8.tar.bz2) = 5281b990251c8c3a15366ad40e4818db
+SHA256 (avfs-0.9.8.tar.bz2) = 5a45760889bdbe65a6ac11b926607681930746dff79924ad8418be1a8a10f5a7
+SIZE (avfs-0.9.8.tar.bz2) = 641756
diff --git a/sysutils/avfs/files/patch-configure b/sysutils/avfs/files/patch-configure
new file mode 100644
index 000000000000..d6f5cb28d078
--- /dev/null
+++ b/sysutils/avfs/files/patch-configure
@@ -0,0 +1,8 @@
+--- configure.orig 2007-05-31 23:54:21.000000000 +0400
++++ configure 2008-06-14 02:58:12.000000000 +0400
+@@ -1,4 +1,4 @@
+-#! /bin/sh
++#! /usr/local/bin/bash
+ # Guess values for system-dependent variables and create Makefiles.
+ # Generated by GNU Autoconf 2.60.
+ #
diff --git a/sysutils/avfs/pkg-descr b/sysutils/avfs/pkg-descr
new file mode 100644
index 000000000000..3ee8e7f3ba23
--- /dev/null
+++ b/sysutils/avfs/pkg-descr
@@ -0,0 +1,5 @@
+AVFS is a system, which enables all programs to look inside gzip, tar,
+zip, etc. files or view remote (ftp, http, dav, etc.) files, without
+recompiling the programs.
+
+WWW: http://avf.sourceforge.net/
diff --git a/sysutils/avfs/pkg-plist b/sysutils/avfs/pkg-plist
new file mode 100644
index 000000000000..343c17184584
--- /dev/null
+++ b/sysutils/avfs/pkg-plist
@@ -0,0 +1,42 @@
+%%LIBRARY%%bin/avfs-config
+%%FUSE%%bin/avfsd
+bin/davpass
+bin/ftppass
+%%FUSE%%bin/mountavfs
+%%FUSE%%bin/umountavfs
+include/avfs.h
+%%LIBRARY%%include/virtual.h
+lib/avfs/extfs/README
+lib/avfs/extfs/a
+lib/avfs/extfs/apt
+lib/avfs/extfs/audio
+lib/avfs/extfs/bpp
+lib/avfs/extfs/deb
+lib/avfs/extfs/deba
+lib/avfs/extfs/debd
+lib/avfs/extfs/dpkg
+lib/avfs/extfs/extfs.ini
+lib/avfs/extfs/ftplist
+lib/avfs/extfs/hp48
+lib/avfs/extfs/iso9660
+lib/avfs/extfs/lslR
+lib/avfs/extfs/mailfs
+lib/avfs/extfs/patchfs
+lib/avfs/extfs/rpm
+lib/avfs/extfs/rpms
+lib/avfs/extfs/trpm
+lib/avfs/extfs/u7z
+lib/avfs/extfs/uar
+lib/avfs/extfs/uarj
+lib/avfs/extfs/ucpio
+lib/avfs/extfs/uha
+lib/avfs/extfs/ulha
+lib/avfs/extfs/urar
+lib/avfs/extfs/uzip
+lib/avfs/extfs/uzoo
+%%LIBRARY%%lib/libavfs.a
+%%LIBRARY%%lib/libavfs.la
+%%LIBRARY%%lib/libavfs.so
+%%LIBRARY%%lib/libavfs.so.0
+@dirrm lib/avfs/extfs
+@dirrm lib/avfs