aboutsummaryrefslogtreecommitdiff
path: root/sysutils/backupme
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-24 10:09:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-24 10:09:04 +0000
commitdf0792e14e34406edaf4084bb84acfe8fde9e4fb (patch)
treebcfc932b7f5b668cf212cc6f29ab0c5789fa34c5 /sysutils/backupme
parent8ae37c4b69d3bc89feff5f5a671f54b07ad03a9d (diff)
downloadports-df0792e14e34406edaf4084bb84acfe8fde9e4fb.tar.gz
ports-df0792e14e34406edaf4084bb84acfe8fde9e4fb.zip
Notes
Diffstat (limited to 'sysutils/backupme')
-rw-r--r--sysutils/backupme/Makefile44
-rw-r--r--sysutils/backupme/distinfo3
-rw-r--r--sysutils/backupme/pkg-descr12
-rw-r--r--sysutils/backupme/pkg-message10
4 files changed, 69 insertions, 0 deletions
diff --git a/sysutils/backupme/Makefile b/sysutils/backupme/Makefile
new file mode 100644
index 000000000000..fb3047d87291
--- /dev/null
+++ b/sysutils/backupme/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: backupme
+# Date created: 21 May 2010
+# Whom: Yaroslav Berezhinskiy <yaroslav@berezhinskiy.org.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= backupme
+PORTVERSION= 0.1
+CATEGORIES= sysutils
+MASTER_SITES= http://backupme.org.ua/
+
+MAINTAINER= yaroslav@berezhinskiy.org.ua
+COMMENT= Flexible and easy backup utility
+
+RUN_DEPENDS= ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
+ ${SITE_PERL}/mach/Filesys/Df.pm:${PORTSDIR}/sysutils/p5-Filesys-Df \
+ ${SITE_PERL}/Filesys/DiskUsage.pm:${PORTSDIR}/sysutils/p5-Filesys-DiskUsage \
+ ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net \
+ ${SITE_PERL}/Net/SCP/Expect.pm:${PORTSDIR}/net/p5-Net-SCP-Expect \
+ ${SITE_PERL}/Net/IPv6Addr.pm:${PORTSDIR}/net-mgmt/p5-Net-IPv6Addr \
+ ${SITE_PERL}/Net/Jabber.pm:${PORTSDIR}/net-im/p5-Net-Jabber \
+ ${SITE_PERL}/Net/SSH.pm:${PORTSDIR}/net/p5-Net-SSH
+
+USE_PERL5= yes
+
+NO_BUILD= yes
+NO_INSTALL_MANPAGES= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ etc/${PORTNAME}.sample.xml
+
+do-install:
+ @${CP} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${CP} ${WRKSRC}/${PORTNAME}.sample.xml ${PREFIX}/etc/
+
+post-install:
+ @${ECHO_CMD} ""
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD} ""
+
+.include <bsd.port.mk>
diff --git a/sysutils/backupme/distinfo b/sysutils/backupme/distinfo
new file mode 100644
index 000000000000..64cdab671e2c
--- /dev/null
+++ b/sysutils/backupme/distinfo
@@ -0,0 +1,3 @@
+MD5 (backupme-0.1.tar.gz) = 35f1e4040183442484ecb203579b19cd
+SHA256 (backupme-0.1.tar.gz) = 4acb2f2d736c0914ee419a1223bb422d4aba08eb7f4a1e530926f07431bf2c6b
+SIZE (backupme-0.1.tar.gz) = 8989
diff --git a/sysutils/backupme/pkg-descr b/sysutils/backupme/pkg-descr
new file mode 100644
index 000000000000..ccce3b05493f
--- /dev/null
+++ b/sysutils/backupme/pkg-descr
@@ -0,0 +1,12 @@
+Flexible and easy backup utility.
+It can be used to backup your file system files, directories or even to
+backup databases.
+
+FEATURES:
+** Can be used with different types of archiveres (tar, rar, zip, 7z etc.);
+** Send backuped files using FTP or SCP protocol;
+** Backup MySQL and PostgreSQL databases;
+** Generate and send report via email or/and jabber.
+
+WWW: http://backupme.org.ua/
+
diff --git a/sysutils/backupme/pkg-message b/sysutils/backupme/pkg-message
new file mode 100644
index 000000000000..139ae19de631
--- /dev/null
+++ b/sysutils/backupme/pkg-message
@@ -0,0 +1,10 @@
+******************************************************************************
+* Path to main program: %%LOCALBASE%%/bin/backupme *
+* *
+* Rename and edit configuration file: *
+* cp /%%LOCALBASE%%/etc/backupme.xml.sample /%%LOCALBASE%%/etc/backupme.xml *
+* or run BackupMe with option -c /path/to/config.xml *
+* *
+* See the documentation for more information at http://backupme.org.ua *
+* Send your comments to the address: yaroslav@berezhinskiy.org.ua *
+******************************************************************************