aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bacula-server
diff options
context:
space:
mode:
authorLars Koeller <lkoeller@FreeBSD.org>2004-08-03 20:22:02 +0000
committerLars Koeller <lkoeller@FreeBSD.org>2004-08-03 20:22:02 +0000
commit54fb240d5c078f056b0418c84b17beece8882b19 (patch)
treef92248e7da7f2980ff3f067c9996a92a38cc3e8d /sysutils/bacula-server
parent253f20b45270962c5ce405bc6e453de75d485e23 (diff)
downloadports-54fb240d5c078f056b0418c84b17beece8882b19.tar.gz
ports-54fb240d5c078f056b0418c84b17beece8882b19.zip
Notes
Diffstat (limited to 'sysutils/bacula-server')
-rw-r--r--sysutils/bacula-server/Makefile19
-rw-r--r--sysutils/bacula-server/distinfo4
-rw-r--r--sysutils/bacula-server/files/chio-bacula19
-rw-r--r--sysutils/bacula-server/files/patch-autoconf-Make.common.in10
-rw-r--r--sysutils/bacula-server/files/patch-src-dird-sql_cmds.c10
5 files changed, 32 insertions, 30 deletions
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index bb4d2591374b..8cae04eeb2f4 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= bacula
-PORTVERSION= 1.34.5
-PORTREVISION= 4
+PORTVERSION= 1.34.6
+#PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bacula
@@ -43,6 +43,7 @@ OPTIONS+= WXCONSOLE "Build with wxGTK based GUI console" off
OPTIONS+= GNOMECONSOLE "Build with GNOME based GUI console" off
OPTIONS+= MYSQL "Use MySQL database instead of SqLite" off
OPTIONS+= POSTGRESQL7 "Use PostgreSQL 7.X database instead of SqLite" off
+OPTIONS+= MTX "Install mtx for control of autochanger devices" off
# Prepare if gnome-console is selected this must be happen before
# include of bsd.port.pre.mk!
@@ -98,6 +99,11 @@ PLIST_SUB+= DBTYPE=${DBTYPE}
PLIST_SUB+= SERVER=""
.endif
+# Install mtx
+.if defined(WITH_MTX)
+RUN_DEPENDS+= ${LOCALBASE}/sbin/mtx:${PORTSDIR}/misc/mtx
+.endif
+
PORTDOCS= bacula.pdf ReleaseNotes html-manual/*
pre-everything::
@@ -115,11 +121,12 @@ pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "You may use the following build options (or make config):"
@${ECHO_MSG} ""
- @${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want the file daemon."
- @${ECHO_MSG} " WITH_WXCONSOLE=yes if you only want a wxGTK based GUI console."
- @${ECHO_MSG} " WITH_GNOMECONSOLE=yes if you only want a GNOME based GUI console."
+ @${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want the file daemon."
+ @${ECHO_MSG} " WITH_WXCONSOLE=yes if you only want a wxGTK based GUI console."
+ @${ECHO_MSG} " WITH_GNOMECONSOLE=yes if you only want a GNOME based GUI console."
+ @${ECHO_MSG} " WITH_MTX=yes if you want to use mtx instead of chio for autochanger control."
.if !defined(WITH_MYSQL) && !defined(WITH_POSTGRESQL7)
- @${ECHO_MSG} " WITH_MYSQL=yes if you want MySQL instead of SqLite as the database."
+ @${ECHO_MSG} " WITH_MYSQL=yes if you want MySQL instead of SqLite as the database."
@${ECHO_MSG} " WITH_POSTGRESQL7=yes if you want PostgreSQL 7.X instead of SqLite as the database."
@${ECHO_MSG} ""
@${ECHO_MSG} "The default DB is SQLite!"
diff --git a/sysutils/bacula-server/distinfo b/sysutils/bacula-server/distinfo
index 533d40223108..5c18b8497be0 100644
--- a/sysutils/bacula-server/distinfo
+++ b/sysutils/bacula-server/distinfo
@@ -1,2 +1,2 @@
-MD5 (bacula-1.34.5.tar.gz) = 3bdccf8c9ee7e794c0035afbc529a33a
-SIZE (bacula-1.34.5.tar.gz) = 4628068
+MD5 (bacula-1.34.6.tar.gz) = 9de593cb206df126a8e27774281c5bf6
+SIZE (bacula-1.34.6.tar.gz) = 4633962
diff --git a/sysutils/bacula-server/files/chio-bacula b/sysutils/bacula-server/files/chio-bacula
index c3a4554a215a..a586cbd1e914 100644
--- a/sysutils/bacula-server/files/chio-bacula
+++ b/sysutils/bacula-server/files/chio-bacula
@@ -33,7 +33,7 @@ MTX=/bin/chio
# Set default values (see case statement below for
# free mapping of drive index and tape device
# We have a double drive Qualstar where drive 1 is the default bacula drive
-TAPE=/dev/nrsa1
+TAPE=/dev/nrsa0
DRIVE=0
# Time to wait for (un)loading
SLEEP=20
@@ -58,6 +58,11 @@ fi
# The slot number
if [ ! -z "$3" ]; then
SLOT=$3
+ # btape fill says "... slot 1 drive 0" :-(
+ if [ "$SLOT" = "slot" ]; then
+ shift
+ SLOT=$3
+ fi
fi
# Set tape device
if [ ! -z "$4" ]; then
@@ -65,16 +70,18 @@ if [ ! -z "$4" ]; then
fi
# Set drive for chio as you need
# here you can also map to any tape device
+# DRIVE is the chio drive number!
case $5 in
0)
DRIVE=0
+ TAPE=/dev/nrsa0
#DRIVE=1
#TAPE=/dev/nrsa2
;;
1)
DRIVE=1
#DRIVE=0
- #TAPE=/dev/nrsa1
+ TAPE=/dev/nrsa1
;;
esac
@@ -109,8 +116,16 @@ case ${COMMAND} in
# enable the following line if you need to eject the cartridge
mt -f ${TAPE} off
sleep 2
+ # if we have a slot, try it
+ if [ ! -z "$SLOT" ]; then
+ ${MTX} -f ${CHANGER} move drive ${DRIVE} slot $((${SLOT}-1))
+ exit $?
+ fi
+ # Try other way (works if source element information is valid for drive)
${MTX} -f ${CHANGER} return drive ${DRIVE}
# If the changer is power cycled with a tape loaded in a drive
+ # we can compute the slot in case of a complete filled magazine, with
+ # one slot free.
if [ "$?" != "0" ]; then
free_slot=`${MTX} -f ${CHANGER} stat | grep "^slot " | grep -v "FULL" | awk '{print $2}'`
free_slot=${free_slot%:}
diff --git a/sysutils/bacula-server/files/patch-autoconf-Make.common.in b/sysutils/bacula-server/files/patch-autoconf-Make.common.in
index b5e564ade083..ca86ad0ebff5 100644
--- a/sysutils/bacula-server/files/patch-autoconf-Make.common.in
+++ b/sysutils/bacula-server/files/patch-autoconf-Make.common.in
@@ -1,16 +1,6 @@
*** autoconf/Make.common.in.orig Sat Jun 19 23:16:06 2004
--- autoconf/Make.common.in Sun Jun 27 18:38:11 2004
***************
-*** 24,29 ****
---- 24,30 ----
- sysconfdir = @sysconfdir@
- scriptdir = @scriptdir@
- mandir = @mandir@/man1
-+ datadir = @datadir@
- manext = 1
-
- # Tools & program stuff
-***************
*** 43,49 ****
RANLIB = @RANLIB@
INSTALL = @INSTALL@
diff --git a/sysutils/bacula-server/files/patch-src-dird-sql_cmds.c b/sysutils/bacula-server/files/patch-src-dird-sql_cmds.c
deleted file mode 100644
index fa6be800fe38..000000000000
--- a/sysutils/bacula-server/files/patch-src-dird-sql_cmds.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/dird/sql_cmds.c 7 Feb 2004 17:27:11 -00001.22.2.7.2.3
-+++ src/dird/sql_cmds.c 23 Jul 2004 09:55:35 -0000
-@@ -261,7 +261,7 @@
- "ORDER BY StartTime ASC";
-
-
--char *uar_sel_jobid_temp = "SELECT JobId FROM temp";
-+char *uar_sel_jobid_temp = "SELECT JobId FROM temp ORDER BY StartTime ASC";
-
- char *uar_sel_all_temp1 = "SELECT * FROM temp1";