aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bacula-server
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2015-10-09 19:09:27 +0000
committerDan Langille <dvl@FreeBSD.org>2015-10-09 19:09:27 +0000
commitf2d06f6e85fc7a468bc42d3ec0dcf1b65dea521a (patch)
tree7145400c26bc1a0c6778d6dccb8727b9d54915a4 /sysutils/bacula-server
parent889ef96d0ee14c359b4af70f5335e1b1042847d9 (diff)
downloadports-f2d06f6e85fc7a468bc42d3ec0dcf1b65dea521a.tar.gz
ports-f2d06f6e85fc7a468bc42d3ec0dcf1b65dea521a.zip
Notes
Diffstat (limited to 'sysutils/bacula-server')
-rw-r--r--sysutils/bacula-server/Makefile4
-rw-r--r--sysutils/bacula-server/distinfo4
-rw-r--r--sysutils/bacula-server/files/patch-src_filed_acl.c190
-rw-r--r--sysutils/bacula-server/files/patch-src_findlib_fstype.c22
-rw-r--r--sysutils/bacula-server/pkg-plist1
5 files changed, 215 insertions, 6 deletions
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index c18b47b9fe72..ae521902f45b 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= bacula
-DISTVERSION= 7.0.5
-PORTREVISION?= 4
+DISTVERSION= 7.2.0
CATEGORIES?= sysutils
MASTER_SITES= SF/bacula/bacula/${PORTVERSION}
PKGNAMEPREFIX?= #
@@ -176,7 +175,6 @@ post-patch:
${WRKSRC}/src/tools/Makefile.in
.endif
-
.if !target(post-install)
post-install:
.if defined(WITH_CLIENT_ONLY)
diff --git a/sysutils/bacula-server/distinfo b/sysutils/bacula-server/distinfo
index 2da3469aaea7..8ffad79b3cac 100644
--- a/sysutils/bacula-server/distinfo
+++ b/sysutils/bacula-server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bacula-7.0.5.tar.gz) = 1457849eb33011b43371801b62ffa13d29bebe51be8d5a36da563b87bb094a49
-SIZE (bacula-7.0.5.tar.gz) = 3216406
+SHA256 (bacula-7.2.0.tar.gz) = 818606fe69c50c3ca21b91e609d4ac6ca08e4189419b89d3ec2e81c8c0389e1c
+SIZE (bacula-7.2.0.tar.gz) = 3301720
diff --git a/sysutils/bacula-server/files/patch-src_filed_acl.c b/sysutils/bacula-server/files/patch-src_filed_acl.c
new file mode 100644
index 000000000000..759e9e686a36
--- /dev/null
+++ b/sysutils/bacula-server/files/patch-src_filed_acl.c
@@ -0,0 +1,190 @@
+--- src/filed/acl.c.orig 2015-08-13 13:52:24 UTC
++++ src/filed/acl.c
+@@ -927,7 +927,7 @@ static bacl_rtn_code generic_set_acl_on_
+ * Define the supported ACL streams for this OS
+ */
+ static int os_access_acl_streams[1] = {
+- STREAM_ACL_DARWIN_ACCESS_ACL
++ STREAM_ACL_DARWIN_ACCESS
+ };
+ static int os_default_acl_streams[1] = {
+ -1
+@@ -988,11 +988,11 @@ static bacl_rtn_code (*os_restore_acl_st
+ * Define the supported ACL streams for these OSes
+ */
+ static int os_access_acl_streams[2] = {
+- STREAM_ACL_FREEBSD_ACCESS_ACL,
+- STREAM_ACL_FREEBSD_NFS4_ACL
++ STREAM_ACL_FREEBSD_ACCESS,
++ STREAM_ACL_FREEBSD_NFS4
+ };
+ static int os_default_acl_streams[1] = {
+- STREAM_ACL_FREEBSD_DEFAULT_ACL
++ STREAM_ACL_FREEBSD_DEFAULT
+ };
+
+ static bacl_rtn_code freebsd_backup_acl_streams(JCR *jcr, FF_PKT *ff_pkt)
+@@ -1065,7 +1065,7 @@ static bacl_rtn_code freebsd_backup_acl_
+ return bacl_rtn_fatal;
+
+ if (jcr->acl_ctx->content_length > 0) {
+- if (send_acl_stream(jcr, STREAM_ACL_FREEBSD_NFS4_ACL) == bacl_rtn_fatal)
++ if (send_acl_stream(jcr, STREAM_ACL_FREEBSD_NFS4) == bacl_rtn_fatal)
+ return bacl_rtn_fatal;
+ }
+ break;
+@@ -1077,7 +1077,7 @@ static bacl_rtn_code freebsd_backup_acl_
+ return bacl_rtn_fatal;
+
+ if (jcr->acl_ctx->content_length > 0) {
+- if (send_acl_stream(jcr, STREAM_ACL_FREEBSD_ACCESS_ACL) == bacl_rtn_fatal)
++ if (send_acl_stream(jcr, STREAM_ACL_FREEBSD_ACCESS) == bacl_rtn_fatal)
+ return bacl_rtn_fatal;
+ }
+
+@@ -1088,7 +1088,7 @@ static bacl_rtn_code freebsd_backup_acl_
+ if (generic_get_acl_from_os(jcr, BACL_TYPE_DEFAULT) == bacl_rtn_fatal)
+ return bacl_rtn_fatal;
+ if (jcr->acl_ctx->content_length > 0) {
+- if (send_acl_stream(jcr, STREAM_ACL_FREEBSD_DEFAULT_ACL) == bacl_rtn_fatal)
++ if (send_acl_stream(jcr, STREAM_ACL_FREEBSD_DEFAULT) == bacl_rtn_fatal)
+ return bacl_rtn_fatal;
+ }
+ }
+@@ -1113,13 +1113,13 @@ static bacl_rtn_code freebsd_restore_acl
+ */
+ switch (stream) {
+ case STREAM_UNIX_ACCESS_ACL:
+- case STREAM_ACL_FREEBSD_ACCESS_ACL:
++ case STREAM_ACL_FREEBSD_ACCESS:
+ case STREAM_UNIX_DEFAULT_ACL:
+- case STREAM_ACL_FREEBSD_DEFAULT_ACL:
++ case STREAM_ACL_FREEBSD_DEFAULT:
+ acl_enabled = pathconf(jcr->last_fname, _PC_ACL_EXTENDED);
+ acl_type_name = "POSIX";
+ break;
+- case STREAM_ACL_FREEBSD_NFS4_ACL:
++ case STREAM_ACL_FREEBSD_NFS4:
+ #if defined(_PC_ACL_NFS4)
+ acl_enabled = pathconf(jcr->last_fname, _PC_ACL_NFS4);
+ #endif
+@@ -1159,12 +1159,12 @@ static bacl_rtn_code freebsd_restore_acl
+ */
+ switch (stream) {
+ case STREAM_UNIX_ACCESS_ACL:
+- case STREAM_ACL_FREEBSD_ACCESS_ACL:
++ case STREAM_ACL_FREEBSD_ACCESS:
+ return generic_set_acl_on_os(jcr, BACL_TYPE_ACCESS, content, content_length);
+ case STREAM_UNIX_DEFAULT_ACL:
+- case STREAM_ACL_FREEBSD_DEFAULT_ACL:
++ case STREAM_ACL_FREEBSD_DEFAULT:
+ return generic_set_acl_on_os(jcr, BACL_TYPE_DEFAULT, content, content_length);
+- case STREAM_ACL_FREEBSD_NFS4_ACL:
++ case STREAM_ACL_FREEBSD_NFS4:
+ return generic_set_acl_on_os(jcr, BACL_TYPE_NFS4, content, content_length);
+ default:
+ break;
+@@ -1273,11 +1273,11 @@ static bacl_rtn_code (*os_restore_acl_st
+ * Define the supported ACL streams for this OS
+ */
+ static int os_access_acl_streams[1] = {
+- STREAM_ACL_TRU64_ACCESS_ACL
++ STREAM_ACL_TRU64_ACCESS
+ };
+ static int os_default_acl_streams[2] = {
+- STREAM_ACL_TRU64_DEFAULT_ACL,
+- STREAM_ACL_TRU64_DEFAULT_DIR_ACL
++ STREAM_ACL_TRU64_DEFAULT,
++ STREAM_ACL_TRU64_DEFAULT_DIR
+ };
+
+ static bacl_rtn_code tru64_backup_acl_streams(JCR *jcr, FF_PKT *ff_pkt)
+@@ -1564,8 +1564,8 @@ char *acl_strerror(int);
+ * Define the supported ACL streams for this OS
+ */
+ static int os_access_acl_streams[2] = {
+- STREAM_ACL_SOLARIS_ACLENT,
+- STREAM_ACL_SOLARIS_ACE
++ STREAM_ACL_SOLARIS_POSIX,
++ STREAM_ACL_SOLARIS_NFS4
+ };
+ static int os_default_acl_streams[1] = {
+ -1
+@@ -1653,10 +1653,10 @@ static bacl_rtn_code solaris_backup_acl_
+
+ switch (acl_type(aclp)) {
+ case ACLENT_T:
+- stream_status = send_acl_stream(jcr, STREAM_ACL_SOLARIS_ACLENT);
++ stream_status = send_acl_stream(jcr, STREAM_ACL_SOLARIS_POSIX);
+ break;
+ case ACE_T:
+- stream_status = send_acl_stream(jcr, STREAM_ACL_SOLARIS_ACE);
++ stream_status = send_acl_stream(jcr, STREAM_ACL_SOLARIS_NFS4);
+ break;
+ default:
+ break;
+@@ -1673,8 +1673,8 @@ static bacl_rtn_code solaris_restore_acl
+ acl_t *aclp;
+ int acl_enabled, error;
+
+- if (stream != STREAM_UNIX_ACCESS_ACL || stream != STREAM_ACL_SOLARIS_ACLENT ||
+- stream != STREAM_ACL_SOLARIS_ACE) {
++ if (stream != STREAM_UNIX_ACCESS_ACL || stream != STREAM_ACL_SOLARIS_POSIX ||
++ stream != STREAM_ACL_SOLARIS_NFS4) {
+ return bacl_rtn_error;
+ }
+
+@@ -1709,7 +1709,7 @@ static bacl_rtn_code solaris_restore_acl
+ * On a filesystem with ACL support make sure this particular ACL type can be restored.
+ */
+ switch (stream) {
+- case STREAM_ACL_SOLARIS_ACLENT:
++ case STREAM_ACL_SOLARIS_POSIX:
+ /*
+ * An aclent can be restored on filesystems with _ACL_ACLENT_ENABLED or _ACL_ACE_ENABLED support.
+ */
+@@ -1720,7 +1720,7 @@ static bacl_rtn_code solaris_restore_acl
+ return bacl_rtn_error;
+ }
+ break;
+- case STREAM_ACL_SOLARIS_ACE:
++ case STREAM_ACL_SOLARIS_NFS4:
+ /*
+ * An ace can only be restored on a filesystem with _ACL_ACE_ENABLED support.
+ */
+@@ -1750,7 +1750,7 @@ static bacl_rtn_code solaris_restore_acl
+ * Validate that the conversion gave us the correct acl type.
+ */
+ switch (stream) {
+- case STREAM_ACL_SOLARIS_ACLENT:
++ case STREAM_ACL_SOLARIS_POSIX:
+ if (acl_type(aclp) != ACLENT_T) {
+ Mmsg1(jcr->errmsg,
+ _("wrong encoding of acl type in acl stream on file \"%s\"\n"),
+@@ -1758,7 +1758,7 @@ static bacl_rtn_code solaris_restore_acl
+ return bacl_rtn_error;
+ }
+ break;
+- case STREAM_ACL_SOLARIS_ACE:
++ case STREAM_ACL_SOLARIS_NFS4:
+ if (acl_type(aclp) != ACE_T) {
+ Mmsg1(jcr->errmsg,
+ _("wrong encoding of acl type in acl stream on file \"%s\"\n"),
+@@ -1802,7 +1802,7 @@ static bacl_rtn_code solaris_restore_acl
+ * Define the supported ACL streams for this OS
+ */
+ static int os_access_acl_streams[1] = {
+- STREAM_ACL_SOLARIS_ACLENT
++ STREAM_ACL_SOLARIS_POSIX
+ };
+ static int os_default_acl_streams[1] = {
+ -1
+@@ -1861,7 +1861,7 @@ static bacl_rtn_code solaris_backup_acl_
+ pm_strcpy(jcr->acl_ctx->content, acl_text);
+ actuallyfree(acl_text);
+ free(acls);
+- return send_acl_stream(jcr, STREAM_ACL_SOLARIS_ACLENT);
++ return send_acl_stream(jcr, STREAM_ACL_SOLARIS_POSIX);
+ }
+
+ berrno be;
diff --git a/sysutils/bacula-server/files/patch-src_findlib_fstype.c b/sysutils/bacula-server/files/patch-src_findlib_fstype.c
new file mode 100644
index 000000000000..d4b90b8c14bd
--- /dev/null
+++ b/sysutils/bacula-server/files/patch-src_findlib_fstype.c
@@ -0,0 +1,22 @@
+--- src/findlib/fstype.c.orig 2015-08-13 13:52:24 UTC
++++ src/findlib/fstype.c
+@@ -31,7 +31,9 @@
+ #include "find.h"
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-
++#ifdef HAVE_SUN_OS
++ #include <sys/mnttab.h>
++#endif
+ #else /* Set up for testing a stand alone program */
+
+ #include <stdio.h>
+@@ -373,7 +375,7 @@ bool read_mtab(mtab_handler_t *mtab_hand
+ mtab_handler(user_ctx, &st, mnt.mnt_fstype, mnt.mnt_mountp,
+ mnt.mnt_mntopts, mnt.mnt_special);
+ }
+- fclose(fp);
++ fclose(mntfp);
+ V(mutex);
+ #endif
+
diff --git a/sysutils/bacula-server/pkg-plist b/sysutils/bacula-server/pkg-plist
index 37beb7889e97..254d324c96fa 100644
--- a/sysutils/bacula-server/pkg-plist
+++ b/sysutils/bacula-server/pkg-plist
@@ -13,7 +13,6 @@ sbin/bacula-sd
sbin/bcopy
sbin/bextract
sbin/bls
-sbin/bpluginfo
sbin/bregex
sbin/bscan
sbin/bsmtp