aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bacula5-bat
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-08-07 19:21:45 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-08-07 19:21:45 +0000
commitd8e5efd339004124efb1a710db697b6d97dd9757 (patch)
tree7e5615caac15ce6b29acbb7409204779b369714e /sysutils/bacula5-bat
parent4b5e2cd2155f28ca4b30bc74267b8e0688c1bae4 (diff)
downloadports-d8e5efd339004124efb1a710db697b6d97dd9757.tar.gz
ports-d8e5efd339004124efb1a710db697b6d97dd9757.zip
Notes
Diffstat (limited to 'sysutils/bacula5-bat')
-rw-r--r--sysutils/bacula5-bat/Makefile33
-rw-r--r--sysutils/bacula5-bat/pkg-descr13
-rw-r--r--sysutils/bacula5-bat/pkg-plist5
3 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/bacula5-bat/Makefile b/sysutils/bacula5-bat/Makefile
new file mode 100644
index 000000000000..e176d8bf4d9f
--- /dev/null
+++ b/sysutils/bacula5-bat/Makefile
@@ -0,0 +1,33 @@
+# Created by: Dan Langille <dan@langille.org>
+# $FreeBSD$
+
+PORTNAME= bacula
+PKGNAMESUFFIX= 5-bat
+PORTREVISION= 5
+
+COMMENT= Network backup solution (GUI)
+
+LIB_DEPENDS+= libqwt.so:${PORTSDIR}/x11-toolkits/qwt5 \
+ libbac.so:${PORTSDIR}/sysutils/bacula5-client
+
+CONFLICTS= bacula-bat-*
+
+USES= pkgconfig
+USE_QT4= qmake_build uic_build moc_build rcc_build
+WITH_BAT= yes
+
+PLIST= ${.CURDIR}/pkg-plist
+MAKE_ENV+= MAKEOBJDIRPREFIX=/
+
+MASTERDIR= ${.CURDIR}/../../sysutils/bacula5-server
+
+CONFIGURE_ARGS+= --enable-bat \
+ --with-qwt=${LOCALBASE}/lib \
+ --disable-build-dird \
+ --disable-build-stored \
+ --enable-client-only
+
+OPTIONS_DEFINE= OPENSSL
+OPTIONS_DEFAULT=OPENSSL
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/bacula5-bat/pkg-descr b/sysutils/bacula5-bat/pkg-descr
new file mode 100644
index 000000000000..91e157ffc8b8
--- /dev/null
+++ b/sysutils/bacula5-bat/pkg-descr
@@ -0,0 +1,13 @@
+bat is the GUI inteface for Bacula.
+
+Bacula is a set of computer programs that permit you (or the system
+administrator) to manage backup, recovery, and verification of
+computer data across a network of computers of different kinds.
+In technical terms, it is a network Client/Server based backup program.
+Bacula is relatively easy to use and efficient, while offering many
+advanced storage management features that make it easy to find and
+recover lost or damaged files. Due to its modular design, Bacula is
+scalable from small single computer systems to systems consisting of
+hundreds of computers located over a large network.
+
+WWW: http://www.bacula.org/
diff --git a/sysutils/bacula5-bat/pkg-plist b/sysutils/bacula5-bat/pkg-plist
new file mode 100644
index 000000000000..0b1e4857dd11
--- /dev/null
+++ b/sysutils/bacula5-bat/pkg-plist
@@ -0,0 +1,5 @@
+@sample %%ETCDIR%%/bat.conf.sample
+man/man1/bat.1.gz
+sbin/bat
+@dirrmtry %%ETCDIR%%
+