aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bareos16-client-static
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-05-18 05:05:00 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-05-18 05:05:00 +0000
commit3bd8555e8aa0e59575259b78ec794142a9f7356b (patch)
tree377e9b8ae002638067b3a61ee2e4d2a916a1d2cc /sysutils/bareos16-client-static
parent03beb6b5fa3994a7353464a37f92c8dc0214057b (diff)
downloadports-3bd8555e8aa0e59575259b78ec794142a9f7356b.tar.gz
ports-3bd8555e8aa0e59575259b78ec794142a9f7356b.zip
Notes
Diffstat (limited to 'sysutils/bareos16-client-static')
-rw-r--r--sysutils/bareos16-client-static/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/sysutils/bareos16-client-static/Makefile b/sysutils/bareos16-client-static/Makefile
new file mode 100644
index 000000000000..422efd07476d
--- /dev/null
+++ b/sysutils/bareos16-client-static/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= bareos16
+PORTREVISION= 0
+PKGNAMESUFFIX= -client-static
+
+COMMENT= Backup archiving recovery open sourced (static client)
+
+PLIST= ${.CURDIR}/pkg-plist
+MASTERDIR= ${.CURDIR}/../../sysutils/bareos16-server
+
+PLIST_FILES= sbin/bareos-fd-static \
+ sbin/bconsole-static
+
+OPTIONS_DEFINE= NLS LMDB
+OPTIONS_DEFAULT=#
+LMDB_DESC= Enable build of LMDB support
+
+CONFIGURE_ARGS+= --enable-client-only \
+ --enable-static-fd \
+ --enable-static-cons \
+ --disable-libtool \
+ --disable-build-dird \
+ --disable-build-stored \
+ --with-jansson=${LOCALBASE}
+
+BROKEN_aarch64= Fails to link: missing sbrk
+
+.include "${MASTERDIR}/Makefile"