aboutsummaryrefslogtreecommitdiff
path: root/sysutils/batmon
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2011-10-19 18:53:33 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2011-10-19 18:53:33 +0000
commit87368eeb509038ee9061f9543a7f377ef1854df4 (patch)
tree5e5660fdfae4d84a113d2ce3917924334a5b3278 /sysutils/batmon
parent35155d9d3f96bd325c487e5afbbb5e8aa837d582 (diff)
downloadports-87368eeb509038ee9061f9543a7f377ef1854df4.tar.gz
ports-87368eeb509038ee9061f9543a7f377ef1854df4.zip
Notes
Diffstat (limited to 'sysutils/batmon')
-rw-r--r--sysutils/batmon/Makefile8
-rw-r--r--sysutils/batmon/files/patch-BatteryModel.m14
2 files changed, 15 insertions, 7 deletions
diff --git a/sysutils/batmon/Makefile b/sysutils/batmon/Makefile
index 52f3cdca3e8c..bbf97eaf297a 100644
--- a/sysutils/batmon/Makefile
+++ b/sysutils/batmon/Makefile
@@ -25,10 +25,4 @@ post-patch:
${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DIR|#GNUSTEP_INSTALLATION_DIR|' \
${WRKSRC}/GNUmakefile
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 900007
-BROKEN= needed API not availible
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/batmon/files/patch-BatteryModel.m b/sysutils/batmon/files/patch-BatteryModel.m
new file mode 100644
index 000000000000..ac15b2a3fed2
--- /dev/null
+++ b/sysutils/batmon/files/patch-BatteryModel.m
@@ -0,0 +1,14 @@
+--- BatteryModel.m.orig 2011-07-15 11:05:22.000000000 +0200
++++ BatteryModel.m 2011-10-19 20:45:35.000000000 +0200
+@@ -246,7 +246,11 @@
+ if( battio.bst.state & ACPI_BATT_STAT_CRITICAL )
+ batteryType = @"CRITICAL "; // could be complementary!
+
++#ifdef ACPI_BATT_STAT_BST_MASK
++ if( battio.bst.state & ACPI_BATT_STAT_BST_MASK )
++#else
+ if( battio.bst.state & ACPI_BATT_STAT_MAX )
++#endif
+ status = @"Charged";
+ if( battio.bst.state & ACPI_BATT_STAT_CHARGING )
+ status = @"Charging";