aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bbcp
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-12 11:21:12 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-12 11:21:12 +0000
commit0622dd2fa757c6198ef4c1d8260005838dafadd7 (patch)
tree52ebb856aaa7ad74c085c587bf2627e3eac566e2 /sysutils/bbcp
parentff88b8dccb21da40ae26da3b0b0d3eec0be95e57 (diff)
downloadports-0622dd2fa757c6198ef4c1d8260005838dafadd7.tar.gz
ports-0622dd2fa757c6198ef4c1d8260005838dafadd7.zip
Notes
Diffstat (limited to 'sysutils/bbcp')
-rw-r--r--sysutils/bbcp/Makefile3
-rw-r--r--sysutils/bbcp/files/patch-src__bbcp.C10
2 files changed, 11 insertions, 2 deletions
diff --git a/sysutils/bbcp/Makefile b/sysutils/bbcp/Makefile
index ccf682b811a5..72af748e5fc2 100644
--- a/sysutils/bbcp/Makefile
+++ b/sysutils/bbcp/Makefile
@@ -11,10 +11,9 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= jhein@symmetricom.com
COMMENT= Secure and fast copy utility
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
USES= tar:xz
-USE_GCC= yes
PLIST_FILES= bin/bbcp
PORTDOCS= ${PORTNAME}.pdf
diff --git a/sysutils/bbcp/files/patch-src__bbcp.C b/sysutils/bbcp/files/patch-src__bbcp.C
new file mode 100644
index 000000000000..22e2531d6cfa
--- /dev/null
+++ b/sysutils/bbcp/files/patch-src__bbcp.C
@@ -0,0 +1,10 @@
+--- ./src/bbcp.C.orig 2012-05-03 21:57:39.000000000 +0200
++++ ./src/bbcp.C 2014-04-12 13:19:42.914184967 +0200
+@@ -58,6 +58,7 @@
+ /* m a i n */
+ /******************************************************************************/
+
++int
+ main(int argc, char *argv[], char *envp[])
+ {
+ bbcp_Node *Source, *Sink;