aboutsummaryrefslogtreecommitdiff
path: root/sysutils/biosfont
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-07-04 18:37:43 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-07-04 18:37:43 +0000
commit745344d7fad849c7eac2abfff23033c3c2d0a45d (patch)
tree1b83123d62c1b788d04021a3483588bdf53fa0f1 /sysutils/biosfont
parent133ecaba0824fdf167af7656e2eb42416a383637 (diff)
downloadports-745344d7fad849c7eac2abfff23033c3c2d0a45d.tar.gz
ports-745344d7fad849c7eac2abfff23033c3c2d0a45d.zip
This port provides a FreeBSD kernel module that can be used to
retrieve the font bitmaps stored in BIOS memory. WWW: http://home.tiscali.nl/rladan/biosfont/ PR: ports/97106 Submitted by: Rene Ladan <r.c.ladan@gmail.com>
Notes
Notes: svn path=/head/; revision=166930
Diffstat (limited to 'sysutils/biosfont')
-rw-r--r--sysutils/biosfont/Makefile43
-rw-r--r--sysutils/biosfont/distinfo3
-rw-r--r--sysutils/biosfont/pkg-descr4
-rw-r--r--sysutils/biosfont/pkg-message14
-rw-r--r--sysutils/biosfont/pkg-plist3
5 files changed, 67 insertions, 0 deletions
diff --git a/sysutils/biosfont/Makefile b/sysutils/biosfont/Makefile
new file mode 100644
index 000000000000..f590ea7ea37c
--- /dev/null
+++ b/sysutils/biosfont/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: biosfont
+# Date created: 10 May 2006
+# Whom: Rene Ladan <r.c.ladan@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= biosfont
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://home.tiscali.nl/rladan/biosfont/
+
+MAINTAINER= r.c.ladan@gmail.com
+COMMENT= Kernel module to retrieve bitmap fonts from BIOS memory
+
+# only platform guraranteed to be ok, feedback/patches are welcome
+ONLY_FOR_ARCHS= i386
+
+MAN4= biosfont.4
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+KMODDIR?= /boot/modules
+
+PLIST_SUB= KMODDIR=${KMODDIR}
+MAKE_ENV+= KMODDIR=${KMODDIR}
+
+.include <bsd.port.pre.mk>
+
+# patches for earlier versions are welcome
+.if ${OSVERSION} < 502117
+IGNORE= requires FreeBSD 5.3 or higher
+.endif
+
+.if !exists(/usr/src/sys/Makefile)
+IGNORE= requires kernel source files
+.endif
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/biosfont.h ${PREFIX}/include
+ ${INSTALL_MAN} ${MAN4:S|^|${WRKSRC}/|} ${PREFIX}/man/man4
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/biosfont/distinfo b/sysutils/biosfont/distinfo
new file mode 100644
index 000000000000..cbf7316bb8dd
--- /dev/null
+++ b/sysutils/biosfont/distinfo
@@ -0,0 +1,3 @@
+MD5 (biosfont-1.0.tar.gz) = dc013ad1e4ed7fc46e74871188bd2eea
+SHA256 (biosfont-1.0.tar.gz) = cbfc43ecb0ca78fc49cadeed387724ddb82be17233b66a5205c972bad61b3da0
+SIZE (biosfont-1.0.tar.gz) = 2613
diff --git a/sysutils/biosfont/pkg-descr b/sysutils/biosfont/pkg-descr
new file mode 100644
index 000000000000..e4e485ef8504
--- /dev/null
+++ b/sysutils/biosfont/pkg-descr
@@ -0,0 +1,4 @@
+This port provides a FreeBSD kernel module that can be used to
+retrieve the font bitmaps stored in BIOS memory.
+
+WWW: http://home.tiscali.nl/rladan/biosfont/
diff --git a/sysutils/biosfont/pkg-message b/sysutils/biosfont/pkg-message
new file mode 100644
index 000000000000..5356883a38a3
--- /dev/null
+++ b/sysutils/biosfont/pkg-message
@@ -0,0 +1,14 @@
+===============================================================================
+
+This port has installed the biosfont kernel module.
+
+To load the kernel module immediately, type the following command:
+
+ kldload biosfont
+
+To load the kernel module at boot, add the following line to
+/boot/loader.conf:
+
+ biosfont_load="YES"
+
+===============================================================================
diff --git a/sysutils/biosfont/pkg-plist b/sysutils/biosfont/pkg-plist
new file mode 100644
index 000000000000..013b506bb8b5
--- /dev/null
+++ b/sysutils/biosfont/pkg-plist
@@ -0,0 +1,3 @@
+include/biosfont.h
+@cwd %%KMODDIR%%
+biosfont.ko