aboutsummaryrefslogtreecommitdiff
path: root/sysutils/boxbackup/files
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2011-08-25 16:03:49 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2011-08-25 16:03:49 +0000
commitae1dfec64ac41caa6a9805f9ece62eb881296065 (patch)
treec80f5d0bee8e9d60123e33e9ce7be9e204426a29 /sysutils/boxbackup/files
parenta4d4769516d5610a89b3dfac2c75daffcae861ce (diff)
Notes
Diffstat (limited to 'sysutils/boxbackup/files')
-rw-r--r--sysutils/boxbackup/files/999.boxbackup.in66
-rw-r--r--sysutils/boxbackup/files/bbackupd.in (renamed from sysutils/boxbackup/files/bbackupd.sh.in)0
-rw-r--r--sysutils/boxbackup/files/bbstored.in (renamed from sysutils/boxbackup/files/bbstored.sh.in)0
-rw-r--r--sysutils/boxbackup/files/patch-configure.ac35
-rw-r--r--sysutils/boxbackup/files/patch-lib-common-BoxPortsAndFiles.h25
-rw-r--r--sysutils/boxbackup/files/pkg-message.client4
-rw-r--r--sysutils/boxbackup/files/pkg-message.server4
7 files changed, 70 insertions, 64 deletions
diff --git a/sysutils/boxbackup/files/999.boxbackup.in b/sysutils/boxbackup/files/999.boxbackup.in
new file mode 100644
index 000000000000..989d62d6b3e2
--- /dev/null
+++ b/sysutils/boxbackup/files/999.boxbackup.in
@@ -0,0 +1,66 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Box Backup monthly store compare
+#
+# Add the following to /etc/periodic.conf to enable the monthly compare:
+# monthly_boxbackup_compare_enable="YES"
+#
+# By default the script will run "compare -aq". If you want to change this to
+# run a full compare, add the following to periodic.conf:
+# monthly_boxbackup_compare_args="-a"
+#
+# NOTE: This script will cause the monthly periodic(8) run to take much longer
+# than usual, depending on the size of your backup store.
+#
+# If you wish to run this independently of the monthly job, you can create a
+# new periodic entry as follows:
+#
+# # mkdir /usr/local/etc/periodic/boxbackup
+# # mv /usr/local/etc/periodic/monthly/999.boxbackup \
+# /usr/local/etc/periodic/boxbackup/100.compare
+#
+# Then add the following to /etc/crontab:
+# 30 5 1 * * root periodic boxbackup
+#
+# (adjust the timings as necessary)
+#
+# You may also wish to add boxbackup_output="root" to periodic.conf so that
+# mail comes from periodic rather than cron.
+
+monthly_boxbackup_compare_enable="NO"
+monthly_boxbackup_compare_args="-aq"
+
+if [ -r /etc/defaults/periodic.conf ]
+then
+ . /etc/defaults/periodic.conf
+ source_periodic_confs
+fi
+
+rc=0
+
+case "$monthly_boxbackup_compare_enable" in
+ [Yy][Ee][Ss])
+ echo
+ echo "Running Box Backup store compare:"
+ %%PREFIX%%/sbin/bbackupquery -q "compare -c $monthly_boxbackup_compare_args" quit
+
+ # Return codes:
+ # 1 Comparison was exact
+ # 2 Differences were found
+ # 3 An error occured
+ if [ $? -eq 2 ]; then
+ echo
+ echo "Differences were found. Please check the output."
+ rc=3
+ elif [ $? -eq 3 ]; then
+ echo
+ echo "An error occurred. Please check the output."
+ rc=3
+ fi
+
+ ;;
+esac
+
+exit $rc
diff --git a/sysutils/boxbackup/files/bbackupd.sh.in b/sysutils/boxbackup/files/bbackupd.in
index b1e5febae656..b1e5febae656 100644
--- a/sysutils/boxbackup/files/bbackupd.sh.in
+++ b/sysutils/boxbackup/files/bbackupd.in
diff --git a/sysutils/boxbackup/files/bbstored.sh.in b/sysutils/boxbackup/files/bbstored.in
index 9554a6bd0e2f..9554a6bd0e2f 100644
--- a/sysutils/boxbackup/files/bbstored.sh.in
+++ b/sysutils/boxbackup/files/bbstored.in
diff --git a/sysutils/boxbackup/files/patch-configure.ac b/sysutils/boxbackup/files/patch-configure.ac
deleted file mode 100644
index e74613444509..000000000000
--- a/sysutils/boxbackup/files/patch-configure.ac
+++ /dev/null
@@ -1,35 +0,0 @@
---- configure.ac.orig Thu Mar 16 22:26:39 2006
-+++ configure.ac Thu Mar 16 22:28:31 2006
-@@ -2,7 +2,7 @@
- # Process this file with autoconf to produce a configure script.
-
- AC_PREREQ(2.59)
--AC_INIT([Box Backup], 0.09, [box@fluffy.co.uk])
-+AC_INIT([Box Backup], 0.10, [box@fluffy.co.uk])
- AC_CONFIG_SRCDIR([lib/common/Box.h])
- AC_CONFIG_HEADERS([lib/common/BoxConfig.h])
-
-@@ -26,6 +26,12 @@
- # Use -rdynamic if we have gcc. This is needed for backtrace
- AC_SUBST([LDADD_RDYNAMIC], ['-rdynamic'])
- fi
-+AC_PATH_PROG([PERL], [perl], [no])
-+if test "x$PERL" != "xno"; then
-+ AC_DEFINE_UNQUOTED([PERL_EXECUTABLE], ["$PERL"], [Location of the perl executable])
-+else
-+ AC_MSG_ERROR([[perl executable was not found]])
-+fi
-
-
- ### Checks for libraries.
-@@ -208,8 +214,8 @@
-
- # Configure the Box build system
- echo
--perl ./infrastructure/makebuildenv.pl &&
-- perl ./infrastructure/makeparcels.pl
-+$PERL ./infrastructure/makebuildenv.pl &&
-+ $PERL ./infrastructure/makeparcels.pl
-
- # Write summary of important info
- cat <<EOC
diff --git a/sysutils/boxbackup/files/patch-lib-common-BoxPortsAndFiles.h b/sysutils/boxbackup/files/patch-lib-common-BoxPortsAndFiles.h
deleted file mode 100644
index 7dc6c8f43d83..000000000000
--- a/sysutils/boxbackup/files/patch-lib-common-BoxPortsAndFiles.h
+++ /dev/null
@@ -1,25 +0,0 @@
---- lib/common/BoxPortsAndFiles.h.orig Thu Mar 16 19:28:09 2006
-+++ lib/common/BoxPortsAndFiles.h Thu Mar 16 19:28:38 2006
-@@ -53,7 +53,7 @@
-
- // Backup store daemon
- #define BOX_PORT_BBSTORED (BOX_PORT_BASE+1)
--#define BOX_FILE_BBSTORED_DEFAULT_CONFIG "/etc/box/bbstored.conf"
-+#define BOX_FILE_BBSTORED_DEFAULT_CONFIG "%%PREFIX%%/etc/box/bbstored.conf"
- // directory within the RAIDFILE root for the backup store daemon
- #define BOX_RAIDFILE_ROOT_BBSTORED "backup"
-
-@@ -61,11 +61,11 @@
- #ifdef WIN32
- #define BOX_FILE_BBACKUPD_DEFAULT_CONFIG "C:\\Program Files\\Box Backup\\bbackupd.conf"
- #else
--#define BOX_FILE_BBACKUPD_DEFAULT_CONFIG "/etc/box/bbackupd.conf"
-+#define BOX_FILE_BBACKUPD_DEFAULT_CONFIG "%%PREFIX%%/etc/box/bbackupd.conf"
- #endif
-
- // RaidFile conf location default
--#define BOX_FILE_RAIDFILE_DEFAULT_CONFIG "/etc/box/raidfile.conf"
-+#define BOX_FILE_RAIDFILE_DEFAULT_CONFIG "%%PREFIX%%/etc/box/raidfile.conf"
-
- // Default name of the named pipe
- #define BOX_NAMED_PIPE_NAME L"\\\\.\\pipe\\boxbackup"
diff --git a/sysutils/boxbackup/files/pkg-message.client b/sysutils/boxbackup/files/pkg-message.client
index 2890641287b5..e804b44d94b9 100644
--- a/sysutils/boxbackup/files/pkg-message.client
+++ b/sysutils/boxbackup/files/pkg-message.client
@@ -1,4 +1,4 @@
To run bbackupd at startup, add bbackupd_enable="YES" to /etc/rc.conf
-Please see http://www.fluffy.co.uk/boxbackup/client.html for client
-configuration options
+Please see http://www.boxbackup.org/client.html for client configuration
+options
diff --git a/sysutils/boxbackup/files/pkg-message.server b/sysutils/boxbackup/files/pkg-message.server
index 7d39f96cd48f..872c82bf5ed8 100644
--- a/sysutils/boxbackup/files/pkg-message.server
+++ b/sysutils/boxbackup/files/pkg-message.server
@@ -1,4 +1,4 @@
To run bbstored at startup, add bbstored_enable="YES" to /etc/rc.conf
-Please see http://www.fluffy.co.uk/boxbackup/server.html for server
-configuration options
+Please see http://www.boxbackup.org/server.html for server configuration
+options