aboutsummaryrefslogtreecommitdiff
path: root/sysutils/boxbackup
diff options
context:
space:
mode:
authorAlan Somers <asomers@FreeBSD.org>2018-05-21 16:02:27 +0000
committerAlan Somers <asomers@FreeBSD.org>2018-05-21 16:02:27 +0000
commite441e9ca24e98d57725813af4df6a2a4163e07d9 (patch)
treeb22470cbf31b8a1444bee3d8f3130c409efc9125 /sysutils/boxbackup
parent4a4182c8bb118e70e7f16d2c2683f4d9d67e3467 (diff)
downloadports-e441e9ca24e98d57725813af4df6a2a4163e07d9.tar.gz
ports-e441e9ca24e98d57725813af4df6a2a4163e07d9.zip
Notes
Diffstat (limited to 'sysutils/boxbackup')
-rw-r--r--sysutils/boxbackup/Makefile2
-rw-r--r--sysutils/boxbackup/files/999.boxbackup.in18
2 files changed, 19 insertions, 1 deletions
diff --git a/sysutils/boxbackup/Makefile b/sysutils/boxbackup/Makefile
index ce47665a8f79..7251d31a46f1 100644
--- a/sysutils/boxbackup/Makefile
+++ b/sysutils/boxbackup/Makefile
@@ -3,7 +3,7 @@
PORTNAME= boxbackup
PORTVERSION= 0.11.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= sysutils
MASTER_SITES= SF
PKGNAMESUFFIX= ${CLIENT_OR_SERVER}
diff --git a/sysutils/boxbackup/files/999.boxbackup.in b/sysutils/boxbackup/files/999.boxbackup.in
index e620fa306ca9..9422cbfc1744 100644
--- a/sysutils/boxbackup/files/999.boxbackup.in
+++ b/sysutils/boxbackup/files/999.boxbackup.in
@@ -38,12 +38,30 @@ then
source_periodic_confs
fi
+SLEEP=/bin/sleep
+JOT=/usr/bin/jot
+
+random() {
+ ${JOT} -r 1 0 900
+}
+
rc=0
case "$monthly_boxbackup_compare_enable" in
[Yy][Ee][Ss])
echo
echo "Running Box Backup store compare:"
+ # When non-interactive, sleep to reduce congestion on rkhunter
+ # site
+ if [ "$1" != -nodelay ]; then
+ # In FreeBSD 12.0 the anticongestion function should
+ # be used instead of a hard-coded sleep
+ if [ -n "$anticongestion_sleeptime" ]; then
+ anticongestion
+ else
+ ${SLEEP} $(random)
+ fi
+ fi
%%PREFIX%%/sbin/bbackupquery -q "compare -c $monthly_boxbackup_compare_args" quit
# Return codes: