aboutsummaryrefslogtreecommitdiff
path: root/sysutils/brasero
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
commitae52bc80895a23ddbe33b86e75a9cf331ae32ba9 (patch)
tree5538a7d3541f6d56e4bbab9c6329f5b9db64dafb /sysutils/brasero
parent7934df773e0cc2a9924de75dd7cad9cc3d79d4ee (diff)
downloadports-ae52bc80895a23ddbe33b86e75a9cf331ae32ba9.tar.gz
ports-ae52bc80895a23ddbe33b86e75a9cf331ae32ba9.zip
Notes
Diffstat (limited to 'sysutils/brasero')
-rw-r--r--sysutils/brasero/Makefile28
-rw-r--r--sysutils/brasero/distinfo6
-rw-r--r--sysutils/brasero/files/patch-src_brasero-data-project.c38
-rw-r--r--sysutils/brasero/files/patch-src_scsi-cam.c22
-rw-r--r--sysutils/brasero/pkg-plist64
5 files changed, 87 insertions, 71 deletions
diff --git a/sysutils/brasero/Makefile b/sysutils/brasero/Makefile
index d915447a33ca..1121385058d9 100644
--- a/sysutils/brasero/Makefile
+++ b/sysutils/brasero/Makefile
@@ -3,11 +3,11 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/brasero/Makefile,v 1.34 2009/01/09 22:03:01 kwm Exp $
+# $MCom: ports/sysutils/brasero/Makefile,v 1.43 2009/03/22 00:17:29 marcus Exp $
PORTNAME= brasero
-PORTVERSION= 0.8.4
-PORTREVISION= 3
+PORTVERSION= 2.26.0
+PORTREVISION= 1
CATEGORIES= sysutils audio multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,20 +17,36 @@ COMMENT= CD/DVD mastering tool for the GNOME desktop
LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify \
totem-plparser.12:${PORTSDIR}/multimedia/totem-pl-parser
+RUN_DEPENDS= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
+ cdrdao:${PORTSDIR}/sysutils/cdrdao
USE_GETTEXT= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehier nautiluscdburner
+USE_XORG= sm
+USE_GNOME= intlhack gnomeprefix gnomehack nautilus2
USE_GSTREAMER= gconf core
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
-CONFIGURE_ARGS= --disable-inotify
+CONFIGURE_ARGS= --disable-inotify --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_CAM_LIB_H=1" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= brasero.1
GCONF_SCHEMAS= brasero.schemas
-.include <bsd.port.mk>
+OPTIONS= LIBBURNIA "Enable libburnia plug-ins" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_LIBBURNIA)
+LIB_DEPENDS+= burn.4:${PORTSDIR}/devel/libburn \
+ isofs.6:${PORTSDIR}/devel/libisofs
+CONFIGURE_ARGS+=--enable-libburnia
+PLIST_SUB+= LIBBURNIA=""
+.else
+PLIST_SUB+= LIBBURNIA="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/brasero/distinfo b/sysutils/brasero/distinfo
index c63fa75cf437..d1776af4b68c 100644
--- a/sysutils/brasero/distinfo
+++ b/sysutils/brasero/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/brasero-0.8.4.tar.bz2) = 5d0ad796e1f7b68a31f8757f1b3f9aef
-SHA256 (gnome2/brasero-0.8.4.tar.bz2) = 6cbe0367e9049f6c93d67f6d9a48b530430e52d3d48ec3ae4b9bc96b79870bba
-SIZE (gnome2/brasero-0.8.4.tar.bz2) = 2755878
+MD5 (gnome2/brasero-2.26.0.tar.bz2) = ef968fe98874da4e26b61591ee57be4a
+SHA256 (gnome2/brasero-2.26.0.tar.bz2) = a1d3568f4e6d68e824884c0e06acd38fdd6cf142231ca6ded2647b95ab289c8a
+SIZE (gnome2/brasero-2.26.0.tar.bz2) = 3129146
diff --git a/sysutils/brasero/files/patch-src_brasero-data-project.c b/sysutils/brasero/files/patch-src_brasero-data-project.c
deleted file mode 100644
index e1f559f12ce1..000000000000
--- a/sysutils/brasero/files/patch-src_brasero-data-project.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/brasero-data-project.c.orig 2008-12-14 07:53:07.000000000 -0500
-+++ src/brasero-data-project.c 2009-02-27 01:26:42.000000000 -0500
-@@ -545,7 +545,7 @@ brasero_data_project_uri_to_nodes (Brase
- if (graft)
- break;
-
-- dirname (parent);
-+ parent = dirname (parent);
- }
-
- if (!graft) {
-@@ -721,7 +721,7 @@ brasero_data_project_uri_has_parent (Bra
- return TRUE;
- }
-
-- dirname (parent);
-+ parent = dirname (parent);
- }
-
- g_free (parent);
-@@ -795,7 +795,7 @@ brasero_data_project_uri_is_graft_needed
- * node is missing. */
- graft_parent = g_hash_table_lookup (priv->grafts, parent);
- while (parent && !graft_parent) {
-- dirname (parent);
-+ parent = dirname (parent);
- graft_parent = g_hash_table_lookup (priv->grafts, parent);
- }
- g_free (parent);
-@@ -2787,7 +2787,7 @@ brasero_data_project_add_excluded_uri (B
- break;
-
- graft = NULL;
-- dirname (parent_uri);
-+ parent_uri = dirname (parent_uri);
- }
- g_free (parent_uri);
-
diff --git a/sysutils/brasero/files/patch-src_scsi-cam.c b/sysutils/brasero/files/patch-src_scsi-cam.c
deleted file mode 100644
index 74546979f326..000000000000
--- a/sysutils/brasero/files/patch-src_scsi-cam.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/scsi-cam.c.orig 2009-01-13 21:35:42.000000000 -0500
-+++ src/scsi-cam.c 2009-01-13 21:36:01.000000000 -0500
-@@ -62,7 +62,7 @@ typedef struct _BraseroScsiCmd BraseroSc
- #define BRASERO_SCSI_CMD_OPCODE_OFF 0
- #define BRASERO_SCSI_CMD_SET_OPCODE(command) (command->cmd [BRASERO_SCSI_CMD_OPCODE_OFF] = command->info->opcode)
-
--#define OPEN_FLAGS O_RDWR /*|O_EXCL */|O_NONBLOCK
-+#define OPEN_FLAGS O_RDONLY /*|O_EXCL */|O_NONBLOCK
-
- BraseroScsiResult
- brasero_scsi_command_issue_sync (gpointer command,
-@@ -158,8 +158,8 @@ brasero_device_handle_open (const gchar
-
- g_assert (path != NULL);
-
-- if (exclusive)
-- flags |= O_EXCL;
-+/* if (exclusive)
-+ flags |= O_EXCL;*/
-
- /* cam_open_device() fails unless we use O_RDWR */
- cam = cam_open_device (path, O_RDWR);
diff --git a/sysutils/brasero/pkg-plist b/sysutils/brasero/pkg-plist
index 20c2908fd45d..b2536ed17af0 100644
--- a/sysutils/brasero/pkg-plist
+++ b/sysutils/brasero/pkg-plist
@@ -1,4 +1,12 @@
bin/brasero
+include/brasero/brasero-drive-selection.h
+include/brasero/brasero-drive.h
+include/brasero/brasero-media.h
+include/brasero/brasero-medium-monitor.h
+include/brasero/brasero-medium-selection.h
+include/brasero/brasero-medium.h
+include/brasero/brasero-units.h
+include/brasero/brasero-volume.h
lib/brasero/plugins/libbrasero-burn-uri.la
lib/brasero/plugins/libbrasero-burn-uri.so
lib/brasero/plugins/libbrasero-cdrdao.la
@@ -19,6 +27,10 @@ lib/brasero/plugins/libbrasero-genisoimage.la
lib/brasero/plugins/libbrasero-genisoimage.so
lib/brasero/plugins/libbrasero-growisofs.la
lib/brasero/plugins/libbrasero-growisofs.so
+%%LIBBURNIA%%lib/brasero/plugins/libbrasero-libburn.la
+%%LIBBURNIA%%lib/brasero/plugins/libbrasero-libburn.so
+%%LIBBURNIA%%lib/brasero/plugins/libbrasero-libisofs.la
+%%LIBBURNIA%%lib/brasero/plugins/libbrasero-libisofs.so
lib/brasero/plugins/libbrasero-local-track.la
lib/brasero/plugins/libbrasero-local-track.so
lib/brasero/plugins/libbrasero-mkisofs.la
@@ -39,10 +51,15 @@ lib/brasero/plugins/libbrasero-vob.la
lib/brasero/plugins/libbrasero-vob.so
lib/brasero/plugins/libbrasero-wodim.la
lib/brasero/plugins/libbrasero-wodim.so
+lib/libbrasero-media.la
+lib/libbrasero-media.so
+lib/libbrasero-media.so.1
lib/nautilus/extensions-2.0/libnautilus-brasero-extension.la
lib/nautilus/extensions-2.0/libnautilus-brasero-extension.so
+libdata/pkgconfig/libbrasero-media.pc
share/applications/brasero.desktop
share/applications/brasero-copy-medium.desktop
+share/applications/brasero-nautilus.desktop
share/applications/brasero-open-image.desktop
share/applications/brasero-open-playlist.desktop
share/applications/brasero-open-project.desktop
@@ -201,6 +218,24 @@ share/applications/brasero-open-project.desktop
%%DATADIR%%/icons/hicolor/scalable/status/brasero-disc-90.svg
%%DATADIR%%/icons/hicolor/scalable/status/brasero-disc-95.svg
%%DATADIR%%/logo.png
+%%DOCSDIR%%/BraseroDrive.html
+%%DOCSDIR%%/BraseroDriveSelection.html
+%%DOCSDIR%%/BraseroMedium.html
+%%DOCSDIR%%/BraseroMediumMonitor.html
+%%DOCSDIR%%/BraseroMediumSelection.html
+%%DOCSDIR%%/BraseroVolume.html
+%%DOCSDIR%%/brasero-brasero-media.html
+%%DOCSDIR%%/brasero-brasero-units.html
+%%DOCSDIR%%/brasero.devhelp
+%%DOCSDIR%%/brasero.devhelp2
+%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
share/gnome/help/brasero/C/brasero.xml
share/gnome/help/brasero/C/figures/brasero_main.png
share/gnome/help/brasero/C/legal.xml
@@ -208,6 +243,8 @@ share/gnome/help/brasero/de/brasero.xml
share/gnome/help/brasero/de/figures/brasero_main.png
share/gnome/help/brasero/el/brasero.xml
share/gnome/help/brasero/el/figures/brasero_main.png
+share/gnome/help/brasero/en_GB/brasero.xml
+share/gnome/help/brasero/en_GB/figures/brasero_main.png
share/gnome/help/brasero/es/brasero.xml
share/gnome/help/brasero/es/figures/brasero_main.png
share/gnome/help/brasero/fr/brasero.xml
@@ -227,6 +264,8 @@ share/icons/hicolor/32x32/apps/brasero.png
share/icons/hicolor/48x48/apps/brasero.png
share/icons/hicolor/scalable/apps/brasero.svg
share/locale/ar/LC_MESSAGES/brasero.mo
+share/locale/bg/LC_MESSAGES/brasero.mo
+share/locale/bn_IN/LC_MESSAGES/brasero.mo
share/locale/ca/LC_MESSAGES/brasero.mo
share/locale/cs/LC_MESSAGES/brasero.mo
share/locale/da/LC_MESSAGES/brasero.mo
@@ -236,18 +275,27 @@ share/locale/el/LC_MESSAGES/brasero.mo
share/locale/en_GB/LC_MESSAGES/brasero.mo
share/locale/es/LC_MESSAGES/brasero.mo
share/locale/et/LC_MESSAGES/brasero.mo
+share/locale/eu/LC_MESSAGES/brasero.mo
share/locale/fi/LC_MESSAGES/brasero.mo
share/locale/fr/LC_MESSAGES/brasero.mo
share/locale/gl/LC_MESSAGES/brasero.mo
+share/locale/gu/LC_MESSAGES/brasero.mo
share/locale/he/LC_MESSAGES/brasero.mo
+share/locale/hi/LC_MESSAGES/brasero.mo
share/locale/hu/LC_MESSAGES/brasero.mo
share/locale/it/LC_MESSAGES/brasero.mo
share/locale/ja/LC_MESSAGES/brasero.mo
+share/locale/kn/LC_MESSAGES/brasero.mo
+share/locale/ko/LC_MESSAGES/brasero.mo
share/locale/lt/LC_MESSAGES/brasero.mo
+share/locale/lv/LC_MESSAGES/brasero.mo
share/locale/mk/LC_MESSAGES/brasero.mo
+share/locale/ml/LC_MESSAGES/brasero.mo
+share/locale/mr/LC_MESSAGES/brasero.mo
share/locale/nb/LC_MESSAGES/brasero.mo
share/locale/nl/LC_MESSAGES/brasero.mo
share/locale/oc/LC_MESSAGES/brasero.mo
+share/locale/or/LC_MESSAGES/brasero.mo
share/locale/pa/LC_MESSAGES/brasero.mo
share/locale/pl/LC_MESSAGES/brasero.mo
share/locale/pt/LC_MESSAGES/brasero.mo
@@ -258,7 +306,10 @@ share/locale/sl/LC_MESSAGES/brasero.mo
share/locale/sr/LC_MESSAGES/brasero.mo
share/locale/sr@latin/LC_MESSAGES/brasero.mo
share/locale/sv/LC_MESSAGES/brasero.mo
+share/locale/ta/LC_MESSAGES/brasero.mo
+share/locale/te/LC_MESSAGES/brasero.mo
share/locale/th/LC_MESSAGES/brasero.mo
+share/locale/vi/LC_MESSAGES/brasero.mo
share/locale/zh_CN/LC_MESSAGES/brasero.mo
share/locale/zh_HK/LC_MESSAGES/brasero.mo
share/locale/zh_TW/LC_MESSAGES/brasero.mo
@@ -266,6 +317,7 @@ share/mime/packages/brasero.xml
share/omf/brasero/brasero-C.omf
share/omf/brasero/brasero-de.omf
share/omf/brasero/brasero-el.omf
+share/omf/brasero/brasero-en_GB.omf
share/omf/brasero/brasero-es.omf
share/omf/brasero/brasero-fr.omf
share/omf/brasero/brasero-it.omf
@@ -285,6 +337,8 @@ share/omf/brasero/brasero-sv.omf
@dirrm share/gnome/help/brasero/fr
@dirrm share/gnome/help/brasero/es/figures
@dirrm share/gnome/help/brasero/es
+@dirrm share/gnome/help/brasero/en_GB/figures
+@dirrm share/gnome/help/brasero/en_GB
@dirrm share/gnome/help/brasero/el/figures
@dirrm share/gnome/help/brasero/el
@dirrm share/gnome/help/brasero/de/figures
@@ -292,6 +346,7 @@ share/omf/brasero/brasero-sv.omf
@dirrm share/gnome/help/brasero/C/figures
@dirrm share/gnome/help/brasero/C
@dirrm share/gnome/help/brasero
+@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/icons/hicolor/16x16/status
@dirrm %%DATADIR%%/icons/hicolor/16x16/actions
@dirrm %%DATADIR%%/icons/hicolor/16x16
@@ -315,17 +370,22 @@ share/omf/brasero/brasero-sv.omf
@dirrmtry share/applications
@dirrm lib/brasero/plugins
@dirrm lib/brasero
+@dirrm include/brasero
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/ro/LC_MESSAGES
-@dirrmtry share/locale/ro
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
@dirrmtry share/locale/sr@latin/LC_MESSAGES
@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN