aboutsummaryrefslogtreecommitdiff
path: root/sysutils/brasero
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-10-14 08:49:06 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-10-14 08:49:06 +0000
commit4a021a30718cba7f3134b8b27fc9a9b100804abf (patch)
tree1ea92ccf5b07af5e70e2f647621b3b70f7a45261 /sysutils/brasero
parent097b3e7241b499a84898effd7e84dd07cfb3d2c1 (diff)
downloadports-4a021a30718cba7f3134b8b27fc9a9b100804abf.tar.gz
ports-4a021a30718cba7f3134b8b27fc9a9b100804abf.zip
Notes
Diffstat (limited to 'sysutils/brasero')
-rw-r--r--sysutils/brasero/Makefile35
-rw-r--r--sysutils/brasero/distinfo3
-rw-r--r--sysutils/brasero/pkg-descr23
-rw-r--r--sysutils/brasero/pkg-plist53
4 files changed, 114 insertions, 0 deletions
diff --git a/sysutils/brasero/Makefile b/sysutils/brasero/Makefile
new file mode 100644
index 000000000000..ed1d188d8f2f
--- /dev/null
+++ b/sysutils/brasero/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: bonfire
+# Date created: 2006-05-12
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/sysutils/brasero/Makefile,v 1.11 2006/09/08 00:44:18 ahze Exp $
+
+PORTNAME= brasero
+PORTVERSION= 0.4.90
+CATEGORIES= sysutils audio multimedia gnome
+MASTER_SITES= SOURCEFORGE
+MASTER_SITE_SUBDIR= bonfire
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= CD/DVD mastering tool for the GNOME desktop
+
+LIB_DEPENDS= notify.2:${PORTSDIR}/devel/libnotify \
+ totem-plparser.1:${PORTSDIR}/multimedia/totem-gstreamer
+
+USE_GETTEXT= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_XLIB= yes
+USE_GNOME= gnomehier nautiluscdburner
+USE_GSTREAMER= gconf core
+INSTALLS_ICONS= yes
+CONFIGURE_ARGS= --disable-inotify
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= brasero.1
+GCONF_SCHEMAS= brasero.schemas
+
+.include <bsd.port.mk>
diff --git a/sysutils/brasero/distinfo b/sysutils/brasero/distinfo
new file mode 100644
index 000000000000..60101bc529eb
--- /dev/null
+++ b/sysutils/brasero/distinfo
@@ -0,0 +1,3 @@
+MD5 (brasero-0.4.90.tar.bz2) = 172a8feb5bf0e68bb3cb94d97583cdbd
+SHA256 (brasero-0.4.90.tar.bz2) = 484e2cfa3b0d94aa5674be86d4aeb6da5cc59dad71682d428e0f0c92a84f57a7
+SIZE (brasero-0.4.90.tar.bz2) = 842349
diff --git a/sysutils/brasero/pkg-descr b/sysutils/brasero/pkg-descr
new file mode 100644
index 000000000000..2e6f14b59756
--- /dev/null
+++ b/sysutils/brasero/pkg-descr
@@ -0,0 +1,23 @@
+CD/DVD mastering tool for the gnome desktop. It has been designed to be
+simple and easy to use.
+
+Features:
+Data CD/DVD:
+- supports edition of discs contents
+- can burn data CD/DVD on the fly
+- supports multisession
+- supports joliet extension
+- can write the image to the hard drive
+Audio CD:
+- write CD-TEXT information (automatically found thanks to gstreamer)
+- supports the edition of CD-TEXT information
+- can burn audio CD on the fly
+- can use all audio files handled by Gstreamer local installation
+- can search for audio files inside dropped folders
+CD/DVD copy:
+- can copy a CD/DVD to the hard drive
+- can copy DVD and CD on the fly
+- supports single-session data DVD
+- supports any kind of CD
+
+WWW: http://perso.wanadoo.fr/bonfire/
diff --git a/sysutils/brasero/pkg-plist b/sysutils/brasero/pkg-plist
new file mode 100644
index 000000000000..ccb87a70364b
--- /dev/null
+++ b/sysutils/brasero/pkg-plist
@@ -0,0 +1,53 @@
+bin/brasero
+share/applications/brasero.desktop
+%%DATADIR%%/disc-00.png
+%%DATADIR%%/disc-05.png
+%%DATADIR%%/disc-10.png
+%%DATADIR%%/disc-100.png
+%%DATADIR%%/disc-15.png
+%%DATADIR%%/disc-20.png
+%%DATADIR%%/disc-25.png
+%%DATADIR%%/disc-30.png
+%%DATADIR%%/disc-35.png
+%%DATADIR%%/disc-40.png
+%%DATADIR%%/disc-45.png
+%%DATADIR%%/disc-50.png
+%%DATADIR%%/disc-55.png
+%%DATADIR%%/disc-60.png
+%%DATADIR%%/disc-65.png
+%%DATADIR%%/disc-70.png
+%%DATADIR%%/disc-75.png
+%%DATADIR%%/disc-80.png
+%%DATADIR%%/disc-85.png
+%%DATADIR%%/disc-90.png
+%%DATADIR%%/disc-95.png
+%%DATADIR%%/icon-final-128x128.png
+%%DATADIR%%/icon-final-256x256.png
+%%DATADIR%%/icon-final-48x48.png
+%%DATADIR%%/logo.png
+share/icons/gnome/48x48/mimetypes/gnome-mime-application-x-brasero.png
+share/locale/ca/LC_MESSAGES/brasero.mo
+share/locale/de/LC_MESSAGES/brasero.mo
+share/locale/es/LC_MESSAGES/brasero.mo
+share/locale/fr/LC_MESSAGES/brasero.mo
+share/locale/it/LC_MESSAGES/brasero.mo
+share/locale/ja/LC_MESSAGES/brasero.mo
+share/locale/pl/LC_MESSAGES/brasero.mo
+share/locale/pt_BR/LC_MESSAGES/brasero.mo
+share/mime/packages/brasero.xml
+share/pixmaps/brasero.png
+@dirrmtry share/pixmaps
+@dirrm share/icons/gnome/48x48/mimetypes
+@dirrm share/icons/gnome/48x48
+@dirrm share/icons/gnome
+@dirrm share/icons
+@dirrm %%DATADIR%%
+@dirrmtry share/applications
+@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca