aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bsdadminscripts
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2012-12-14 14:38:15 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2012-12-14 14:38:15 +0000
commita9bb4c65f85f33acd5c973e6bbf52c850a5c3076 (patch)
tree45bd0533449a510fe19c4cf7bc651a1b77c95467 /sysutils/bsdadminscripts
parent193957a077a26ac8a2adcb96fa573450f0745613 (diff)
downloadports-a9bb4c65f85f33acd5c973e6bbf52c850a5c3076.tar.gz
ports-a9bb4c65f85f33acd5c973e6bbf52c850a5c3076.zip
Notes
Diffstat (limited to 'sysutils/bsdadminscripts')
-rw-r--r--sysutils/bsdadminscripts/Makefile8
-rw-r--r--sysutils/bsdadminscripts/files/patch-pkg_libchk75
-rw-r--r--sysutils/bsdadminscripts/files/patch-src::pkg_libchk19
3 files changed, 77 insertions, 25 deletions
diff --git a/sysutils/bsdadminscripts/Makefile b/sysutils/bsdadminscripts/Makefile
index a23437724e4d..f0dfcb9e1e9a 100644
--- a/sysutils/bsdadminscripts/Makefile
+++ b/sysutils/bsdadminscripts/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: bsdadminscripts
-# Date created: 15 May 2006
-# Whom: Dominic Fandrey <lon_kamikaze@gmx.de>
-#
+# Created by: Dominic Fandrey <lon_kamikaze@gmx.de>
# $FreeBSD$
-#
PORTNAME= bsdadminscripts
PORTVERSION= 6.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils ports-mgmt
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
diff --git a/sysutils/bsdadminscripts/files/patch-pkg_libchk b/sysutils/bsdadminscripts/files/patch-pkg_libchk
new file mode 100644
index 000000000000..56fdcbc1ca41
--- /dev/null
+++ b/sysutils/bsdadminscripts/files/patch-pkg_libchk
@@ -0,0 +1,75 @@
+--- ./pkg_libchk.orig 2012-12-12 19:38:36.000000000 +0100
++++ ./pkg_libchk 2012-12-12 19:40:22.000000000 +0100
+@@ -23,6 +23,8 @@
+
+ readonly name=pkg_libchk
+ readonly version=1.6.1
++readonly osname=`uname -s`
++readonly pkgng=`make -VWITH_PKGNG`
+
+ # Use a line break as delimiter.
+ IFS='
+@@ -206,7 +208,7 @@
+ # We cannot handle non-native binaries,
+ # so assume everything is in order.
+ if ! readelf -e "$1" 2>&1 | \
+- grep -E "^[[:space:]]*OS/ABI:[[:space:]]*UNIX - $OSTYPE\$" \
++ grep -E "^[[:space:]]*OS/ABI:[[:space:]]*UNIX - $osname\$" \
+ > /dev/null
+ then
+ return 2
+@@ -405,10 +407,17 @@
+
+ # Get the packages to work on.
+ test -z "$packages" && packages="-a"
+-packages="$(pkg_info -E $packages)"
+-test -z "$recursive" -a -z "$Recursive" || packages="$packages
+-$(pkg_info -q $recursive $Recursive "$packages" 2> /dev/null | \
+-sed -E 's|^@pkgdep[[:space:]]*||1')"
++if [ "$pkgng" = "yes" ]; then
++ packages="$(pkg info -q $packages)"
++ test -z "$recursive" -a -z "$Recursive" || packages="$packages
++ $(pkg info -q $recursive $Recursive "$packages" 2> /dev/null | \
++ sed -E 's|^@pkgdep[[:space:]]*||1')"
++else
++ packages="$(pkg_info -E $packages)"
++ test -z "$recursive" -a -z "$Recursive" || packages="$packages
++ $(pkg_info -q $recursive $Recursive "$packages" 2> /dev/null | \
++ sed -E 's|^@pkgdep[[:space:]]*||1')"
++fi
+
+ # Create the regexp to match ldd output
+ match_expr="$compat=> not found|dependency .+ not found"
+@@ -420,9 +429,15 @@
+ # Check each selected package.
+ for package in $packages; {
+ package_num="$(($package_num + 1))"
+- test $origin \
+- && package_name="$(pkg_info -qo "$package")" \
+- || package_name="$package"
++ if [ "$pkgng" = "yes" ]; then
++ test $origin \
++ && package_name="$(pkg info -qo "$package")" \
++ || package_name="$package"
++ else
++ test $origin \
++ && package_name="$(pkg_info -qo "$package")" \
++ || package_name="$package"
++ fi
+
+ # Print what we're doing.
+ statusSet "Starting job $package_num of $package_amount: $package_name"
+@@ -432,7 +447,12 @@
+ # Remember freeing the semaphore.
+ trap 'semaphoreFree jobs' EXIT
+
+- files="$(pkg_info -qL "$package")"
++ files=""
++ if [ "$pkgng" = "yes" ]; then
++ files="$(pkg info -lq "$package")"
++ else
++ files="$(pkg_info -qL "$package")"
++ fi
+ # Get the programs libraries in case it doesn't use the
+ # operating system to find its libraries.
+ libraries="$(echo "$files" | grep -E '\.so[\.0-9]*$')"
diff --git a/sysutils/bsdadminscripts/files/patch-src::pkg_libchk b/sysutils/bsdadminscripts/files/patch-src::pkg_libchk
deleted file mode 100644
index a6cd544af136..000000000000
--- a/sysutils/bsdadminscripts/files/patch-src::pkg_libchk
+++ /dev/null
@@ -1,19 +0,0 @@
---- pkg_libchk.orig 2011-07-16 21:42:34.990085774 +0400
-+++ pkg_libchk 2011-07-16 21:45:53.405082081 +0400
-@@ -23,6 +23,7 @@
-
- readonly name=pkg_libchk
- readonly version=1.6.1
-+readonly osname=`uname -s`
-
- # Use a line break as delimiter.
- IFS='
-@@ -206,7 +207,7 @@
- # We cannot handle non-native binaries,
- # so assume everything is in order.
- if ! readelf -e "$1" 2>&1 | \
-- grep -E "^[[:space:]]*OS/ABI:[[:space:]]*UNIX - $OSTYPE\$" \
-+ grep -E "^[[:space:]]*OS/ABI:[[:space:]]*UNIX - $osname\$" \
- > /dev/null
- then
- return 2