aboutsummaryrefslogtreecommitdiff
path: root/sysutils/burp
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-01 13:39:36 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-01 13:39:36 +0000
commitd29b54e7a1b66114887afda42e9bc42537206106 (patch)
treebadad8f564afdb74b36339281a7a756f8f45ac1a /sysutils/burp
parenta8df345f23507aba091b3729c8b370901007374c (diff)
downloadports-d29b54e7a1b66114887afda42e9bc42537206106.tar.gz
ports-d29b54e7a1b66114887afda42e9bc42537206106.zip
Notes
Diffstat (limited to 'sysutils/burp')
-rw-r--r--sysutils/burp/Makefile8
-rw-r--r--sysutils/burp/files/patch-src_server.c15
2 files changed, 16 insertions, 7 deletions
diff --git a/sysutils/burp/Makefile b/sysutils/burp/Makefile
index ba578d7807c9..175741b76c35 100644
--- a/sysutils/burp/Makefile
+++ b/sysutils/burp/Makefile
@@ -46,10 +46,4 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/vss_strip
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/burp
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 1200039 && ${CC:T} == "clang"
-BROKEN= fails to compile due to clang 4.0 regression: util/bdthreads.cc:132:10: ordered comparison between pointer and zero
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/burp/files/patch-src_server.c b/sysutils/burp/files/patch-src_server.c
new file mode 100644
index 000000000000..437149aa720e
--- /dev/null
+++ b/sysutils/burp/files/patch-src_server.c
@@ -0,0 +1,15 @@
+server.c:546:25: error: ordered comparison between pointer and zero ('struct strlist **' and 'int')
+ if(!ret && cconf->keep>0)
+ ~~~~~~~~~~~^~
+
+--- src/server.c.orig 2018-08-01 13:34:56 UTC
++++ src/server.c
+@@ -543,7 +543,7 @@ static int do_backup_server(const char *basedir, const
+ working, current, currentdata,
+ finishing, cconf, client,
+ p1cntr, cntr);
+- if(!ret && cconf->keep>0)
++ if(!ret && cconf->keep != NULL)
+ ret=remove_old_backups(basedir, cconf, client);
+ }
+