aboutsummaryrefslogtreecommitdiff
path: root/sysutils/busybox/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-01-21 23:55:21 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-01-21 23:55:21 +0000
commita5e727e03bec1091be3605f7d5fef6ee491830b9 (patch)
tree4451c5b00f985a0cb3dc64690bf5ae37b72191ae /sysutils/busybox/Makefile
parent838b61da71b818c3c994522935bba45ab26c357d (diff)
downloadports-a5e727e03bec1091be3605f7d5fef6ee491830b9.tar.gz
ports-a5e727e03bec1091be3605f7d5fef6ee491830b9.zip
Notes
Diffstat (limited to 'sysutils/busybox/Makefile')
-rw-r--r--sysutils/busybox/Makefile27
1 files changed, 15 insertions, 12 deletions
diff --git a/sysutils/busybox/Makefile b/sysutils/busybox/Makefile
index 611d37c8d530..9f69da8c15b5 100644
--- a/sysutils/busybox/Makefile
+++ b/sysutils/busybox/Makefile
@@ -1,18 +1,17 @@
-# New ports collection makefile for: busybox
-# Date created: Aug.18, 2008
-# Whom: luigi@FreeBSD.org
-#
+# Created by: luigi@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= busybox
PORTVERSION= 1.20.2
+PORTREVISION= 1
CATEGORIES= sysutils misc shells
MASTER_SITES= http://www.busybox.net/downloads/
-#PATCH_SITES= http://www.busybox.net/downloads/fixes-${PORTVERSION}/
-#PATCH_DIST_STRIP= -p1
-#PATCHFILES= \
+PATCH_SITES= http://www.busybox.net/downloads/fixes-${PORTVERSION}/
+PATCH_DIST_STRIP= -p1
+PATCHFILES= busybox-1.20.2-kernel_ver.patch \
+ busybox-1.20.2-ntpd.patch \
+ busybox-1.20.2-sys-resource.patch
MAINTAINER= mandree@FreeBSD.org
COMMENT= Busybox for FreeBSD
@@ -21,17 +20,21 @@ LICENSE= GPLv2
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
+CONFLICTS_INSTALL= busybox-unstable-*
+
MAKE_JOBS_SAFE= yes
-MAKE_ARGS+= SKIP_STRIP=y
+MAKE_ARGS+= SKIP_STRIP=y CC="${CC}" HOSTCC="${CC}" CXX="${CXX}" HOSTCXX="${CXX}"
USE_BZIP2= yes
USE_GMAKE= yes
# avoid clang, breaks in findutils/find.c l. 752+,
# uses a GCC extension/invalid C code:
-USE_GCC= 4.2+
+USE_GCC?= 4.2+
PLIST_FILES= bin/busybox
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
USE_PERL5_BUILD= yes
PORTDOCS= *
.endif
@@ -50,7 +53,7 @@ do-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
${RM} -f ${DOCSDIR}/.gitignore
.endif