aboutsummaryrefslogtreecommitdiff
path: root/sysutils/busybox
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2011-07-14 10:57:39 +0000
committerMatthias Andree <mandree@FreeBSD.org>2011-07-14 10:57:39 +0000
commitdb405d8512433770561eb01c2bd7697fb2164256 (patch)
treec702e8dc5a49c537b41c414e6b533f87f8520e0b /sysutils/busybox
parent8db330f4bb0497055a408c41a1a0824624d4ca34 (diff)
downloadports-db405d8512433770561eb01c2bd7697fb2164256.tar.gz
ports-db405d8512433770561eb01c2bd7697fb2164256.zip
Notes
Diffstat (limited to 'sysutils/busybox')
-rw-r--r--sysutils/busybox/Makefile20
-rw-r--r--sysutils/busybox/files/patch-strnlen3
2 files changed, 20 insertions, 3 deletions
diff --git a/sysutils/busybox/Makefile b/sysutils/busybox/Makefile
index 5e83f5c90ede..ba4fbdee0452 100644
--- a/sysutils/busybox/Makefile
+++ b/sysutils/busybox/Makefile
@@ -7,20 +7,32 @@
PORTNAME= busybox
PORTVERSION= 1.18.5
+PORTREVISION= 1
CATEGORIES= sysutils misc shells
MASTER_SITES= http://www.busybox.net/downloads/
MAINTAINER= mandree@FreeBSD.org
COMMENT= Busybox for FreeBSD
+LICENSE= GPLv2
+
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
-MAKE_ARGS= SKIP_STRIP=y
+MAKE_JOBS_SAFE= yes
+MAKE_ARGS+= SKIP_STRIP=y
USE_BZIP2= yes
USE_GMAKE= yes
+CPPFLAGS+= -include libgen.h
+# avoid clang, breaks in findutils/find.c l. 752+:
+USE_GCC= 4.2+
PLIST_FILES= bin/busybox
+.if !defined(NOPORTDOCS)
+USE_PERL5_BUILD= yes
+PORTDOCS= *
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/sed/gsed/' ${WRKSRC}/scripts/gen_build_files.sh
@${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' \
@@ -29,9 +41,13 @@ post-patch:
do-configure:
${CP} ${FILESDIR}/data-.config ${WRKSRC}/.config
- cd ${WRKSRC} && ${GMAKE} oldconfig
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} oldconfig
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
+ ${RM} -f ${DOCSDIR}/.gitignore
+.endif
.include <bsd.port.mk>
diff --git a/sysutils/busybox/files/patch-strnlen b/sysutils/busybox/files/patch-strnlen
index bd16f428e69b..5d639049a653 100644
--- a/sysutils/busybox/files/patch-strnlen
+++ b/sysutils/busybox/files/patch-strnlen
@@ -2,12 +2,13 @@ diff --git a/sysklogd/logread.c b/sysklogd/logread.c
index 52c97aa..93b886f 100644
--- sysklogd/logread.c
+++ sysklogd/logread.c
-@@ -14,6 +14,19 @@
+@@ -14,6 +14,20 @@
#include <sys/sem.h>
#include <sys/shm.h>
+#include <osreldate.h>
+#if __FreeBSD_version < 800067
++size_t strnlen(const char *s, size_t maxlen);
+size_t strnlen(const char *s, size_t maxlen)
+{
+ size_t i;