aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ccd2iso
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2004-06-24 11:45:44 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2004-06-24 11:45:44 +0000
commit91bd6bb8dd6392a7217e96fd9fc41201653dc899 (patch)
treeba647201226654b070b8fc75c405ad191aefaf06 /sysutils/ccd2iso
parentf78eb5764e718b579968279a12be89726db96602 (diff)
downloadports-91bd6bb8dd6392a7217e96fd9fc41201653dc899.tar.gz
ports-91bd6bb8dd6392a7217e96fd9fc41201653dc899.zip
Notes
Diffstat (limited to 'sysutils/ccd2iso')
-rw-r--r--sysutils/ccd2iso/Makefile1
-rw-r--r--sysutils/ccd2iso/files/patch-src-ccd2iso.c26
2 files changed, 27 insertions, 0 deletions
diff --git a/sysutils/ccd2iso/Makefile b/sysutils/ccd2iso/Makefile
index ab18c345b1c1..c18d17fadcf7 100644
--- a/sysutils/ccd2iso/Makefile
+++ b/sysutils/ccd2iso/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ccd2iso
PORTVERSION= 0.9
+PORTREVISION?= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/sysutils/ccd2iso/files/patch-src-ccd2iso.c b/sysutils/ccd2iso/files/patch-src-ccd2iso.c
new file mode 100644
index 000000000000..65219723dd75
--- /dev/null
+++ b/sysutils/ccd2iso/files/patch-src-ccd2iso.c
@@ -0,0 +1,26 @@
+
+$FreeBSD$
+
+--- src/ccd2iso.c.orig Thu Nov 13 06:43:41 2003
++++ src/ccd2iso.c Thu Jun 24 15:31:04 2004
+@@ -22,6 +22,7 @@
+ #include <config.h>
+ #endif
+
++#include <err.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <sys/stat.h>
+@@ -47,7 +48,12 @@
+ }
+
+ src_file = fopen(argv[1], "r");
++ if (src_file == NULL)
++ err(1, "%s", argv[1]);
++
+ dst_file = fopen(argv[2], "w");
++ if (dst_file == NULL)
++ err(1, "%s", argv[2]);
+
+ stat(argv[1], &stat_file);
+ total_bytes = stat_file.st_size;