aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cdf
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-10-26 18:41:39 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-10-26 18:41:39 +0000
commitd7aecd0c11fe13f3237992d1b2586df814000e81 (patch)
treeeef154ece5d9820ec2f32eae1e5bd3197606fae5 /sysutils/cdf
parent10e491cce3824bdb611215fef6755186a2330f13 (diff)
downloadports-d7aecd0c11fe13f3237992d1b2586df814000e81.tar.gz
ports-d7aecd0c11fe13f3237992d1b2586df814000e81.zip
Notes
Diffstat (limited to 'sysutils/cdf')
-rw-r--r--sysutils/cdf/Makefile21
-rw-r--r--sysutils/cdf/distinfo2
-rw-r--r--sysutils/cdf/files/patch-colors.c15
-rw-r--r--sysutils/cdf/files/patch-main.c11
-rw-r--r--sysutils/cdf/pkg-descr8
5 files changed, 57 insertions, 0 deletions
diff --git a/sysutils/cdf/Makefile b/sysutils/cdf/Makefile
new file mode 100644
index 000000000000..7da534df9f89
--- /dev/null
+++ b/sysutils/cdf/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: cdf
+# Date created: 2004-10-22
+# Whom: Charlie & <root@lame.novel.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cdf
+PORTVERSION= 0.1
+CATEGORIES= sysutils
+MASTER_SITES= http://bmp-plugins.berlios.de/misc/cdf/
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= A colorized df
+
+PLIST_FILES= bin/cdf
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>
diff --git a/sysutils/cdf/distinfo b/sysutils/cdf/distinfo
new file mode 100644
index 000000000000..dcbcd7be66b7
--- /dev/null
+++ b/sysutils/cdf/distinfo
@@ -0,0 +1,2 @@
+MD5 (cdf-0.1.tar.gz) = 8591e101a9da0844c010804445091545
+SIZE (cdf-0.1.tar.gz) = 147061
diff --git a/sysutils/cdf/files/patch-colors.c b/sysutils/cdf/files/patch-colors.c
new file mode 100644
index 000000000000..7b617b6e8db0
--- /dev/null
+++ b/sysutils/cdf/files/patch-colors.c
@@ -0,0 +1,15 @@
+--- src/colors.c.orig Fri Oct 22 19:03:40 2004
++++ src/colors.c Fri Oct 22 19:04:16 2004
+@@ -53,12 +53,6 @@
+
+ int read_colors()
+ {
+-
+-#ifdef DEBUG
+- if (read_config_file(expand_filename("~/.cdfrc")) != 0)
+- (void)fprintf(stderr, "Using default color theme\n");
+-#endif /* DEBUG */
+-
+ bracket_color = (char *)malloc(64);
+ gauge_color = (char *)malloc(64);
+ header_color = (char *)malloc(64);
diff --git a/sysutils/cdf/files/patch-main.c b/sysutils/cdf/files/patch-main.c
new file mode 100644
index 000000000000..dd5f2a3bfc5d
--- /dev/null
+++ b/sysutils/cdf/files/patch-main.c
@@ -0,0 +1,11 @@
+--- src/main.c.orig Fri Oct 22 19:18:32 2004
++++ src/main.c Fri Oct 22 19:18:43 2004
+@@ -38,6 +38,8 @@
+
+
+ blocksize = 1048576;
++
++ read_config_file(expand_filename("~/.cdfrc"));
+
+ while ((ch = getopt(argc, argv, "gkmt:v")) != -1)
+ switch (ch) {
diff --git a/sysutils/cdf/pkg-descr b/sysutils/cdf/pkg-descr
new file mode 100644
index 000000000000..0c1ab2c16189
--- /dev/null
+++ b/sysutils/cdf/pkg-descr
@@ -0,0 +1,8 @@
+cdf means "colorized df". The main features of cdf are:
+
+ * customazable color schemes
+ * eye-friendly capacity bars
+ * most of such utils needs some 3rd party libraries, python interpreter
+ and so on, while cdf written in pure C
+
+WWW: http://bmp-plugins.berlios.de/misc/cdf/cdf.html