aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cfengine-masterfiles37
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2015-12-07 03:10:43 +0000
committerCy Schubert <cy@FreeBSD.org>2015-12-07 03:10:43 +0000
commit230daa56e1e76aa164b70a217a5144ce4072abec (patch)
tree8819c3d6079bcc1c52b049e0503526d49edf7548 /sysutils/cfengine-masterfiles37
parent52e3eb14e1d9f66e74fabfe5706c982c4e1e8211 (diff)
downloadports-230daa56e1e76aa164b70a217a5144ce4072abec.tar.gz
ports-230daa56e1e76aa164b70a217a5144ce4072abec.zip
Notes
Diffstat (limited to 'sysutils/cfengine-masterfiles37')
-rw-r--r--sysutils/cfengine-masterfiles37/Makefile34
-rw-r--r--sysutils/cfengine-masterfiles37/distinfo2
-rw-r--r--sysutils/cfengine-masterfiles37/files/patch-cfe_internal__update__update_policy.cf36
-rw-r--r--sysutils/cfengine-masterfiles37/pkg-descr10
-rw-r--r--sysutils/cfengine-masterfiles37/pkg-plist130
5 files changed, 212 insertions, 0 deletions
diff --git a/sysutils/cfengine-masterfiles37/Makefile b/sysutils/cfengine-masterfiles37/Makefile
new file mode 100644
index 000000000000..42e1faa6c710
--- /dev/null
+++ b/sysutils/cfengine-masterfiles37/Makefile
@@ -0,0 +1,34 @@
+# Created by: cy@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= cfengine-masterfiles
+PORTVERSION= 3.7.2
+CATEGORIES= sysutils
+MASTER_SITES= https://cfengine-package-repos.s3.amazonaws.com/tarballs/
+
+MAINTAINER= cy@FreeBSD.org
+# gjb@FreeBSD.org is also committer for this port
+# skreuzer@FreeBSD.org is also committer for this port
+COMMENT= cfengine sample policies for installations and upgrades
+
+LICENSE= GPLv3
+
+CPE_VENDOR= gnu
+
+.if !defined(MASTERDIR)
+PKGNAMESUFFIX= 37
+.endif
+
+RUN_DEPENDS= cfengine:${PORTSDIR}/sysutils/cfengine${PKGNAMESUFFIX}
+
+FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
+
+CONFLICTS= cfengine-masterfiles[234]*
+
+MAKE_JOBS_UNSAFE= yes
+USES= cpe
+HAS_CONFIGURE= yes
+EXAMPLESDIR= ${PREFIX}/share/examples/cfengine-masterfiles
+CONFIGURE_ARGS= --prefix=${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/cfengine-masterfiles37/distinfo b/sysutils/cfengine-masterfiles37/distinfo
new file mode 100644
index 000000000000..c9a66e5e46a5
--- /dev/null
+++ b/sysutils/cfengine-masterfiles37/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cfengine-masterfiles-3.7.2.tar.gz) = ed2026d0deca24e9094ec1d0e84a9488eebd470cc23fec940eadbb7106515bc5
+SIZE (cfengine-masterfiles-3.7.2.tar.gz) = 449943
diff --git a/sysutils/cfengine-masterfiles37/files/patch-cfe_internal__update__update_policy.cf b/sysutils/cfengine-masterfiles37/files/patch-cfe_internal__update__update_policy.cf
new file mode 100644
index 000000000000..50323c7e4eb9
--- /dev/null
+++ b/sysutils/cfengine-masterfiles37/files/patch-cfe_internal__update__update_policy.cf
@@ -0,0 +1,36 @@
+Index: update_policy.cf
+===================================================================
+--- cfe_internal/update/update_policy.cf.orig
++++ cfe_internal/update/update_policy.cf
+@@ -239,6 +239,19 @@
+ depth_search => u_recurse_basedir("inf"),
+ action => u_immediate;
+
++ "/usr/local/sbin/$(agents).cfsaved"
++ comment => "Remove all .cfsaved file extension",
++ handle => canonify("cfe_internal_update_policy_files_remove_$(agent)_cfsaved"),
++ delete => u_tidy;
++
++ freebsd::
++ "$(sys.workdir)/bin/$(agents)"
++ comment => "Create symlinks of CFE binaries in /usr/local/sbin",
++ handle => canonify("cfe_internal_update_policy_files_sbin_$(agents)"),
++ move_obstructions => "true",
++ link_from => u_ln_s("/usr/local/sbin/$(agents)");
++
++ !freebsd::
+ "/usr/local/sbin/$(agents)"
+ comment => "Create symlinks of CFE binaries in /usr/local/sbin",
+ handle => canonify("cfe_internal_update_policy_files_sbin_$(agents)"),
+@@ -245,11 +258,6 @@
+ move_obstructions => "true",
+ link_from => u_ln_s("$(sys.workdir)/bin/$(agents)");
+
+- "/usr/local/sbin/$(agents).cfsaved"
+- comment => "Remove all .cfsaved file extension",
+- handle => canonify("cfe_internal_update_policy_files_remove_$(agent)_cfsaved"),
+- delete => u_tidy;
+-
+ am_policy_hub::
+
+ "$(master_location)/."
diff --git a/sysutils/cfengine-masterfiles37/pkg-descr b/sysutils/cfengine-masterfiles37/pkg-descr
new file mode 100644
index 000000000000..3b2329cbc24b
--- /dev/null
+++ b/sysutils/cfengine-masterfiles37/pkg-descr
@@ -0,0 +1,10 @@
+CFEngine 3 is a popular open source configuration management system.
+Its primary function is to provide automated configuration and
+maintenance of large-scale computer systems.
+
+The repository is intended to provide a stable base policy for
+installations and upgrades, and is used by CFEngine 3.6 and newer.
+The port installs the repository as examples which should be copied by
+the user to the masterfiles directory (usually /var/cfengine/masterfiles).
+
+WWW: https://docs.cfengine.com/docs/master/guide-writing-and-serving-policy-policy-framework.html
diff --git a/sysutils/cfengine-masterfiles37/pkg-plist b/sysutils/cfengine-masterfiles37/pkg-plist
new file mode 100644
index 000000000000..4047fb766fb8
--- /dev/null
+++ b/sysutils/cfengine-masterfiles37/pkg-plist
@@ -0,0 +1,130 @@
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/CFE_cfengine.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/core/deprecated/cfengine_processes.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/core/host_info_report.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/core/limit_robot_agents.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/core/log_rotation.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/core/main.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/enterprise/CFE_hub_specific.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/enterprise/CFE_knowledge.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/enterprise/file_change.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/enterprise/ha/ha.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/enterprise/ha/ha_def.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/enterprise/ha/ha_update.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/enterprise/main.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/update/cfe_internal_dc_workflow.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/update/cfe_internal_local_git_remote.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/update/cfe_internal_update_from_repository.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/update/update_bins.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/update/update_policy.cf
+%%EXAMPLESDIR%%/masterfiles/cfe_internal/update/update_processes.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.5/cf_agent.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.5/cf_execd.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.5/cf_hub.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.5/cf_monitord.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.5/cf_runagent.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.5/cf_serverd.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.5/def.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.5/def_inputs.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.5/reports.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.5/update_def.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.5/update_def_inputs.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.6/cf_agent.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.6/cf_execd.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.6/cf_hub.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.6/cf_monitord.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.6/cf_runagent.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.6/cf_serverd.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.6/def.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.6/def_inputs.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.6/reports.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.6/update_def.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.6/update_def_inputs.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.7/cf_agent.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.7/cf_execd.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.7/cf_hub.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.7/cf_monitord.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.7/cf_runagent.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.7/cf_serverd.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.7/def.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.7/def_inputs.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.7/reports.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.7/update_def.cf
+%%EXAMPLESDIR%%/masterfiles/controls/3.7/update_def_inputs.cf
+%%EXAMPLESDIR%%/masterfiles/inventory/any.cf
+%%EXAMPLESDIR%%/masterfiles/inventory/debian.cf
+%%EXAMPLESDIR%%/masterfiles/inventory/freebsd.cf
+%%EXAMPLESDIR%%/masterfiles/inventory/generic.cf
+%%EXAMPLESDIR%%/masterfiles/inventory/linux.cf
+%%EXAMPLESDIR%%/masterfiles/inventory/lsb.cf
+%%EXAMPLESDIR%%/masterfiles/inventory/macos.cf
+%%EXAMPLESDIR%%/masterfiles/inventory/os.cf
+%%EXAMPLESDIR%%/masterfiles/inventory/redhat.cf
+%%EXAMPLESDIR%%/masterfiles/inventory/suse.cf
+%%EXAMPLESDIR%%/masterfiles/inventory/windows.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/bundles.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/cfe_internal.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/commands.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/common.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/databases.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/feature.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/files.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/guest_environments.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/monitor.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/packages.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/paths.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/processes.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/services.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.5/storage.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/autorun.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/bundles.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/cfe_internal.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/cfe_internal_hub.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/cfengine_enterprise_hub_ha.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/commands.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/common.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/databases.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/edit_xml.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/examples.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/feature.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/files.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/guest_environments.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/monitor.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/packages.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/paths.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/processes.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/services.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/stdlib.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/storage.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/users.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.6/vcs.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/autorun.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/bundles.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/cfe_internal.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/cfe_internal_hub.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/cfengine_enterprise_hub_ha.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/commands.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/common.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/databases.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/edit_xml.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/examples.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/feature.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/files.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/guest_environments.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/monitor.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/packages.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/paths.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/processes.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/services.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/stdlib.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/storage.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/users.cf
+%%EXAMPLESDIR%%/masterfiles/lib/3.7/vcs.cf
+%%EXAMPLESDIR%%/masterfiles/promises.cf
+%%EXAMPLESDIR%%/masterfiles/services/autorun/hello.cf
+%%EXAMPLESDIR%%/masterfiles/services/main.cf
+%%EXAMPLESDIR%%/masterfiles/sketches/meta/api-runfile.cf
+%%EXAMPLESDIR%%/masterfiles/templates/host_info_report.mustache
+%%EXAMPLESDIR%%/masterfiles/update.cf
+%%EXAMPLESDIR%%/modules/packages/apt_get
+%%EXAMPLESDIR%%/modules/packages/yum
+