aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cfengine3-legacy
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-02-10 21:37:55 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-02-10 21:37:55 +0000
commit580b911de3b0a5ef1d6a68ad56bea0515bb08f64 (patch)
treea5fabe5c8994fdc2621dee80033137553deed3b1 /sysutils/cfengine3-legacy
parentf9941ead1b1bbfeaf35219b0c790ebcf9bef2ad3 (diff)
downloadports-580b911de3b0a5ef1d6a68ad56bea0515bb08f64.tar.gz
ports-580b911de3b0a5ef1d6a68ad56bea0515bb08f64.zip
Notes
Diffstat (limited to 'sysutils/cfengine3-legacy')
-rw-r--r--sysutils/cfengine3-legacy/Makefile67
-rw-r--r--sysutils/cfengine3-legacy/distinfo6
-rw-r--r--sysutils/cfengine3-legacy/files/cf-execd.in30
-rw-r--r--sysutils/cfengine3-legacy/files/cf-serverd.in30
-rw-r--r--sysutils/cfengine3-legacy/files/cfexecd.in30
-rw-r--r--sysutils/cfengine3-legacy/files/cfservd.in30
-rw-r--r--sysutils/cfengine3-legacy/files/patch-Makefile.in40
-rw-r--r--sysutils/cfengine3-legacy/files/patch-contrib_Makefile.in18
-rw-r--r--sysutils/cfengine3-legacy/files/patch-doc_Makefile.in75
-rw-r--r--sysutils/cfengine3-legacy/files/patch-inputs_Makefile.in18
-rw-r--r--sysutils/cfengine3-legacy/pkg-descr15
-rw-r--r--sysutils/cfengine3-legacy/pkg-plist54
12 files changed, 127 insertions, 286 deletions
diff --git a/sysutils/cfengine3-legacy/Makefile b/sysutils/cfengine3-legacy/Makefile
index a1077d4f3db1..1b709381f200 100644
--- a/sysutils/cfengine3-legacy/Makefile
+++ b/sysutils/cfengine3-legacy/Makefile
@@ -1,53 +1,62 @@
-# New ports collection makefile for: cfengine
-# Date created: March 16, 1998
-# Whom: jseger@FreeBSD.org
+# New ports collection makefile for: cfengine v3
+# Date created: February 2, 2009
+# Whom: jrhett@netconsonance.com
#
# $FreeBSD$
#
PORTNAME= cfengine
-PORTVERSION= 2.2.9
+PORTVERSION= 3.0.1
+DISTVERSION= 3.0.1a7
CATEGORIES= sysutils
MASTER_SITES= http://www.cfengine.org/downloads/
MAINTAINER= jrhett@netconsonance.com
COMMENT= A systems administration tool for networks
+LATEST_LINK= cfengine3
-USE_RC_SUBR= cfexecd cfservd
+USE_RC_SUBR= cf-execd cf-serverd
-WITH_BDB_VER?= 46
+WITH_BDB_VER?= 47
USE_BDB= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-docs \
- --docdir=${DOCSDIR} \
- --htmldir=${DOCSDIR}/html
-CONFIGURE_ENV+= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS} \
- BERKELEY_DB_CFLAGS=-I${BDB_INCLUDE_DIR} \
+BUILD_DEPENDS=
+EXAMPLESDIR= ${PREFIX}/share/examples/cfengine3
+DOCSDIR= ${PREFIX}/share/doc/cfengine3
+CONFIGURE_ARGS= --docdir=${DOCSDIR} \
+ --htmldir=${DOCSDIR}/html \
+ --with-berkeleydb=${LOCALBASE}
+
+CONFIGURE_ENV+= BERKELEY_DB_CFLAGS=-I${BDB_INCLUDE_DIR} \
BERKELEY_DB_LDFLAGS=-L${BDB_LIB_DIR} \
BERKELEY_DB_LIB=-l${BDB_LIB_NAME}
-.if !defined(NOPORTDOCS)
-INFO= cfengine-Tutorial cfengine-Reference cfengine-Anomalies
+
+OPTIONS= PCRE "Enable Perl-compatible regular expressions" on
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PCRE)
+BUILD_DEPENDS+= ${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}
.endif
-MAN8= cfagent.8 cfengine.8 cfenvd.8 cfenvgraph.8 cfetoolcheck.8 \
- cfetoolcreate.8 cfetooldump.8 cfetoolgraph.8 cfetoolimport.8 \
- cfetoolinfo.8 cfetoolupdate.8 cfexecd.8 cfkey.8 \
- cfrun.8 cfservd.8 cfshow.8
+MAN8= cf-agent.8 cf-key.8 cf-monitord.8 \
+ cf-report.8 cf-serverd.8 cf-execd.8 \
+ cf-know.8 cf-promise.8 cf-runagent.8
+
+.if !defined(NOPORTDOCS)
+INFO= cf3-reference
+.endif
post-patch:
- @${REINPLACE_CMD} -e s,-pthread,${PTHREAD_CFLAGS},g \
- -e s,-lpthread,${PTHREAD_LIBS},g \
- -e s,lpthread,${PTHREAD_LIBS},g \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^pkgdatadir/s!=.*!= ${EXAMPLESDIR}!'\
+ ${WRKSRC}/inputs/Makefile.in
+
@${REINPLACE_CMD} -e '/^docdir/s!=.*!= @docdir@!'\
- ${WRKSRC}/doc/Makefile.in \
- ${WRKSRC}/Makefile.in
+ ${WRKSRC}/tests/file_masters/Makefile.in \
+ ${WRKSRC}/tests/units/Makefile.in
+
@${REINPLACE_CMD} -e '/^htmldir/s!=.*!= @htmldir@!'\
- ${WRKSRC}/doc/Makefile.in \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e '/^pkgdatadir/s!=.*!= ${EXAMPLESDIR}!'\
- ${WRKSRC}/inputs/Makefile.in \
- ${WRKSRC}/contrib/Makefile.in
+ ${WRKSRC}/docs/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/cfengine3-legacy/distinfo b/sysutils/cfengine3-legacy/distinfo
index f9dd09c0f296..708e674a5c15 100644
--- a/sysutils/cfengine3-legacy/distinfo
+++ b/sysutils/cfengine3-legacy/distinfo
@@ -1,3 +1,3 @@
-MD5 (cfengine-2.2.9.tar.gz) = ce115587078a7a8345dca52891f95513
-SHA256 (cfengine-2.2.9.tar.gz) = 98489dd49a15c4e6f2065435d415a4a5d0b79d67b10478eeb0a0de579a6bade2
-SIZE (cfengine-2.2.9.tar.gz) = 2933246
+MD5 (cfengine-3.0.1a7.tar.gz) = c3b10df0717024084309eb3a477c116b
+SHA256 (cfengine-3.0.1a7.tar.gz) = c1592b0c8185bd4459dd145828011880bf4756bb3cb439385f35cee2d947523b
+SIZE (cfengine-3.0.1a7.tar.gz) = 1143539
diff --git a/sysutils/cfengine3-legacy/files/cf-execd.in b/sysutils/cfengine3-legacy/files/cf-execd.in
new file mode 100644
index 000000000000..064c4d842e88
--- /dev/null
+++ b/sysutils/cfengine3-legacy/files/cf-execd.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: cf-execd
+# REQUIRE: SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following line to /etc/rc.conf[.local] to enable cf-execd(8)
+#
+# cf-execd_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable cf-execd.
+# cf-execd_flags (str): Custom additional arguments to be passed
+# to cf-execd (default empty).
+#
+
+. %%RC_SUBR%%
+
+name="cf-execd"
+rcvar=${name}_enable
+
+command="%%PREFIX%%/sbin/${name}"
+
+load_rc_config $name
+
+: ${cf-execd_enable="NO"}
+: ${cf-execd_flags=""}
+
+run_rc_command "$1"
diff --git a/sysutils/cfengine3-legacy/files/cf-serverd.in b/sysutils/cfengine3-legacy/files/cf-serverd.in
new file mode 100644
index 000000000000..3f3cd7a5b46a
--- /dev/null
+++ b/sysutils/cfengine3-legacy/files/cf-serverd.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: cf-serverd
+# REQUIRE: SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following line to /etc/rc.conf[.local] to enable cf-serverd(8)
+#
+# cf-serverd_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable cf-serverd.
+# cf-serverd_flags (str): Custom additional arguments to be passed
+# to cf-serverd (default empty).
+#
+
+. %%RC_SUBR%%
+
+name="cf-serverd"
+rcvar=${name}_enable
+
+command="%%PREFIX%%/sbin/${name}"
+
+load_rc_config $name
+
+: ${cf-serverd_enable="NO"}
+: ${cf-serverd_flags=""}
+
+run_rc_command "$1"
diff --git a/sysutils/cfengine3-legacy/files/cfexecd.in b/sysutils/cfengine3-legacy/files/cfexecd.in
deleted file mode 100644
index a892216ff80e..000000000000
--- a/sysutils/cfengine3-legacy/files/cfexecd.in
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: cfexecd
-# REQUIRE: SERVERS
-# BEFORE: DAEMON
-# KEYWORD: shutdown
-#
-# Add the following line to /etc/rc.conf[.local] to enable cfexecd(8)
-#
-# cfexecd_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable cfexecd.
-# cfexecd_flags (str): Custom additional arguments to be passed
-# to cfexecd (default empty).
-#
-
-. %%RC_SUBR%%
-
-name="cfexecd"
-rcvar=${name}_enable
-
-command="%%PREFIX%%/sbin/${name}"
-
-load_rc_config $name
-
-: ${cfexecd_enable="NO"}
-: ${cfexecd_flags=""}
-
-run_rc_command "$1"
diff --git a/sysutils/cfengine3-legacy/files/cfservd.in b/sysutils/cfengine3-legacy/files/cfservd.in
deleted file mode 100644
index caa8300fd181..000000000000
--- a/sysutils/cfengine3-legacy/files/cfservd.in
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: cfservd
-# REQUIRE: SERVERS
-# BEFORE: DAEMON
-# KEYWORD: shutdown
-#
-# Add the following line to /etc/rc.conf[.local] to enable cfservd(8)
-#
-# cfservd_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable cfservd.
-# cfservd_flags (str): Custom additional arguments to be passed
-# to cfservd (default empty).
-#
-
-. %%RC_SUBR%%
-
-name="cfservd"
-rcvar=${name}_enable
-
-command="%%PREFIX%%/sbin/${name}"
-
-load_rc_config $name
-
-: ${cfservd_enable="NO"}
-: ${cfservd_flags=""}
-
-run_rc_command "$1"
diff --git a/sysutils/cfengine3-legacy/files/patch-Makefile.in b/sysutils/cfengine3-legacy/files/patch-Makefile.in
deleted file mode 100644
index 558288e16305..000000000000
--- a/sysutils/cfengine3-legacy/files/patch-Makefile.in
+++ /dev/null
@@ -1,40 +0,0 @@
---- Makefile.in.orig Mon Aug 4 10:55:48 2008
-+++ Makefile.in Tue Aug 12 23:03:09 2008
-@@ -187,7 +187,7 @@
- builddir = @builddir@
- datadir = @datadir@
- datarootdir = @datarootdir@
--docdir = $(pkgdatadir)
-+docdir = $(prefix)/share/doc/cfengine
- dvidir = @dvidir@
- exec_prefix = @exec_prefix@
- host = @host@
-@@ -225,7 +225,11 @@
- @BUILD_DOC_TRUE@DOC_DIR = doc
- SUBDIRS = pub src contrib inputs $(DOC_DIR)
- EXTRA_DIST = acconfig.h doc/cfengine.8 COPYING ChangeLog INSTALL NEWS README LICENSE
--doc_DATA = README ChangeLog INSTALL NEWS
-+.if defined(NOPORTDOCS)
-+doc_DATA =
-+.else
-+doc_DATA = README ChangeLog INSTALL NEWS AUTHORS TODO
-+.endif
-
- #
- # Some basic clean ups
-@@ -300,6 +304,7 @@
- -rm -f libtool
- install-docDATA: $(doc_DATA)
- @$(NORMAL_INSTALL)
-+.if !defined(NOPORTDOCS)
- test -z "$(docdir)" || $(MKDIR_P) "$(DESTDIR)$(docdir)"
- @list='$(doc_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
-@@ -307,6 +312,7 @@
- echo " $(docDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(docdir)/$$f'"; \
- $(docDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
- done
-+.endif
-
- uninstall-docDATA:
- @$(NORMAL_UNINSTALL)
diff --git a/sysutils/cfengine3-legacy/files/patch-contrib_Makefile.in b/sysutils/cfengine3-legacy/files/patch-contrib_Makefile.in
deleted file mode 100644
index 5dac09930b39..000000000000
--- a/sysutils/cfengine3-legacy/files/patch-contrib_Makefile.in
+++ /dev/null
@@ -1,18 +0,0 @@
---- contrib/Makefile.in.orig 2008-07-01 22:50:46.000000000 -0400
-+++ contrib/Makefile.in 2008-07-01 22:51:08.000000000 -0400
-@@ -251,6 +251,7 @@
- cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
- install-pkgdataSCRIPTS: $(pkgdata_SCRIPTS)
- @$(NORMAL_INSTALL)
-+.if !defined(NOPORTEXAMPLES)
- test -z "$(pkgdatadir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)"
- @list='$(pkgdata_SCRIPTS)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
-@@ -260,6 +261,7 @@
- $(pkgdataSCRIPT_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgdatadir)/$$f"; \
- else :; fi; \
- done
-+.endif
-
- uninstall-pkgdataSCRIPTS:
- @$(NORMAL_UNINSTALL)
diff --git a/sysutils/cfengine3-legacy/files/patch-doc_Makefile.in b/sysutils/cfengine3-legacy/files/patch-doc_Makefile.in
deleted file mode 100644
index 622933721277..000000000000
--- a/sysutils/cfengine3-legacy/files/patch-doc_Makefile.in
+++ /dev/null
@@ -1,75 +0,0 @@
---- doc/Makefile.in.orig 2008-12-24 06:42:47.000000000 -0800
-+++ doc/Makefile.in 2009-02-02 14:27:17.000000000 -0800
-@@ -220,7 +220,7 @@
- man_MANS = cfengine.8 cfagent.8 cfenvd.8 cfenvgraph.8 cfexecd.8 cfkey.8 cfrun.8 cfservd.8 cfshow.8 cfetoolcheck.8 cfetooldump.8 cfetoolimport.8 cfetoolupdate.8 cfetoolcreate.8 cfetoolgraph.8 cfetoolinfo.8
-
- # Info used in building the Info files
--info_TEXINFOS = cfengine-Reference.texinfo cfengine-Tutorial.texinfo cfengine-Anomalies.texinfo
-+info_TEXINFOS =
- infofiles = $(info_TEXINFOS:.texinfo=.info)
- MAKEINFOHTML = $(MAKEINFO) --html --no-split --css-include=cfcomdoc.css
-
-@@ -543,6 +543,7 @@
- done
-
- dist-info: $(INFO_DEPS)
-+.if !defined(NOPORTDOCS)
- @srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
- list='$(INFO_DEPS)'; \
- for base in $$list; do \
-@@ -559,6 +560,7 @@
- else :; fi; \
- done; \
- done
-+.endif
-
- mostlyclean-aminfo:
- -rm -rf cfengine-Reference.aux cfengine-Reference.cp cfengine-Reference.cps \
-@@ -648,6 +650,7 @@
- done
- install-docDATA: $(doc_DATA)
- @$(NORMAL_INSTALL)
-+.if !defined(NOPORTDOCS)
- test -z "$(docdir)" || $(MKDIR_P) "$(DESTDIR)$(docdir)"
- @list='$(doc_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
-@@ -655,6 +658,7 @@
- echo " $(docDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(docdir)/$$f'"; \
- $(docDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
- done
-+.endif
-
- uninstall-docDATA:
- @$(NORMAL_UNINSTALL)
-@@ -665,6 +669,7 @@
- done
- install-htmlDATA: $(html_DATA)
- @$(NORMAL_INSTALL)
-+.if !defined(NOPORTDOCS)
- test -z "$(htmldir)" || $(MKDIR_P) "$(DESTDIR)$(htmldir)"
- @list='$(html_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
-@@ -672,6 +677,7 @@
- echo " $(htmlDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(htmldir)/$$f'"; \
- $(htmlDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(htmldir)/$$f"; \
- done
-+.endif
-
- uninstall-htmlDATA:
- @$(NORMAL_UNINSTALL)
-@@ -808,6 +814,7 @@
- install-info: install-info-am
-
- install-info-am: $(INFO_DEPS)
-+.if !defined(NOPORTDOCS)
- @$(NORMAL_INSTALL)
- test -z "$(infodir)" || $(MKDIR_P) "$(DESTDIR)$(infodir)"
- @srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
-@@ -837,6 +844,7 @@
- install-info --info-dir="$(DESTDIR)$(infodir)" "$(DESTDIR)$(infodir)/$$relfile" || :;\
- done; \
- else : ; fi
-+.endif
- install-man: install-man8
-
- install-pdf: install-pdf-am
diff --git a/sysutils/cfengine3-legacy/files/patch-inputs_Makefile.in b/sysutils/cfengine3-legacy/files/patch-inputs_Makefile.in
deleted file mode 100644
index bac3996a6dc6..000000000000
--- a/sysutils/cfengine3-legacy/files/patch-inputs_Makefile.in
+++ /dev/null
@@ -1,18 +0,0 @@
---- inputs/Makefile.in.orig 2008-07-01 22:51:16.000000000 -0400
-+++ inputs/Makefile.in 2008-07-01 22:51:37.000000000 -0400
-@@ -267,6 +267,7 @@
- cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
- install-pkgdataSCRIPTS: $(pkgdata_SCRIPTS)
- @$(NORMAL_INSTALL)
-+.if !defined(NOPORTEXAMPLES)
- test -z "$(pkgdatadir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)"
- @list='$(pkgdata_SCRIPTS)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
-@@ -276,6 +277,7 @@
- $(pkgdataSCRIPT_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgdatadir)/$$f"; \
- else :; fi; \
- done
-+.endif
-
- uninstall-pkgdataSCRIPTS:
- @$(NORMAL_UNINSTALL)
diff --git a/sysutils/cfengine3-legacy/pkg-descr b/sysutils/cfengine3-legacy/pkg-descr
index b1a53d4609d2..7c0c7eb39135 100644
--- a/sysutils/cfengine3-legacy/pkg-descr
+++ b/sysutils/cfengine3-legacy/pkg-descr
@@ -1,9 +1,10 @@
-Cfengine, or the configuration engine is an agent/software robot and a
-very high level language for building expert systems to administrate
-and configure large computer networks. Cfengine uses the idea of
-classes and a primitive form of intelligence to define and automate
-the configuration and maintenance of system state, for small to huge
-configurations. Cfengine is designed to be a part of a computer immune
-system.
+Cfengine is an automated suite of programs for configuring and
+maintaining Unix-like computers. It has been used on computing arrays
+of between 1 and 20,000 computers since 1993 by a wide range of
+organizations. Cfengine is supported by active research and was the
+first autonomic, hands-free management system for Unix-like operating
+systems. Cfengine is an autonomic maintenance system not merely a
+change management roll-out tool. Cfengine has a history of security
+and adaptability.
WWW: http://www.cfengine.org/
diff --git a/sysutils/cfengine3-legacy/pkg-plist b/sysutils/cfengine3-legacy/pkg-plist
index 59ee35803ad5..6666ad838c65 100644
--- a/sysutils/cfengine3-legacy/pkg-plist
+++ b/sysutils/cfengine3-legacy/pkg-plist
@@ -1,43 +1,25 @@
@comment $FreeBSD$
-lib/libcfengine.la
-lib/libcfengine.a
-sbin/cfagent
-sbin/cfdoc
-sbin/cfenvd
-sbin/cfenvgraph
-sbin/cfetool
-sbin/cfetoolgraph
-sbin/cfexecd
-sbin/cfkey
-sbin/cfrun
-sbin/cfservd
-sbin/cfshow
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.chflags.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.freebsd.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.ftp.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.groups.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.linux.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.main.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.motd.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.preconf.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.services.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.site.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.solaris.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.sun4.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cf.users.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cfagent.conf-advanced.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cfagent.conf.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cfengine.el
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cfrc.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cfrun.hosts.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cfservd.conf.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/update.conf.example
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+lib/libpromises.la
+lib/libpromises.a
+sbin/cf-agent
+sbin/cf-execd
+sbin/cf-key
+sbin/cf-know
+sbin/cf-monitord
+sbin/cf-promises
+sbin/cf-report
+sbin/cf-runagent
+sbin/cf-serverd
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/failsafe.cf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/library.cf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/promises.cf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/site.cf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/update.cf
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/cf3-Reference.pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%