aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cfengine3
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2012-04-19 04:21:15 +0000
committerCy Schubert <cy@FreeBSD.org>2012-04-19 04:21:15 +0000
commit304dafefee551e611751565830a89f709975d05b (patch)
treed7d39c4db4f6ba98071fc611a08bb5fdd0aee735 /sysutils/cfengine3
parentc33757b213b379d62e4e07c7444d21a6117ad30d (diff)
downloadports-304dafefee551e611751565830a89f709975d05b.tar.gz
ports-304dafefee551e611751565830a89f709975d05b.zip
Notes
Diffstat (limited to 'sysutils/cfengine3')
-rw-r--r--sysutils/cfengine3/Makefile57
-rw-r--r--sysutils/cfengine3/distinfo4
-rw-r--r--sysutils/cfengine3/pkg-plist32
3 files changed, 64 insertions, 29 deletions
diff --git a/sysutils/cfengine3/Makefile b/sysutils/cfengine3/Makefile
index afbc3936b3e2..7af0239439a8 100644
--- a/sysutils/cfengine3/Makefile
+++ b/sysutils/cfengine3/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: cfengine v3
+
# Date created: February 2, 2009
# Whom: jrhett@netconsonance.com
#
@@ -6,44 +6,73 @@
#
PORTNAME= cfengine
-PORTVERSION= 3.2.3
-PORTREVISION= 1
+PORTVERSION= 3.3.0
CATEGORIES= sysutils
MASTER_SITES= http://cfengine.com/source-code/download?file=
MAINTAINER= cy@FreeBSD.org
COMMENT= A systems administration tool for networks
LATEST_LINK= cfengine3
-FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
+FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
+
+CONFLICTS= cfengine-2*
USE_RC_SUBR= cf-execd cf-serverd
-WITH_BDB_VER?= 47
-USE_BDB= yes
+USE_LDCONFIG= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
# EXAMPLESDIR= ${PREFIX}/share/examples/cfengine3
-DOCSDIR= ${PREFIX}/share/doc/cfengine3
+DOCSDIR= ${PREFIX}/share/doc/cfengine
CONFIGURE_ARGS= --docdir=${DOCSDIR} \
--htmldir=${DOCSDIR}/html \
- --with-berkeleydb=${LOCALBASE}
+ --mandir=${PREFIX}/man \
+ --enable-fhs
-CONFIGURE_ENV+= BERKELEY_DB_CFLAGS=-I${BDB_INCLUDE_DIR} \
- BERKELEY_DB_LDFLAGS=-L${BDB_LIB_DIR} \
- BERKELEY_DB_LIB=-l${BDB_LIB_NAME}
+OPTIONS= PCRE "Enable Perl-compatible regular expressions" on \
+ TOKYOCABINET "Enable TokyoCabinet support" on \
+ QDBM "Enable QDBM support" off \
+ PGSQL "Enable PostgreSQL connector" off \
+ MYSQL "Enable MySQL connector" off
-OPTIONS= PCRE "Enable Perl-compatible regular expressions" on
.include <bsd.port.pre.mk>
+.if defined(WITH_TOKYOCABINET) && defined(WITH_QDBM)
+BROKEN= TOKYOCABINET and QDBM are mutuallly exclusive
+.endif
+
.if defined(WITH_PCRE)
-LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}
.endif
+.if defined(WITH_TOKYOCABINET)
+CONFIGURE_ARGS+= --with-tokyocabinet=${LOCALBASE}
+LIB_DEPENDS+= tokyocabinet.9:${PORTSDIR}/databases/tokyocabinet
+.endif
+
+.if defined(WITH_QDBM)
+CONFIGURE_ARGS+= --with-qdbm=${LOCALBASE}
+LIB_DEPENDS+= qdbm.14:${PORTSDIR}/databases/qdbm
+.endif
+
+.if defined(WITH_PGSQL)
+CONFIGURE_ARGS+= --with-postgresql=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --with-postgresql=no
+.endif
+
+.if defined(WITH_MYSQL)
+CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --with-mysql=no
+.endif
+
+
MAN8= cf-agent.8 cf-key.8 cf-monitord.8 \
cf-report.8 cf-serverd.8 cf-execd.8 \
cf-know.8 cf-promises.8 cf-runagent.8
-
post-patch:
@${REINPLACE_CMD} -e '/^htmldir/s!=.*!= @htmldir@!'\
diff --git a/sysutils/cfengine3/distinfo b/sysutils/cfengine3/distinfo
index 273366103b79..dbede959d2cd 100644
--- a/sysutils/cfengine3/distinfo
+++ b/sysutils/cfengine3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cfengine-3.2.3.tar.gz) = 20748f2d10ec4e3623138c2ae1cf7d78d147b8c5c15be42965c3155d0762792d
-SIZE (cfengine-3.2.3.tar.gz) = 1128462
+SHA256 (cfengine-3.3.0.tar.gz) = 170a65cce35b9b333594543b9b3480e5d9c19c28e275431e6e58a3be9372c0a7
+SIZE (cfengine-3.3.0.tar.gz) = 1236769
diff --git a/sysutils/cfengine3/pkg-plist b/sysutils/cfengine3/pkg-plist
index a42b443c43bc..16fde280b479 100644
--- a/sysutils/cfengine3/pkg-plist
+++ b/sysutils/cfengine3/pkg-plist
@@ -1,6 +1,6 @@
-lib/libpromises.la
-lib/libpromises.so
-lib/libpromises.so.1
+libexec/cfengine/libpromises.la
+libexec/cfengine/libpromises.so
+libexec/cfengine/libpromises.so.1
sbin/cf-agent
sbin/cf-execd
sbin/cf-key
@@ -10,9 +10,9 @@ sbin/cf-promises
sbin/cf-report
sbin/cf-runagent
sbin/cf-serverd
-share/cfengine/masterfiles/cfengine_stdlib.cf
-share/cfengine/masterfiles/failsafe.cf
-share/cfengine/masterfiles/promises.cf
+share/cfengine/CoreBase/failsafe.cf
+share/cfengine/CoreBase/cfengine_stdlib.cf
+share/cfengine/CoreBase/promises.cf
%%DOCSDIR%%/ChangeLog
%%DOCSDIR%%/README
%%DOCSDIR%%/example_config/cfengine_stdlib.cf
@@ -22,7 +22,8 @@ share/cfengine/masterfiles/promises.cf
%%DOCSDIR%%/example_config/update.cf
%%DOCSDIR%%/examples/active_directory.cf
%%DOCSDIR%%/examples/app_baseline.cf
-%%DOCSDIR%%/examples/cfengine_stdlib.cf
+%%DOCSDIR%%/examples/guest_environment_kvm.cf
+%%DOCSDIR%%/examples/hostswithclass.cf
%%DOCSDIR%%/examples/promise_knowledge.cf
%%DOCSDIR%%/examples/unit_abort.cf
%%DOCSDIR%%/examples/unit_accessed_before.cf
@@ -80,8 +81,6 @@ share/cfengine/masterfiles/promises.cf
%%DOCSDIR%%/examples/unit_edit_setvar.cf
%%DOCSDIR%%/examples/unit_edit_triggerclass.cf
%%DOCSDIR%%/examples/unit_env.cf
-%%DOCSDIR%%/examples/unit_environment.cf
-%%DOCSDIR%%/examples/unit_environment_simple.cf
%%DOCSDIR%%/examples/unit_epimenides.cf
%%DOCSDIR%%/examples/unit_escape.cf
%%DOCSDIR%%/examples/unit_exec_args.cf
@@ -145,12 +144,15 @@ share/cfengine/masterfiles/promises.cf
%%DOCSDIR%%/examples/unit_log_private.cf
%%DOCSDIR%%/examples/unit_loops.cf
%%DOCSDIR%%/examples/unit_lsdir.cf
+%%DOCSDIR%%/examples/unit_maplist.cf
%%DOCSDIR%%/examples/unit_measure_log.cf
%%DOCSDIR%%/examples/unit_measurements.cf
%%DOCSDIR%%/examples/unit_menu.cf
%%DOCSDIR%%/examples/unit_method.cf
+%%DOCSDIR%%/examples/unit_method_polymorph.cf
%%DOCSDIR%%/examples/unit_method_validate.cf
%%DOCSDIR%%/examples/unit_method_var.cf
+%%DOCSDIR%%/examples/unit_method_var2.cf
%%DOCSDIR%%/examples/unit_module_exec.cf
%%DOCSDIR%%/examples/unit_module_exec_2.cf
%%DOCSDIR%%/examples/unit_monitord.cf
@@ -159,10 +161,11 @@ share/cfengine/masterfiles/promises.cf
%%DOCSDIR%%/examples/unit_neighbourhood_watch.cf
%%DOCSDIR%%/examples/unit_null_config.cf
%%DOCSDIR%%/examples/unit_occurrences.cf
+%%DOCSDIR%%/examples/unit_orchestration_hostlist.cf
%%DOCSDIR%%/examples/unit_ordering.cf
%%DOCSDIR%%/examples/unit_package_apt.cf
%%DOCSDIR%%/examples/unit_package_freebsd.cf
-%%DOCSDIR%%/examples/unit_package_hash.cf
+%%DOCSDIR%%/examples/unit_package_latest.cf
%%DOCSDIR%%/examples/unit_package_msi_file.cf
%%DOCSDIR%%/examples/unit_package_msi_version.cf
%%DOCSDIR%%/examples/unit_package_rpm.cf
@@ -182,7 +185,6 @@ share/cfengine/masterfiles/promises.cf
%%DOCSDIR%%/examples/unit_process_restart.cf
%%DOCSDIR%%/examples/unit_process_restart_basic.cf
%%DOCSDIR%%/examples/unit_process_signalling.cf
-%%DOCSDIR%%/examples/unit_services_win.cf
%%DOCSDIR%%/examples/unit_product.cf
%%DOCSDIR%%/examples/unit_promises.cf
%%DOCSDIR%%/examples/unit_readlist.cf
@@ -218,9 +220,12 @@ share/cfengine/masterfiles/promises.cf
%%DOCSDIR%%/examples/unit_server_flatcopy_localhost.cf
%%DOCSDIR%%/examples/unit_service_disable.cf
%%DOCSDIR%%/examples/unit_service_start.cf
+%%DOCSDIR%%/examples/unit_services_concept.cf
+%%DOCSDIR%%/examples/unit_services_win.cf
%%DOCSDIR%%/examples/unit_setuidlog.cf
%%DOCSDIR%%/examples/unit_setvar.cf
%%DOCSDIR%%/examples/unit_software_dist.cf
+%%DOCSDIR%%/examples/unit_software_update_version_yum.cf
%%DOCSDIR%%/examples/unit_splitstring.cf
%%DOCSDIR%%/examples/unit_sql.cf
%%DOCSDIR%%/examples/unit_storage.cf
@@ -245,12 +250,13 @@ share/cfengine/masterfiles/promises.cf
%%DOCSDIR%%/examples/unit_warnifline.cf
%%DOCSDIR%%/examples/unit_webserver.cf
%%DOCSDIR%%/examples/unit_zenoss.cf
+%%DOCSDIR%%/examples/win_dns_client.cf
%%DOCSDIR%%/examples/win_emergency.cf
%%DOCSDIR%%/examples/win_registry.cf
%%DOCSDIR%%/examples/win_schedule.cf
-%%DOCSDIR%%/examples/win_services.cf
@dirrm %%DOCSDIR%%/examples
@dirrm %%DOCSDIR%%/example_config
@dirrm %%DOCSDIR%%
-@dirrm share/cfengine/masterfiles
+@dirrm share/cfengine/CoreBase
@dirrm share/cfengine
+@dirrm libexec/cfengine