aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cloop-utils
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2004-06-28 01:17:38 +0000
committerMax Khon <fjoe@FreeBSD.org>2004-06-28 01:17:38 +0000
commit8fbb1f7acc48d72e60e28906def769e9db3c53b4 (patch)
tree19d3e12226a805bac3949d40ff38b598353c352f /sysutils/cloop-utils
parent8a65d874ab48e5c69b52cb9214e2c607a7858eee (diff)
downloadports-8fbb1f7acc48d72e60e28906def769e9db3c53b4.tar.gz
ports-8fbb1f7acc48d72e60e28906def769e9db3c53b4.zip
Notes
Diffstat (limited to 'sysutils/cloop-utils')
-rw-r--r--sysutils/cloop-utils/Makefile14
-rw-r--r--sysutils/cloop-utils/distinfo4
-rw-r--r--sysutils/cloop-utils/files/patch-Makefile16
-rw-r--r--sysutils/cloop-utils/files/patch-create_compressed_fs.c57
-rw-r--r--sysutils/cloop-utils/files/patch-extract_compressed_fs.c33
-rw-r--r--sysutils/cloop-utils/pkg-plist2
6 files changed, 13 insertions, 113 deletions
diff --git a/sysutils/cloop-utils/Makefile b/sysutils/cloop-utils/Makefile
index 8cfd3bf7389b..ed7cb45f6272 100644
--- a/sysutils/cloop-utils/Makefile
+++ b/sysutils/cloop-utils/Makefile
@@ -6,18 +6,26 @@
#
PORTNAME= cloop-utils
-PORTVERSION= 2.01
+PORTVERSION= ${CLOOP_VERSION}.${CLOOP_REVISION}
CATEGORIES= sysutils
MASTER_SITES= http://developer.linuxtag.net/knoppix/sources/
-DISTNAME= cloop_${PORTVERSION}-1
+DISTNAME= cloop_${CLOOP_VERSION}-${CLOOP_REVISION}
MAINTAINER= fjoe@FreeBSD.org
COMMENT= Compressed loop FS utils
-WRKSRC= ${WRKDIR}/cloop-${PORTVERSION}
+WRKSRC= ${WRKDIR}/cloop-${CLOOP_VERSION}
USE_GMAKE= yes
+USE_REINPLACE= yes
MAKE_ENV= APPSONLY=yes
PORTDOCS= README
+PLIST_FILES= bin/create_compressed_fs bin/extract_compressed_fs
+
+CLOOP_VERSION= 2.01
+CLOOP_REVISION= 2
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/^CFLAGS:=/CFLAGS?=/' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/create_compressed_fs ${PREFIX}/bin
diff --git a/sysutils/cloop-utils/distinfo b/sysutils/cloop-utils/distinfo
index 3f0181a6b2ef..3fe49bf5a91c 100644
--- a/sysutils/cloop-utils/distinfo
+++ b/sysutils/cloop-utils/distinfo
@@ -1,2 +1,2 @@
-MD5 (cloop_2.01-1.tar.gz) = f69971fdfbb93ebcd37aa35e2bd4e460
-SIZE (cloop_2.01-1.tar.gz) = 21862
+MD5 (cloop_2.01-2.tar.gz) = 2458db44bb97bbe9a88d420e3a07d100
+SIZE (cloop_2.01-2.tar.gz) = 22440
diff --git a/sysutils/cloop-utils/files/patch-Makefile b/sysutils/cloop-utils/files/patch-Makefile
deleted file mode 100644
index 153f237ebbbb..000000000000
--- a/sysutils/cloop-utils/files/patch-Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
---- Makefile.orig Thu Jan 15 10:34:31 2004
-+++ Makefile Thu Jan 15 10:34:31 2004
-@@ -23,8 +23,12 @@
- endif
-
- KERNOBJ:=compressed_loop.o
-+ALL_TARGETS = create_compressed_fs extract_compressed_fs
-+ifndef APPSONLY
-+ALL_TARGETS += cloop.o
-+endif
-
--all: cloop.o create_compressed_fs extract_compressed_fs
-+all: $(ALL_TARGETS)
-
- cloop.o: compressed_loop.o
- $(LD) -r -o $@ $^
diff --git a/sysutils/cloop-utils/files/patch-create_compressed_fs.c b/sysutils/cloop-utils/files/patch-create_compressed_fs.c
deleted file mode 100644
index d974375dc72f..000000000000
--- a/sysutils/cloop-utils/files/patch-create_compressed_fs.c
+++ /dev/null
@@ -1,57 +0,0 @@
---- create_compressed_fs.c.orig Sun Oct 26 05:15:22 2003
-+++ create_compressed_fs.c Tue Jan 20 03:37:34 2004
-@@ -18,7 +18,30 @@
- #include <stdlib.h>
- #include <string.h>
- #include <sys/stat.h>
-+#if defined(__FreeBSD__)
-+#include <sys/endian.h>
-+#include <netinet/in.h>
-+typedef uint64_t loff_t;
-+#ifndef htobe64
-+static __inline __uint64_t
-+__bswap64(__uint64_t _x)
-+{
-+
-+ return ((_x >> 56) | ((_x >> 40) & 0xff00) | ((_x >> 24) & 0xff0000) |
-+ ((_x >> 8) & 0xff000000) | ((_x << 8) & ((__uint64_t)0xff << 32)) |
-+ ((_x << 24) & ((__uint64_t)0xff << 40)) |
-+ ((_x << 40) & ((__uint64_t)0xff << 48)) | ((_x << 56)));
-+}
-+#if BYTE_ORDER == LITTLE_ENDIAN
-+#define htobe64(x) __bswap64(x)
-+#else
-+#define htobe64(x)
-+#endif
-+#endif
-+#define __cpu_to_be64 htobe64
-+#else
- #include <asm/byteorder.h>
-+#endif
- #include <fcntl.h>
- #include <zlib.h>
- #include "compressed_loop.h"
-@@ -195,6 +218,23 @@
- cbp=cbp->next;
- free(compressed_blocks); compressed_blocks=cbp;
- }
-+#if defined(__FreeBSD__)
-+ /*
-+ * FreeBSD requires padding to 512 byte boundary
-+ */
-+ bytes_so_far = lseek(STDOUT_FILENO, 0, SEEK_END);
-+ if (bytes_so_far % 512)
-+ {
-+ static char padding[512];
-+ off_t len = 512 - bytes_so_far % 512;
-+
-+ if (write(STDOUT_FILENO, padding, len) != len)
-+ {
-+ perror("writing padding block");
-+ return 1;
-+ }
-+ }
-+#endif
- fprintf(stderr,"Done.\n");
- return 0;
- }
diff --git a/sysutils/cloop-utils/files/patch-extract_compressed_fs.c b/sysutils/cloop-utils/files/patch-extract_compressed_fs.c
deleted file mode 100644
index 551ab3ac1290..000000000000
--- a/sysutils/cloop-utils/files/patch-extract_compressed_fs.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- extract_compressed_fs.c.orig Sun Oct 26 04:57:09 2003
-+++ extract_compressed_fs.c Mon Jan 19 05:28:47 2004
-@@ -8,7 +8,30 @@
- #include <errno.h>
- #include <string.h>
- #include <zlib.h>
-+#if defined(__FreeBSD__)
-+#include <sys/endian.h>
-+#include <netinet/in.h>
-+typedef uint64_t loff_t;
-+#ifndef be64toh
-+static __inline __uint64_t
-+__bswap64(__uint64_t _x)
-+{
-+
-+ return ((_x >> 56) | ((_x >> 40) & 0xff00) | ((_x >> 24) & 0xff0000) |
-+ ((_x >> 8) & 0xff000000) | ((_x << 8) & ((__uint64_t)0xff << 32)) |
-+ ((_x << 24) & ((__uint64_t)0xff << 40)) |
-+ ((_x << 40) & ((__uint64_t)0xff << 48)) | ((_x << 56)));
-+}
-+#if BYTE_ORDER == LITTLE_ENDIAN
-+#define be64toh(x) __bswap64(x)
-+#else
-+#define be64toh(x)
-+#endif
-+#endif
-+#define __be64_to_cpu be64toh
-+#else
- #include <asm/byteorder.h>
-+#endif
- #include "compressed_loop.h"
-
- struct compressed_block
diff --git a/sysutils/cloop-utils/pkg-plist b/sysutils/cloop-utils/pkg-plist
deleted file mode 100644
index ecc556caea0b..000000000000
--- a/sysutils/cloop-utils/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/create_compressed_fs
-bin/extract_compressed_fs