aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cloudabi-utils
diff options
context:
space:
mode:
authorEd Schouten <ed@FreeBSD.org>2015-07-13 12:26:40 +0000
committerEd Schouten <ed@FreeBSD.org>2015-07-13 12:26:40 +0000
commit4269d185f796ee1420d33c0876249236c5572e29 (patch)
treecf46f11e2243893342af5534ee533a5dc4cc00b4 /sysutils/cloudabi-utils
parent64ea2c29f9764d78d7e38d497fe0873d99945f4f (diff)
downloadports-4269d185f796ee1420d33c0876249236c5572e29.tar.gz
ports-4269d185f796ee1420d33c0876249236c5572e29.zip
Notes
Diffstat (limited to 'sysutils/cloudabi-utils')
-rw-r--r--sysutils/cloudabi-utils/Makefile37
-rw-r--r--sysutils/cloudabi-utils/distinfo2
-rw-r--r--sysutils/cloudabi-utils/pkg-descr11
3 files changed, 50 insertions, 0 deletions
diff --git a/sysutils/cloudabi-utils/Makefile b/sysutils/cloudabi-utils/Makefile
new file mode 100644
index 000000000000..feec0fc99b78
--- /dev/null
+++ b/sysutils/cloudabi-utils/Makefile
@@ -0,0 +1,37 @@
+# Created by: Ed Schouten <ed@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cloudabi-utils
+PORTVERSION= 0.2
+CATEGORIES= sysutils
+MASTER_SITES= https://nuxi.nl/distfiles/cloudabi-utils/
+
+MAINTAINER= ed@FreeBSD.org
+COMMENT= Utilities for running CloudABI programs
+
+LICENSE= BSD2CLAUSE
+
+BUILD_DEPENDS= cloudabi-toolchain>=0:${PORTSDIR}/devel/cloudabi-toolchain
+LIB_DEPENDS= libyaml.so:${PORTSDIR}/textproc/libyaml
+
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= CloudABI has not yet been ported to other architectures
+
+USES= tar:xz
+
+PLIST_FILES= bin/cloudabi-run \
+ libexec/cloudabi-reexec \
+ man/man1/cloudabi-run.1.gz
+
+do-build:
+ @cd ${WRKSRC} && \
+ PREFIX=${LOCALBASE} \
+ CLOUDABI_CC=${LOCALBASE}/bin/x86_64-unknown-cloudabi-cc \
+ ${SH} build
+
+do-install:
+ @cd ${WRKSRC} && \
+ PREFIX=${STAGEDIR}${PREFIX} \
+ ${SH} install
+
+.include <bsd.port.mk>
diff --git a/sysutils/cloudabi-utils/distinfo b/sysutils/cloudabi-utils/distinfo
new file mode 100644
index 000000000000..bfc2176359dc
--- /dev/null
+++ b/sysutils/cloudabi-utils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cloudabi-utils-0.2.tar.xz) = 210a15563d7019597b5a5a1b171803c23b4aa57c6fb9bab138d033232710f90e
+SIZE (cloudabi-utils-0.2.tar.xz) = 12704
diff --git a/sysutils/cloudabi-utils/pkg-descr b/sysutils/cloudabi-utils/pkg-descr
new file mode 100644
index 000000000000..388a1071063c
--- /dev/null
+++ b/sysutils/cloudabi-utils/pkg-descr
@@ -0,0 +1,11 @@
+Nuxi CloudABI is an application binary interface for UNIX-like operating
+systems built around the concept of capability-based security. In a
+nutshell, it means that you can run processes directly on top of a UNIX
+kernel while keeping complete control over the actions the process is
+allowed to perform.
+
+This package installs utilities that are useful when running CloudABI
+processes. The cloudabi-run utility can run CloudABI processes,
+providing it the resources (sockets and files) that it requires.
+
+WWW: https://github.com/NuxiNL/cloudabi-utils