aboutsummaryrefslogtreecommitdiff
path: root/sysutils/coaster/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-04-19 17:18:30 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-04-19 17:18:30 +0000
commit87f19cea80d17a094504433dd4f375de84d4a06b (patch)
tree26a9945a0571d577c4db780666a1346be31698b3 /sysutils/coaster/Makefile
parent3594c0fb73e48ebbc688f976653172c0ebd2ad0a (diff)
Notes
Diffstat (limited to 'sysutils/coaster/Makefile')
-rw-r--r--sysutils/coaster/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/sysutils/coaster/Makefile b/sysutils/coaster/Makefile
index 1570bdd33340..4ca99e149633 100644
--- a/sysutils/coaster/Makefile
+++ b/sysutils/coaster/Makefile
@@ -27,13 +27,22 @@ USE_GCC= 3.4
USE_GMAKE= yes
USE_X_PREFIX= yes
INSTALLS_OMF= yes
-USE_LIBTOOL_VER=15
+USE_INC_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
DOCS= AUTHORS COPYING ChangeLog NEWS README TODO
GCONF_SCHEMAS= coaster.schemas
+patch-autotools:
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
post-install:
@-update-desktop-database
.ifndef (NOPORTDOCS)