aboutsummaryrefslogtreecommitdiff
path: root/sysutils/condor/files
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2014-02-07 14:50:49 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2014-02-07 14:50:49 +0000
commit62c65f2797ac7b94a9257774c0bda8f471cc9716 (patch)
tree305d13d513c5874b979007a5dee900e3a5aa3686 /sysutils/condor/files
parent7c527c0183a8123262c3d8c540a9dff88ce846d5 (diff)
Notes
Diffstat (limited to 'sysutils/condor/files')
-rw-r--r--sysutils/condor/files/patch-build-cmake-CondorPackageConfig.cmake6
-rw-r--r--sysutils/condor/files/patch-build-cmake-macros-SystemSpecificInformations.cmake8
-rw-r--r--sysutils/condor/files/patch-src-condor_includes-config.h.cmake4
-rw-r--r--sysutils/condor/files/patch-src-condor_scripts-CMakeLists.txt11
4 files changed, 9 insertions, 20 deletions
diff --git a/sysutils/condor/files/patch-build-cmake-CondorPackageConfig.cmake b/sysutils/condor/files/patch-build-cmake-CondorPackageConfig.cmake
index 2f1cec5b3604..86891e9cf411 100644
--- a/sysutils/condor/files/patch-build-cmake-CondorPackageConfig.cmake
+++ b/sysutils/condor/files/patch-build-cmake-CondorPackageConfig.cmake
@@ -1,11 +1,11 @@
---- build/cmake/CondorPackageConfig.cmake.orig 2012-01-17 10:53:14.000000000 -0600
-+++ build/cmake/CondorPackageConfig.cmake 2012-04-07 14:37:17.000000000 -0500
+--- build/cmake/CondorPackageConfig.cmake.orig 2013-09-19 15:12:10.000000000 -0500
++++ build/cmake/CondorPackageConfig.cmake 2013-10-20 12:04:52.000000000 -0500
@@ -1,3 +1,4 @@
+
###############################################################
#
# Copyright 2011 Red Hat, Inc.
-@@ -144,6 +145,23 @@
+@@ -170,6 +171,23 @@
# enable if we desire native packaging.
# set ( CPACK_GENERATOR "${CPACK_GENERATOR};PackageMaker" ) ;
# set (CPACK_OSX_PACKAGE_VERSION)
diff --git a/sysutils/condor/files/patch-build-cmake-macros-SystemSpecificInformations.cmake b/sysutils/condor/files/patch-build-cmake-macros-SystemSpecificInformations.cmake
index 14ace26f71fd..35231aeff59c 100644
--- a/sysutils/condor/files/patch-build-cmake-macros-SystemSpecificInformations.cmake
+++ b/sysutils/condor/files/patch-build-cmake-macros-SystemSpecificInformations.cmake
@@ -1,6 +1,6 @@
---- build/cmake/macros/SystemSpecificInformations.cmake.orig 2012-01-17 16:53:14.000000000 +0000
-+++ build/cmake/macros/SystemSpecificInformations.cmake 2012-05-06 17:29:25.053492551 +0100
-@@ -230,7 +230,8 @@
+--- build/cmake/macros/SystemSpecificInformations.cmake.orig 2013-09-19 15:12:10.000000000 -0500
++++ build/cmake/macros/SystemSpecificInformations.cmake 2013-10-20 12:04:52.000000000 -0500
+@@ -241,7 +241,8 @@
endif(EXISTS "/etc/issue")
elseif(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
@@ -10,7 +10,7 @@
set( FREEBSD_RELEASE "${CMAKE_MATCH_1}" )
set( FREEBSD_MAJOR "${CMAKE_MATCH_2}" )
set( FREEBSD_MINOR "${CMAKE_MATCH_3}" )
-@@ -248,6 +249,11 @@
+@@ -259,6 +260,11 @@
set( CONDOR_FREEBSD7 ON )
elseif(FREEBSD_MAJOR MATCHES "8" )
set( CONDOR_FREEBSD8 ON )
diff --git a/sysutils/condor/files/patch-src-condor_includes-config.h.cmake b/sysutils/condor/files/patch-src-condor_includes-config.h.cmake
index 88247d6f3c30..a46f8e5a772d 100644
--- a/sysutils/condor/files/patch-src-condor_includes-config.h.cmake
+++ b/sysutils/condor/files/patch-src-condor_includes-config.h.cmake
@@ -1,5 +1,5 @@
---- src/condor_includes/config.h.cmake.orig 2012-01-17 10:53:14.000000000 -0600
-+++ src/condor_includes/config.h.cmake 2012-04-07 14:37:17.000000000 -0500
+--- src/condor_includes/config.h.cmake.orig 2013-09-19 15:12:10.000000000 -0500
++++ src/condor_includes/config.h.cmake 2013-10-20 12:04:52.000000000 -0500
@@ -47,6 +47,8 @@
#cmakedefine CONDOR_FREEBSD7
///* Define if on FreeBSD 8 */
diff --git a/sysutils/condor/files/patch-src-condor_scripts-CMakeLists.txt b/sysutils/condor/files/patch-src-condor_scripts-CMakeLists.txt
deleted file mode 100644
index 611975916f63..000000000000
--- a/sysutils/condor/files/patch-src-condor_scripts-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/condor_scripts/CMakeLists.txt.orig 2012-01-17 10:53:14.000000000 -0600
-+++ src/condor_scripts/CMakeLists.txt 2012-04-07 14:37:17.000000000 -0500
-@@ -30,8 +30,6 @@
- if (WANT_FULL_DEPLOYMENT)
- install ( FILES condor_configure DESTINATION ${C_SBIN} PERMISSIONS ${CONDOR_SCRIPT_PERMS} )
- install ( FILES condor_configure DESTINATION ${C_SBIN} RENAME condor_install PERMISSIONS ${CONDOR_SCRIPT_PERMS} )
-- install ( CODE "EXECUTE_PROCESS(COMMAND ${CMAKE_COMMAND} -E create_symlink ./sbin/condor_install \${CMAKE_INSTALL_PREFIX}/condor_install)" )
-- install ( CODE "EXECUTE_PROCESS(COMMAND ${CMAKE_COMMAND} -E create_symlink ./sbin/condor_configure \${CMAKE_INSTALL_PREFIX}/condor_configure)" )
- endif(WANT_FULL_DEPLOYMENT)
-
- install ( FILES condor_ssh sshd.sh DESTINATION ${C_LIBEXEC} PERMISSIONS ${CONDOR_SCRIPT_PERMS} )