aboutsummaryrefslogtreecommitdiff
path: root/sysutils/conky
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-20 16:14:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-20 16:14:11 +0000
commit9d7f84a6282600a10102fabb4d7220f773a95825 (patch)
tree93f13ab56135d4327e6e87196570e81d2e65b8f0 /sysutils/conky
parentb8bfe27fd3f308648fcae2b69bb896d072511f55 (diff)
downloadports-9d7f84a6282600a10102fabb4d7220f773a95825.tar.gz
ports-9d7f84a6282600a10102fabb4d7220f773a95825.zip
Notes
Diffstat (limited to 'sysutils/conky')
-rw-r--r--sysutils/conky/Makefile1
-rw-r--r--sysutils/conky/files/patch-src-bmpx.c60
-rw-r--r--sysutils/conky/files/patch-src-bmpx.h42
3 files changed, 103 insertions, 0 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index cc8b30cbb362..17173562072a 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -7,6 +7,7 @@
PORTNAME= conky
PORTVERSION= 1.7.2
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF
diff --git a/sysutils/conky/files/patch-src-bmpx.c b/sysutils/conky/files/patch-src-bmpx.c
new file mode 100644
index 000000000000..895c8675c1f0
--- /dev/null
+++ b/sysutils/conky/files/patch-src-bmpx.c
@@ -0,0 +1,60 @@
+--- src/bmpx.c.orig 2009-09-23 22:02:33.000000000 +0300
++++ src/bmpx.c 2009-09-23 22:03:54.000000000 +0300
+@@ -41,7 +41,7 @@
+ static int connected = 0;
+ static char *unknown = "unknown";
+
+-void fail(GError *error);
++void fail(GError *error, struct information *);
+
+ void update_bmpx()
+ {
+@@ -57,15 +57,15 @@
+ bus = dbus_g_bus_get(DBUS_BUS_SESSION, &error);
+ if (bus == NULL) {
+ ERR("BMPx error 1: %s\n", error->message);
+- fail(error);
++ fail(error, current_info);
+ return;
+ }
+
+ remote_object = dbus_g_proxy_new_for_name(bus, BMP_DBUS_SERVICE,
+- BMP_DBUS_PATH, BMP_DBUS_INTERFACE);
++ BMP_DBUS_PATH__BMP, BMP_DBUS_INTERFACE__BMP);
+ if (!remote_object) {
+ ERR("BMPx error 2: %s\n", error->message);
+- fail(error);
++ fail(error, current_info);
+ return;
+ }
+
+@@ -77,7 +77,7 @@
+ G_TYPE_INVALID, G_TYPE_INT, &current_track, G_TYPE_INVALID)) {
+ } else {
+ ERR("BMPx error 3: %s\n", error->message);
+- fail(error);
++ fail(error, current_info);
+ return;
+ }
+
+@@ -111,17 +111,17 @@
+ g_value_get_string(g_hash_table_lookup(metadata, "location"));
+ } else {
+ ERR("BMPx error 4: %s\n", error->message);
+- fail(error);
++ fail(error, current_info);
+ return;
+ }
+
+ g_hash_table_destroy(metadata);
+ } else {
+- fail(error);
++ fail(error, current_info);
+ }
+ }
+
+-void fail(GError *error)
++void fail(GError *error, struct information *current_info)
+ {
+ if (error) {
+ g_error_free(error);
diff --git a/sysutils/conky/files/patch-src-bmpx.h b/sysutils/conky/files/patch-src-bmpx.h
new file mode 100644
index 000000000000..0bb5e98c6a77
--- /dev/null
+++ b/sysutils/conky/files/patch-src-bmpx.h
@@ -0,0 +1,42 @@
+--- src/bmpx.h.orig 2009-09-23 22:04:47.000000000 +0300
++++ src/bmpx.h 2009-09-23 22:02:05.000000000 +0300
+@@ -0,0 +1,39 @@
++/* -*- mode: c; c-basic-offset: 4; tab-width: 4; indent-tabs-mode: t -*-
++ * vim: ts=4 sw=4 noet ai cindent syntax=c
++ *
++ * Conky, a system monitor, based on torsmo
++ *
++ * Please see COPYING for details
++ *
++ * Copyright (c) 2005-2009 Brenden Matthews, Philip Kovacs, et. al.
++ * (see AUTHORS)
++ * All rights reserved.
++ *
++ * This program is free software: you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License as published by
++ * the Free Software Foundation, either version 3 of the License, or
++ * (at your option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ * GNU General Public License for more details.
++ * You should have received a copy of the GNU General Public License
++ * along with this program. If not, see <http://www.gnu.org/licenses/>.
++ *
++ */
++
++#ifndef BMPX_H_
++#define BMPX_H_
++
++void update_bmpx(void);
++struct bmpx_s {
++ char *title;
++ char *artist;
++ char *album;
++ char *uri;
++ int bitrate;
++ int track;
++};
++
++#endif /*BMPX_H_*/